LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ATI Mobility Radeon!!! (http://www.linuxquestions.org/questions/linux-hardware-18/ati-mobility-radeon-54239/)

dellcom1800 04-09-2003 02:01 PM

ATI Mobility Radeon!!!
 
I have installed UT2003. i however can not get it to run do to the following error:

Couldn't ser video mode: Couldn't find matching GLX visual


History:

Exiting due to error


i assume this has to do with a driver problem but i can not be sure (also i can not enable 3D Acceleration in my display properties either which makes me more suspicious of a driver problem)
i have checked with the ATI website and they tell me to go to the vender's site (in this case DELL) which i do but there is no Linux driver for my graphics card at this time...

is there any way i can get around this???

Wolven 04-09-2003 02:40 PM

What model dell do you have?
The proper drivers for your card are on the ATI site. You just need to get the ones for the right chipset. There is very little difference in them, as it is. Let me know which you have, and I'll try to get you the specific ones you need, and get you running some UT happiness.

rpg 06-10-2003 01:21 PM

I just tried to follow your advice, since I have an ATI mobility Radeon M6 in my Gateway. But when I went to the ATI web site and tried to find Mobility drivers for linux, they just said that the drivers have to be optimized for your display, go pester your laptop vendor. But of course Gateway doesn't want to hear from linux. Any alternate suggestions?

marshmellowman 06-10-2003 04:42 PM

what version of XF86 are u using
what distrabution of linux

rpg 06-10-2003 08:25 PM

I'm using Mandrake 9.1. I think that's XFree86-4.3:

rpm --query XFree86

gives me

XFree86-4.3-5mdk

My XF86-Config has a "Device" section with

Driver "radeon" in it.

I note that there's a kernel module radeonfb.o

hunter0000 08-25-2003 06:53 PM

ati mobility (m6) 3d doesn't work.
 
To the person who mentiond that their gateway with an ati mobiility 6 chip doesn't do 3d.

This is correct. xfree 4.3 SAYS it supports 3d, but this isincorrect.

I even recompiled DRI with mach64 3d server(what dri says will allow you to get 3d accel out of a ati mobility chip), but no dice. glxinfo still returns no 3d accelleration.

I have a gateway model "400sd4" laptop. If anyone has gotten 3d accelleration out of a ati rage mobility chip, please let meknow how.

rpg 08-25-2003 09:40 PM

Radeon Mobility problems
 
I don't need, or even especially want 3D from my mobility. I'd settle for it not getting all screwed up when I put it in standby mode.

godzuki 09-04-2003 05:29 PM

Re: ati mobility (m6) 3d doesn't work.
 
Quote:

Originally posted by hunter0000
To the person who mentiond that their gateway with an ati mobiility 6 chip doesn't do 3d.

This is correct. xfree 4.3 SAYS it supports 3d, but this isincorrect.

I even recompiled DRI with mach64 3d server(what dri says will allow you to get 3d accel out of a ati mobility chip), but no dice. glxinfo still returns no 3d accelleration.

I have a gateway model "400sd4" laptop. If anyone has gotten 3d accelleration out of a ati rage mobility chip, please let meknow how.

I think you might find this usefull:

http://forums.gentoo.org/viewtopic.p...e+acceleration

h1tman 09-04-2003 10:24 PM

what if i have slackware?how do i use the gentoo trick?

Mad Merlin 09-04-2003 11:21 PM

Try using a newer kernel if your current one doesn't support/recognize some of your hardware, otherwise grab the DRI packages from http://dri.sourceforge.net/ and that should help out.

h1tman 09-05-2003 10:58 AM

i will test out later thanks bro.


All times are GMT -5. The time now is 11:28 PM.