LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ATI fglrx driver expands screen size (http://www.linuxquestions.org/questions/linux-hardware-18/ati-fglrx-driver-expands-screen-size-761203/)

Pakhomov 10-11-2009 03:34 PM

ATI fglrx driver expands screen size
 
1 Attachment(s)
I have notebook ASUS A8Sr with ATI HD2400 video card (monitor of notebook has size 1280x800). And Linux Slackware64 13.0 with kernel 2.6.28.5 (x86_64 smp) updated from Slamd64.
After I installed newest ATI fglrx driver (version 9.9). All things work. But screen size (virtual screen of course) become more large - 2560x800 - in two times. And first part (x=0..1280) as a normal screen, but second part (with x=1281..2560) like black hole - black color with invisible desktop items.

Code:

myhost:$ xrandr
Screen 0: minimum 320 x 200, current 2560 x 800, maximum 2560 x 800
default connected 1280x800+0+0 0mm x 0mm
  2560x800      60.0 
  1280x800      60.0*
  1280x768      60.0 
  1280x720      60.0 
  1024x768      60.0 
  800x600        60.0 
  720x480        60.0 
  640x480        60.0 
  640x432        60.0 
  640x400        60.0 
  512x384        60.0 
  400x300        60.0 
  320x240        60.0 
  320x200        60.0

I note that selected "1280x800" mode in this list, but in head write "current 2560 x 800"

I have not any virtual screen in xorg.conf, but have option "PreferredMode"
Code:

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1280x800"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID      "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth    24
        SubSection "Display"
                Modes  "1280x800"
        EndSubSection
EndSection

I try setting option "Virtual 1280 800" but not work.

It is part of Xorg.0.log
Code:

(II) LoadModule: "fglrx"
(II) Loading /usr/lib64/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.4.99.906, module version = 8.65.4
        Module class: X.Org Video Driver

(--) Chipset Supported AMD Graphics Processor (0x94C9) found

(**) fglrx(0): Center Mode is disabled
(==) fglrx(0): TMDS coherent mode is enabled
(II) fglrx(0): Total of 13 modes found for primary display.
(--) fglrx(0): Virtual size is 1280x800 (pitch 0)

(--) fglrx(0): Display dimensions: (300, 190) mm
(--) fglrx(0): DPI set to (108, 106)
(--) fglrx(0): Virtual size is 2560x800 (pitch 2560)

(WW) fglrx(0): Option "PreferredMode" is not used 
(WW) fglrx(0): Option "VendorName" is not used     
(WW) fglrx(0): Option "ModelName" is not used     

(II) fglrx(0): Restoring recent mode: 1280x800@60Hz

Whole log file in attach.

This is problem with fglrx driver only. Radeon driver work fine.

How I can remove virtual screen "2560x800"?

AwesomeMachine 10-11-2009 06:00 PM

Take this and copy and paste it into xorg.conf, in subsection display, underneath Mode:

Modeline "1280x800"x60.0 68.94 1280 1292 1356 1408 800 803 806 816 +hsync +vsync

You can also shut down X, and run:

X -configure

from a terminal. The command will give you instructions. If the new xorg.conf works, you will get a textured background when you test it with:

X -config /home/sam/xorg.conf.new

The new xorg.conf will be more complete, and you can then add what you need from the existing xorg.conf. But adding the modeline to the existing xorg.conf will probably work. Try it first.

Shadow_7 10-12-2009 10:01 AM

You might try adding that parameter for virtual screen at the resolution you want to use. 1280x800. Or wait six months for the next update and it'll fix itself? ATI drivers are.... frustrating.

Code:

        SubSection "Display"
                Depth  24
                Virtual "1280x800"
                Modes  "1280x800"
        EndSubSection

Or run ati-config against your current xorg.conf and see if it knows how to fix itself. Or a fresh xorg.conf "X -configure" and ati-config against that.

Taking a second look at your conf, you're missing the Depth argument for your Modes. Just adding that might help, or might otherwise be the issue. Virtual is a bit redundant. Although isn't it supposed to not use/do virtual if you don't specify it?


All times are GMT -5. The time now is 05:30 PM.