LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-25-2005, 04:34 AM   #1
ssobeht
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 207

Rep: Reputation: 30
Ati Fglrx amd64 latest drivers + 2.6.13 kernel problem


Hi,

I installed these drivers
http://www.stanchina.net/~flavio/deb...installer.html
but this is what I get when doing modprobe:

Code:
debian:/home/raskolnikov# modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.13-juampe/misc/fglrx.ko): No such device
And this is what dmesg shows
Code:
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 20
Trying to register duplicated ioctl32 handler c0246400
[fglrx:firegl_init_32compat_ioctls] *ERROR* unable to register ioctl32 0
[fglrx:firegl_init] *ERROR* Couldn't register compat32 ioctls!
Using self-compiled 2.6.13.4 kernel and GCC 4.0

Any suggestions?
 
Old 10-26-2005, 02:11 PM   #2
ronald-be
Member
 
Registered: Aug 2004
Location: Belgium
Distribution: debian 5.02
Posts: 73

Rep: Reputation: 15
hi,

did you install a 32-bit or a 64-bit version of your distro? seems you have both versions in your library. Did it compile without errors? do you have a driver in /lib AND in /lib64? Please let me know?

greetings,

ronald-be
 
Old 10-26-2005, 03:27 PM   #3
ssobeht
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 207

Original Poster
Rep: Reputation: 30
How stupid i am. I forgot to unload the radeon module lol.

After that i had to recompile the kernel with no DRI and now evrything is working.

Thanx!
 
Old 11-18-2005, 07:01 AM   #4
nazdrowie
Member
 
Registered: Oct 2004
Distribution: Debian
Posts: 39

Rep: Reputation: 15
I've followed the instructions from http://www.linux-laptop.net/hosted/r4000-gentoo.html (downloading the proprietary ati drivers, etc.) to try to set up the X server on my laptop but even though I can ran the basic X window manager (with the 3 xterms and a clock), I'm getting the same error that ssobeht was getting after returning to the console from my primitive X session:
Code:
FATAL: Error inserting fglrx (/lib/modules/2.6.13-gentoo-r5/video/fglrx.ko): No such device
[drm] failed to load kernel module "fglrx"
FATAL: Error inserting fglrx (/lib/modules/2.6.13-gentoo-r5/video/fglrx.ko): No such device
[drm] failed to load kernel module "fglrx"
(EE) fglrx(0): DRIScreenInit failed!
What to do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2 and fglrx (ATI Drivers) cythrawll Slackware 7 10-18-2005 06:44 PM
Problem with ATI fglrx drivers on mandriva2005 olkku486 Linux - Hardware 5 06-27-2005 07:10 AM
ATi fglrx drivers in Gentoo + kernel 2.6.10 vharishankar Linux - Distributions 1 03-08-2005 02:26 AM
ATI fglrx drivers being slow ben77 Linux - Hardware 2 10-01-2004 04:08 PM
Problem with fglrx module (ati-drivers-3.9.0-r1) with kernel 2.6.7 in Gentoo Mitchua Linux - Hardware 1 07-10-2004 09:36 PM


All times are GMT -5. The time now is 10:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration