LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-13-2004, 10:27 PM   #1
indiglopulse
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
ATI Drivers... stuck in Mesa.


Ok, First and foremost I'd like to apologize. I am new to linux, and I have googled my heart out for the past two days, and I have found many answers to my question, however I still can't get any of them to work. If anyone can offer something simpler or different than what is already out there it would be much appreciated. Now, my problem:

I am running an ATI 9700 on an ASUS P4S800-DE with P4 3.0 w/HT.
(EDIT) Running Mandrake 10.0 with Kernel 2.6

After much googling and my first linux learning experience, I was able to install the ATI drivers. (using sh make.sh, etc... the problem I had was the kernel source was not available so it could not construct the mod.. I got taht worked out and ran fglrxconfig no problem) This forum was very helpful in doing so. However, now that I have them installed they will not load. I know for a fact they have been installed correctly, but it continues to go back to Mesa SoftwareGL when i do fglrxinfo:

Code:
$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: <mesa-url>(can't post URL with less than 5 posts)
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
I read elsewhere that this can be caused by improper selection of resolution. So I ran fglrxconfig several times, trying various resolutions and settings, but to no avail. No matter what i do it is still going to Mesa. I also read somewhere that I can do "insmod" to get it to load the ATI module manually, but I am new to linux so I don't know how to do this, or what exactly it does. I also read that doing this won't load it automatically.



I also read somewhere that deleting the Mesa library altogether would do teh trick, but I don't trust my linux skills enough to do so. I checked the ATI support page, and they suggested I do rpm -e on the mesa library. But since i had already rpm -Uh --force the ATI drivers, this package didn't exist. It doesn't seem logical to me that it is using a package that doesn't exist.


Any insight would be helpful, even something I could google myself would be appreciated.

Thanks.

Last edited by indiglopulse; 11-13-2004 at 10:39 PM.
 
Old 11-14-2004, 02:07 AM   #2
H2O-linux
Member
 
Registered: Sep 2004
Location: Second ring of youranus
Distribution: debian testing
Posts: 153

Rep: Reputation: 30
ati thread
 
Old 11-14-2004, 02:29 AM   #3
indiglopulse
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 13

Original Poster
Rep: Reputation: 0
AGH. Once again this post doesn't help me.... like i said I am new to this, and that tutorial is for those running Slackware. I went to do it and discovered I can't perform their basic "rpm2tgz" command. Yes i'm a newbie, but I'm trying to learn... and it's rather difficult to do so if everything out there is not well explained. Thanks for the help nonetheless.

Last edited by indiglopulse; 11-14-2004 at 02:46 AM.
 
Old 11-14-2004, 03:07 PM   #4
steve_d555
Member
 
Registered: Apr 2004
Location: Massachusetts
Distribution: Debian, Slack 10, Gentoo!
Posts: 87

Rep: Reputation: 15
Are you using Xorg or Xfree? And try insmod fglrx, that will manually load the Fglrx driver. You should also look at step 11 if you are using Xorg.

--Steve
 
Old 11-14-2004, 03:13 PM   #5
indiglopulse
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 13

Original Poster
Rep: Reputation: 0
I am using XFree86. I will try the insmod, but how do I get it to do that automatically? (if it does work)

EDIT: it is XFree version 4.3

Last edited by indiglopulse; 11-14-2004 at 03:15 PM.
 
Old 11-14-2004, 05:08 PM   #6
steve_d555
Member
 
Registered: Apr 2004
Location: Massachusetts
Distribution: Debian, Slack 10, Gentoo!
Posts: 87

Rep: Reputation: 15
Not sure about mandrake but for Gentoo its /etc/modules.autoload.d/kernel-2.x
 
Old 11-14-2004, 05:26 PM   #7
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
post your /etc/X11/XF86Config-4 here. Have you adjusted the settings in that? Also post you /var/log/XFree.0.log file. I use xorg on my computer if you do it will be more like /etc/X11/xorg.conf and /var/log/Xorg.0.log
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing MESA drivers AnoobiS Slackware 1 12-01-2005 12:32 PM
Ati Drivers totally stuck just_dan Linux - Newbie 1 09-16-2005 02:40 PM
mesa dri or ati proprietatry drivers? shanenin Linux - Software 1 07-08-2004 04:49 AM
ATI FireGL Drivers for WineX, Uninstalling mesa? Aeiri Linux - Software 2 04-10-2004 02:53 PM
How to force ATI GLX instead of Mesa jjcohen Red Hat 3 02-10-2004 05:10 AM


All times are GMT -5. The time now is 05:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration