LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-16-2007, 12:35 PM   #1
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 716

Rep: Reputation: 81
ATI drivers & Xen


Hi
Did anybody manage to make the proprietary ATI drivers work with Xen?
I am using ATI drivers version 8.39.4 with Xen 3.1.0, but each time I try to load the fglrx module I get in dmesg the error message "fglrx: Unknown symbol flush_tlb_page" and the module doesn't load.
I tried to "google" but didn't find anything interesting. Any clue? Thanks... .
 
Old 11-16-2007, 07:15 PM   #2
Willy Gommel
LQ Newbie
 
Registered: Nov 2007
Posts: 28

Rep: Reputation: 1
I am a Debian user. In poking through the documents in my FGLRX module area, I find the following notation:

"fglrx-driver (8.28.8-4) unstable; urgency=low

* Add patch 12-CONFIG_X86_XEN to allow building on Xen-enabled kernels;
thanks to Loic Minier.
(Closes: #368802)"

Hope this helps you out.
 
Old 12-27-2007, 04:28 PM   #3
Pearlseattle
Member
 
Registered: Aug 2007
Location: Switzerland
Distribution: Gentoo
Posts: 716

Original Poster
Rep: Reputation: 81
I know, but it does not work, sniff sniff...
Anyway, thank you.
 
Old 09-06-2008, 07:38 AM   #4
mad4linux
Member
 
Registered: Aug 2003
Distribution: Debian Testing / kubuntu
Posts: 86

Rep: Reputation: 21
Issue remains: Etch n half, amd64, Xen, ATI 3D

Still the same problem with Xen Kernels and ati driver.
I'm using this kernel:
vmlinuz-2.6.18-6-xen-amd64

and trying to load this fglrx-module:
fglrx-kernel-2.6.18-6-xen-amd64 (8.28.8-4+2.6.18.dfsg.1-22etch2)

Code:
mesg | grep fglrx
gives this output:

Code:
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
fglrx: Unknown symbol flush_tlb_page
fglrx: Unknown symbol flush_tlb_page
Does anybody know anything helpful on how to fix this? I need 3D hardware accel for blender. Without i'll have to set up my system again without xen.

I also tried to apply the patch mentioned in this tread before. But it seems, that it is already done. Patch gives me the following output:

Code:
patching file firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] n
Apply anyway? [n] n
Skipping patch.
patch: **** malformed patch at line 18:

Last edited by mad4linux; 09-06-2008 at 08:26 AM. Reason: text added
 
  


Reply

Tags
debian, fglrx, xen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9600Pro & ATI Proprietary Drivers problem Hyakutake Slackware 6 12-04-2005 11:08 AM
Fedora 4 & ATI Drivers Fedux Linux - Newbie 5 11-01-2005 03:36 PM
ATI drivers & SuSe 9.2 make Suse/Novell 3 11-12-2004 09:16 AM
New ATI drivers & tv apps agalias Linux - Software 3 10-22-2003 04:21 PM
ATI Drivers & Safeguarding zuele Linux - Hardware 0 10-06-2003 07:39 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration