LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 06-15-2009, 01:10 PM   #1
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Rep: Reputation: 18
ATI driver install - monitor out-of-range


Hi,

I have tried installing the ATi drivers via the 1-click install process, however when I get to init 3 and try to run sax2 (sax2 -r -m 0=fglrx) my monitor just goes out of range.

I have tried this in both OpenSuSE 11.1 and 11.0 - both the same.

I have tried running sax2 with the -l switch for low resolution - no change.

I have also tried the switch "--vesa 0:800x600@60" and "--vesa 0:1024x768@60" which are known resolutions/requencies that this monitor supports (the latter is the native resolution) - no change.

I have tried another monitor but it's exactly the same.

My video card is an ATi Radeon HD2600AGP and is correctly identified by OpenSuSE, and displays video fine using the default driver.

Anyone have any suggestions please? Any help much appreciated.

Code:
kieren@ideq-suse:~> glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_get_proc_address, GLX_ARB_multisample,
    GLX_EXT_import_context, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_MESA_allocate_memory, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_NV_swap_group, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier, GLX_SGIX_swap_group,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_swap_barrier, GLX_EXT_texture_from_pixmap
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_program,
    GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_point_parameters,
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_draw_buffers, GL_ATI_texture_env_combine3,
    GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square,
    GL_NV_fragment_program, GL_NV_light_max_exponent, GL_NV_point_sprite,
    GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_NV_vertex_program,
    GL_NV_vertex_program1_1, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
    GL_SGIX_shadow, GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x60 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
Code:
ideq-suse:/home/kieren # sax2 -p
Chip: 0  is -> ATI ATI Radeon HD 2600 Pro AGP (RV630 9587) 01:00:0 0x1002 0x9587 AGP fglrx
 
Old 06-15-2009, 02:18 PM   #2
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
I have had mix results with sax2 in the past with ATI cards. Also, 1-Click Install is great when it works.

I too had my share of hurdles with my ATI GPU's over time. I tried all the solutions, but one always did it for me.

I always fixed my display problems using this simple method ot work properly. If not install it using OpenSuse YAST installer to install the package "fglrx".

2) This can be done in command line (init3) or GUI in a terminal.Make a backup copy of your xorg. Just to be on the safe side.

Code:
cp /etc/X11/xorg.conf xorg.conf.bak
3) Then

Code:
aticonfig --initial --input=/etc/X11/xorg.conf
The
Code:
--input
command is what makes the difference. Otherwise it may use the MESA driver instead and not modify xorg.conf at all.

4) Restart your X server with CTRL-ALT-BACKSPACE (In Suse you need to tap rapidly the key combination twice in a row for it to function.)

Or you can just reboot the system and it should commeback in GUI. Test if the fglrx fdriver is working in a terminal by typing:
Code:
fglrxinfo
 
Old 06-16-2009, 02:56 PM   #3
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
Hi, thanks for the suggestion. I tried this but no joy - as soon as I rebooted I got "out of range".

Unfortunely now I have no video in X at all. I have tried copying the xorg file back and then starting sax2 with various combinations of switches like -a, -l, --vesa 0:800x600@60, -m 0=radeonhd etc but no joy - I either get "out of range", "no input signal" or the system just hangs and I have to ctrl+C to get back to prompt. Sometimes the kernel seems to freeze too, and I have to use the reset button.

Is there a help manual for aticonfig? Perhaps with different settings I can get it working, but it reports there is no manual available, and typing aticonfig --help just spams my screen and I can only read the last few lines.
 
Old 06-16-2009, 06:02 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
I do not have the answer you require, only a suggestion:

ATI have historically provided poor support for linux. This is rumoured to be improving, but not much has happened yet it seems.

NVIDIA have partly risen to the challenge linux presents by offering closed source linux drivers for their hardware. To their credit, these are regularly updated and usually "just work".

In my experience these drivers work so well with linux that I will currently not buy any hardware that doesn't already have, or doesn't have the option to install ( eg a laptop or netbook ) an NVIDIA GPU. Otherwise it has always proven to be too much of a headache, and my time is limited.

So my suggestion is: Get an NVIDIA GPU. Install their (politically incorrect) closed source module and all should be sweet.

Eventually the other manufacturers may wake up to linux. Meanwhile I am happy to support (and "advertise" here for) the ones that do support linux. Hewlett Packard also gets a "thumbs up" here for their printer drivers for linux.

Every hit the hardware manufacturer's "Linux Drivers Download" page gets means they think .... "Oh! Maybe there is a growing market here. Maybe we should employ someone to support the purchasers of our hardware who are running linux".

It's a commercial thing:
"You pays your money and you makes your choice".

Or you can continue to bang your head against the wall.

Hope you get something sorted out to your satisfaction.
 
Old 06-17-2009, 06:30 AM   #5
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
Ati Drivers are very good since AMD purchased ATI. Problems with Nvidia also exist, has with any other hardware driver.

From what symptoms you seem to have they may be other prolems with your system besides drivers. Maybe the card is damaged or malfunctioning.

At this point, to get back to some GUI I woul suggest uninstalling the fglrx drivers and reverting to VESA.

If you have another GPU you could use just to test your system that would be great. Just a good old PCI graphic card would do. (I always keep one for emergencies)
 
Old 06-17-2009, 12:51 PM   #6
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
There are a couple of hardware avenues I can try, but this card worked pefectly under Suse 11.0 with the one-click install process before, and I only reinstalled after some hard drive problems I had before.

The only changes that have been made to the system besides the new HDD are I changed the AGP aperture from 128 to 256MB and I slowed the memory bus speed to 166 (333 as it's DDR1) to match the processor. I found that LOTRO was doing weird things under Windows when the mem was running at 200 (400) when the proc only has a 166FSB (sempron 2.8GHz).

I'll try changing the AGP aperture and perhaps change the mem bus speed back up to 200 and see if that changes anything. I have another vid card I can try which is nVidia, but it's an old GeForce4 Ti 4200 so graphics in LOTRO will be appauling.

I'll POST resutls if I get it working.

Edit: the affected system is a different one to the one in my sig

Last edited by khinch; 06-17-2009 at 12:52 PM. Reason: Update
 
Old 06-17-2009, 02:02 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Just out of curiosity, is there anything between the system and the monitor, like a KVM ?
 
Old 06-17-2009, 03:38 PM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
What does /var/log/Xorg.0.log have to say on the subject? It sounds like the fglrx install screwed up your monitor settings. You may need a VirtualX setting, (If still valid) or HorizSync & VertRefresh.

X will just throw out modes it doesn't like even if you specify them. I wonder what modes you have set?
 
Old 06-17-2009, 07:08 PM   #9
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
Good point, after your done testing with your old card to see that it's not your system that's causing problems look at your monitor settings and compare them with your monitor specifications.

You may see your problem lies with settings badly interpretted by the drivers and also completely out of range....Out of Range being the theme for this thread. Hahaha!
 
Old 06-20-2009, 12:40 PM   #10
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
Thanks for the suggestions. I have tried putting the AGP aperture back to 128MB and the memory bus speed back up to 200 but it was still the same, and these are the only differences since it worked perfectly with the FGLRX drivers before.

There are no KVMs or anything in the loop - just a DVI-VGA adapter and a VGA cable.

The monitor I have been using always seems to report itself as liking 68Hz refresh, which is visible but a bit garbled and dark. As soon as I manually select 60 or 75Hz it's fine. This happens with all linux distros and even Windows XP and 7, so the monitor must be reporting itself like that. Having said that, this fault happens with another monitor also, with a totally different VGA lead and DVI-VGA adapater.

Further to that, I experimented with installing Ubuntu 9.04 and then letting it install the FGLRX drivers automatically - same thing - as soon as it reboots, "out-of-range".

I'll get the output of /var/log/Xorg.0.log and post it up later, the difficulty being that once the fault has occurred I can only access the system at runlevel 3, so I'll have to save the output to USB stick and read it with a live distro or Windows7.

Out of interest, I did manage to get some output in 800x600 mode at one point, but stupidly hadn't logged whether it was FGLRX or radeonHD driver I used to get it, and then tried 1024x768 with the same command which borked the system so I couldn't check previous commands (had to press reset button).

I'll post any more results when I get them.

Edit: I forgot to mention, this card is an AGP Radeon HD2600pro, so it's quite a rare card. It could be that the more recent FGLRX drivers have broken compatibility, but I'll keep an open mind while testing.

Last edited by khinch; 06-20-2009 at 12:43 PM. Reason: Update
 
Old 06-20-2009, 03:57 PM   #11
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,615

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Serach your xorg.conf for a line with the words

HorizSync
VertRefresh

Set them (or put them in if they are not there)

HorizSync 31.5-55
VertRefresh 40 - 70

Even the most borked of old monitors will run on that

In your screen section, put in a line like after your chosen colour depth like

Modes "1024x768"

Even the most borked of old monitors will run on that
comment out any other modes lines, and try it. Rev up the settings afterwards.
 
Old 06-21-2009, 06:00 AM   #12
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
Well I have had some brief success - I managed to get a desktop working on fglrx driver, but it only worked until I rebooted for some reason. Here's what I did:

A fresh install of OpenSuSE 11.1 with all updates performed at install time. I then backed up my xorg.conf and Xorg.99.log, which are attached (xorg.conf.original.txt and Xorg99log_original.txt). I added the ATi repositories, downloaded the fglrx and pae kernel module, then switched to runlevel 3.

I have found (through experimentation) that sax2 only works after the "aticonfig --initial", which is strange I think. If I reboot straight after the aticonfig command I get out of range. So, I ran "aticonfig --initial" before backing up the Xorg.conf and Xorg99log again (first one attached as xorg.conf.aticonfig.txt - max files uploaded) and then "sax2 -r -l -m 0=fglrx". At this point I get a sax2 config screen at 800x600. If I attemt to change any of the settings at this stage I get no video again, so I left it unchanged and rebooted.

This worked, and I got a desktop running on fglrx at 800x600. I then ran amdcccle and the refresh rate was running at 72Hz for some reason. I set refresh to 60 as I know through Windows this monitor likes 60 or 75, and then changed resolution to 1024x768. This worked! And I got glxgears and xgl_glxgears scores of 3000+ and 600 respectively. The problem was as soon as I rebooted - out-of-range.

So, I know this card is capably of working correctly, I just need to find out how to convince it.

What could have changed between the reboot? Is there a config file I am missing?

I also have a couple of sax2 error logs and a Xorg99logto upload, but I have reached the 3file cap for this post.
Attached Files
File Type: txt xorg.conf.original.txt (4.5 KB, 4 views)
File Type: txt Xorg99log_original.txt (217.9 KB, 3 views)
File Type: txt xorg.conf.aticonfig.txt (4.8 KB, 2 views)
 
Old 06-21-2009, 11:58 AM   #13
Steel_J
Member
 
Registered: Oct 2004
Location: Montreal, Canada
Distribution: Kubuntu 10.04, Mint 8 and Puppy 4.3.1
Posts: 355
Blog Entries: 1

Rep: Reputation: 31
You xorg.conf is wrongly formatted.

As I mentionned before, stay away from sax2 or YAST to configure it. Only use Aticonfig, admcccle and manual editing of your xorg.conf file.

Everytime you use sax2 after aticonfig you modify the xorg created by aticonfig.

Now from what I understand you an recreate your success of 800x600 at will so:

Use aticonfig config again but with the option -f to force the creation of a new xorg file.
Quote:
aticonfig --initial -f
.Do this from init3 or lower.

Then reboot.

Do you know how to use VI or VIM command line text editors? Because that is the secret to fixing these problems. I have a little guide I can post for you that I keep around if you like. Let me know.

So you need to edit your xorg.conf with vim from the command line and test your setups by using startx to start the gui. You'll know when things are right.

2nd point; I read your xorg.conf and I see something completely out of place. This section:
Quote:
Section "Monitor"
Identifier "Monitor[0]"
VendorName "ADI"
UseModes "Modes[0]"
DisplaySize 304 228
HorizSync 30.0 - 62.0
VertRefresh 43.0 - 75.0
Option "DPMS"
Option "PreferredMode" "1024x768"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "radeonhd"
VendorName "ATI"
BoardName "ATI Radeon HD 2600 Pro AGP"
Option "monitor-DVI-I_2/analog" "Monitor[0]"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection
You have two section for everything!!! You have two device sections. One using the radeonhd open driver and the next is for fglrx. You cannot use both drivers in the conf file. You also have two screen sections which I did not quote; it has some virtual resolutions that are pretty high.

Here is an modified version of xorg.conf that i want you to try:
Quote:
# /.../
# SaX generated X11 config file
# Created on: 2009-06-20T22:47:03+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dri"
Load "dbe"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "gb"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech Optical Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1024x768" 81.8 1024 1080 1192 1360 768 769 772 802
ModeLine "1024x768" 76.2 1024 1080 1192 1360 768 769 772 800
ModeLine "1024x768" 69.7 1024 1080 1184 1344 768 769 772 798
ModeLine "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
ModeLine "800x600" 48.9 800 840 920 1040 600 601 604 627
ModeLine "800x600" 45.5 800 840 920 1040 600 601 604 625
ModeLine "800x600" 42.1 800 840 920 1040 600 601 604 623
ModeLine "800x600" 38.2 800 832 912 1024 600 601 604 622
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
Option "PreferredMode" "1024x768"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection
Also one last question. How many monitors do you have?
 
Old 06-21-2009, 02:05 PM   #14
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
Warning! Long post - only read if you can spare 10mins.

Also, thanks for the replies, I think you all (especially Steel_J) have spent a lot of time helping me out here.

Quote:
Now from what I understand you an recreate your success of 800x600 at will so
Within reason I can. Sometimes I seem to break it so bad I have to re-install (read on for more info about that).

Quote:
Do you know how to use VI or VIM command line text editors? Because that is the secret to fixing these problems. I have a little guide I can post for you that I keep around if you like. Let me know.
Actually, not before today, but I have become very used to things like :qa! and :wq and :startinsert today. However, the guide would be much appreciated! The help files in Vi are comprehensive and good, but take a lot of searching when you're new.

Quote:
You have two section for everything!!!
I'm glad you said that, because I noticed that today and was going to ask about it on here. So that answers my question, it's not normal.

Quote:
Here is an modified version of xorg.conf that i want you to try:
I'm up for that, but I discovered something about the fglrx driver today that leads me to believe there is more to this than the xorg.conf file.

Quote:
Also one last question. How many monitors do you have?
I have three available for testing. I have been using mainly my 15" LCD which has these probs. I have a 17" LCD, but don't tend to use it as it powers off after 1-2 hours use, and then subsequently every 5 mins, but it can be useful for testing. I also have a 15" CRT if necessary.

This site is only where I live on weekdays, my home machine is the one profiled in my sig, and is working fine right now, but here I have to make do with stuff I have lying around. I know for sure the monitor and vid card are OK, because they are both rock solid in WindowsXP and Windows7, and used to be rock solid in SuSE 11.0 until I had a hard drive prob. However, again, read on....

Also, I hear what you're saying about sax2 etc, but it I did all this stuff this morning, so I can take this advice forwards.

Ready? Got a cup of tea/coffee/beer/whisky? Then read my next POST.

Last edited by khinch; 06-21-2009 at 02:23 PM. Reason: update
 
Old 06-21-2009, 02:13 PM   #15
khinch
Member
 
Registered: Apr 2007
Location: Carlisle, UK
Distribution: Debian
Posts: 73

Original Poster
Rep: Reputation: 18
Here is what I spent most of today doing:

Fresh install of OpenSuSE 11.1 with all updates installed. I then backed up xorg.conf and Xorg.99.log, which should be identical to the ones previously posted. I installed the Ati repositories, and installed files X11-video-fglrxG01 and ati-fglrxG01-kmp-pae. I then did:

init3.
aticonfig –-initial

At which point I backed up my xorg.conf, which is attached as xorg.conf_2.txt. I know from experience if I reboot at this stage then I will get out-of-range, so I took business_kid's suggestion and used Vi to edit the file, setting horizsync to 31.5-55 and vertrefresh to 40.0-70.0. Reboot and...... out-of-range.

Rebooted to init3 and did:-
sax2 -r -l -m 0=fglrx
reboot to init6 – worked fine with 800x600 desktop. At this point I backed up xorg.conf again, which is attached as xorg.conf_3.txt.

So, knowing I know have a working fglrx desktop, I booted to init3 and used Vi to change xorg.conf, under the screen section I changed all instances of 800x600 to 1024x768. Saved, rebooted and – out-of-range. Rebooted to init3 and put them back – fine again at 800x600.

I then noticed that since running sax2 the horizsync and vertrefresh had changed from the original. With a fresh install the monitor sits at 1024x768 fine using the radeonhd driver, so I changed the horizsync and vertrefresh to match the originals (horizsync from 20-46 to 30-62, and vertrefresh from 50-60 to 43-75), put screen res back to 1024x768. Deep breath, reboot and – out-of-range.

At this point I realised all the rebooting was unnecessary and time consuming, so another reboot to init3 lasted me for the next hour or so. Also, at this point I KNOW that this monitor will display 1024x768 at 60Hz, so it's only the horizsync I have to worry about (or so I thought). I also know that some value between 30-62KHz must be OK since that is the values in the original xorg.conf, which works fine at 1024x768 @60Hz. I set the horizsync value to 30, 31, 32etc up to 62 in increments of 1 and tried startx each time, every single one – out-of-range. (I got very quick at up- up- enter- :startinsert- backspace- number- :wq- enter- up -up enter- ctrl+alt+backspace- up -up etc...)

So, another tactic needed. I put the settings in xorg.conf back to 800x600, horizsync 20-46, vert refresh 43-75 and rebooted – worked fine again at 800x600. I then checked the settings in YAST - > monitor settings - > where strangely the monitor values showed up as horiz 30-46K and vert 50-75 – totally different from the ones in the xorg.conf file that I just set. So, in this section of YAST I set the monitor to 1024x768 – blackscreen on monitor, power LED still green – no response – not even an out-of-range (I know, almost refreshing at this point). Tried ctrl+alt+backspace, tried alt+sysreq+R,E,I,S,U,B – nothing. Kernel crashed. I had to hit reset.

Thankfully the settings didn't stick – back to init5 and I'm at 800x600 again. This time I used amdcccle. I set monitor to 1024x768 – fine. It defaulted to 72Hz for some reason, but it was also fine at 75Hz and 60Hz. I left it at 60 as I know for sure it works there in Windows and in SuSE11.0 before. I ran glxgears and fgl_glxgears – 3600+ and 600+ rates so it's definitely working. I backed up the output of glxinfo and fglrxinfo to text files at this point if anyone wants to see them, but there is a 3file cap on here so can't add to this post. So, reboot to init5 and – deep breath – no GUI, it just went directly to command prompt with a message “skipped services in runlevel 5”. At this point I saved my xorg.conf again as xorg.conf_4.txt.

I checked xorg.conf and amdcccle has edited it since it's labelled itself all over the place, and changed the vertrefresh to 43-75, so I changed it back to 50-60. Rebooted at this point and it went straight back to command prompt again - “skipped services in runlevel 5”.

I noticed at this point that the resolutions in the screen section were still set to 800x600, despite amdcccle editing it when I set it to 1024x768. So I put it back to 1024x768, rebooted, X failed again dumping me back at the command prompt with my new best friend: “skipped services in runlevel 5”.

So, at this point I copied a known-good xorg.conf back, good ol' xorg.conf_3.txt was copied back, since it worked fine before for ages. Rebooted – command prompt – skipped services in runlevel 5. Now, I tried the sax2 route again as that's what got me working with the 800x600 desktop before, so once again I tried: sax2 -r -l -m 0=fglrx, but the kernel crashed again this time and I had to reset again. Not even alt+sysreq+REISUB worked.

So, back to runlevel3, ran aticonfig --initial, went OK. So as in previous cases I tried what got me a working 800x600 desktop: sax2 -r -l -m 0=fglrx yielded

Code:
XC: Sorry, could not start configuration server
XC: for details refer to the log file:
	/var/log/SaX.log
XC: abort
(I have this log file backed up also, if it's useful).

So, back to basics once more. I coped the file xorg.conf_original back to /etc/X11/xorg.conf and ran aticonfig --initial, followed by sax2 -r -l -m 0=fglrx and was met once again by a black screen with another kernel crash. At this point I reinstalled from scratch, and have a shiny new installation to break.

What is making me wonder, is that most of the severe problems only started after running amdcccle, it seems to have made changes to files other than xorg.conf. Even when I copied back a known-good xorg.conf file and repeated processes that worked previously, after running amdcccle it all went downhill. However, strangely, amdcccle is the only utility that has got me a working 1024x768 fglrx desktop, but it only works until reboot. So I know for sure this monitor will display 1024x768 at 60Hz from this video card using the fglrx driver, since it did it for a short time before reboot, I just have to find the right file I think. Very frustrating.

So, does anyone know what else amdcccle changes that could affect this? I can try any other xorg.conf if anyone thinks it will help, but my experience today suggests that Ati have made changes that use more than just this one file.

As always, any further help much appreciated.
Attached Files
File Type: txt xorg.conf_2.txt (4.8 KB, 0 views)
File Type: txt xorg.conf_3.txt (4.0 KB, 1 views)
File Type: txt xorg.conf_4.txt (4.4 KB, 0 views)

Last edited by khinch; 06-21-2009 at 03:14 PM.
 
  


Reply

Tags
ati, driver, radeon, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First boot after install monitor says out of range cuco76 Fedora - Installation 3 06-16-2007 10:31 PM
monitor out of range after FC6 install crazyjedi Linux - Newbie 4 11-16-2006 04:06 PM
External monitor only for ATI driver joshcav Linux - Hardware 2 02-18-2006 12:58 PM
Monitor Resolution of Resfresh seems out of range on new install manderino Mandriva 29 12-06-2004 12:35 PM
Monitor: frequency out of range. Mandrake 9 install mlsbraves Linux - Hardware 5 07-16-2004 06:37 AM


All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration