LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-25-2008, 08:11 PM   #1
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
ATI Catalyst Segmentation Fault


I've been having problems with Catalyst drivers since 8.6.

Looks like 8.7 was released recently. Just tried it and getting same problems. Went back to 8.5. 8.5 seems to work but rtwc (wolfenstein) occasionally locks up.

Problem: Catalyst 8.6 causes segmentation fault running glxinfo. Mythtv-setup display is also goofed up. Wine programs are also goofed up such as jfduke under wine. Same problems under 8.7. Eduke and sdlquake seem to work under 8.7. I can't remember if they worked under 8.6.

I have the gigabyte with integrated HD3200 (780g) board.
Looks like others with other ATI cards also having problems.
The 8.7 change log says the texture problem solved but also outstanding.
Does 8.7 work for anyone?
 
Old 07-26-2008, 03:41 PM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
Which ati card are you using? HD3200?

Did you follow the instructions during install?

If that is the case, then you can try radeon/radeonhd or ati
 
Old 07-27-2008, 08:48 AM   #3
forum1793
Member
 
Registered: May 2008
Posts: 312

Original Poster
Rep: Reputation: 34
Quote:
Which ati card are you using? HD3200?
Yes, HD3200
Quote:
Did you follow the instructions during install?
I installed it the same way I've installed all the others.
1. Exit out of X
2. Delete folder at /usr/share/ati
3. rmmod fglrx
4. Delete folder at /lib/m*/fglrx (although this step probably not needed)
5. Install new version by ati*run from command line.

Is there something else I should be doing? I'm running slackware and the autoinstaller seems to work. No obvious errors are seen.

Quote:
If that is the case, then you can try radeon/radeonhd or ati
Does this do good 3D acceleration?

If I go this route, which do you recommend for the HD3200, radeon, radeonhd, some of framebuffer?

Looking at my /lib area, the last kernel build did include drm.ko and radeon.ko.

Do I just need to load both of these. Where do you see radeonhd?

Granted I could and might read up on this myself, but if you know off the top of your head, it might be helpful.

Thank you
 
Old 07-28-2008, 07:33 PM   #4
forum1793
Member
 
Registered: May 2008
Posts: 312

Original Poster
Rep: Reputation: 34
I've learned a little since last post.

Open drivers aren't working to well on my system. Radeon gives goofy colors. RadeonHD colors are better but both of these only give me two resolutions and they are too big for monitor. After exiting X, when using radeonhd, text graphics was goofed up and had to reboot.

Neither radeon or radeonhd do 3d acceleration so drm and I've been told agpgart are not needed.

Also learned catalyst 8.6 and 8.7 have problems and do not work textured graphics. This evidently includes mythtv.

Kernel 2.6.26 does not work with catalyst 8.5 on.

So I went back to kernel 2.6.25.11 and catalyst 8.5.

Glxgears are >3x what they are if not using fglrx proprietary driver

Folks working on the open drivers intend to add 3d acceleration in time.
 
Old 08-10-2008, 01:24 PM   #5
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 292

Rep: Reputation: 75
I'm using Slackware 12.1 with kernel version 2.6.26.1. The ati drivers version 8.6 and 8.7 don't work with the new kernel. There are patches for both but I use the 8.6 ati drivers as the resulting compiled fglrx.ko driver doesn't result in warnings. Here's the link for the 8.6 drivers.
https://a248.e.akamai.net/f/674/9206...x86.x86_64.run
So here's what I did.
Quote:
I installed it the same way I've installed all the others.
1. Exit out of X
2. Delete folder at /usr/share/ati
3. rmmod fglrx
4. Delete folder at /lib/m*/fglrx (although this step probably not needed)
5. Install new version by ati*run from command line.
And from here we need to patch the firegl_public.c and firegl_public.h files.
Code:
6. cd /lib/modules/fglrx/build_mod
7. wget http://ati.cchtml.com/attachment.cgi?id=631; mv attachment.cgi?id=631 patch_Fglrx_8_6_2.6.26.diff.patch
8. patch -p1 < patch_Fglrx_8_6_2.6.26.diff.patch
9. make.sh
10. cd ..
11. make_install.sh
12. logout to X to command line
13. aticonfig --initial -f
14. startx
This should get the ati drivers up and running. Otherwise, the ati drivers won't install correctly. I haven't installed the 8.7 drivers as the make.sh command results in warnings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATi Catalyst driver 8.1 problem on Slack 10.2 brooky9999 Slackware 5 02-08-2008 09:10 AM
LXer: ATI Releases Catalyst 7.10 Drivers for Linux LXer Syndicated Linux News 0 11-01-2007 08:30 PM
ATI Segmentation Fault jimmy512 Linux - Software 2 07-05-2007 05:37 AM
LXer: Ati releases Catalyst 6.9 for Win and Linux LXer Syndicated Linux News 0 09-22-2006 05:54 AM
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika Suse/Novell 2 12-02-2005 09:34 AM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration