LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-23-2009, 01:48 AM   #1
dizon
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
Unhappy Atheros AR 8132 on my Acer Aspire one D250


My ethernet card (Atheros AR8132) on Acer Aspire One D250 cannot readed, please help me (i'm using slackware linux operating system)
i was trying to compile my kernel using kernel version 2.26.30.5, the eth0 was readed but if i plug the UTP cable in my ethernet card, my OS (slackware) going to be hang or everything's stop working. i was check the atheros device in kernel (especially the fast ethernet). i was trying the other OS like Ubuntu n Mint, but it same. Thanks for everything.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 08-25-2009, 04:12 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,174

Rep: Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526Reputation: 526
There can be long delays if dhcp goes waiting for an answer, but it will eventually time out (60 secs?)
You need to fill in sensible values in
/etc/rc.d/rc.wireless.conf - if you have a wireless system
/etc/rc.d/rc.inet1.conf - whatever system you have. A wireless card is eth[4]

Each has a man page. Also check for stupid things like ethernet switching in the bios. This means that if the eth0 connects, the wlan0 is disabled, and vice versa.
 
Old 10-22-2009, 02:37 AM   #3
notihnio
LQ Newbie
 
Registered: Oct 2009
Location: Greece
Distribution: slackware-current
Posts: 23

Rep: Reputation: 5
[SOLVED]i had exactly the same problem o my acer aspire one 250 using slackware 13! by default slack uses ATL1C driver version 1.0.0.10
eth0 was up looked fine buty did not work


if you type:
ethtool -i eth0 you will see that

driver: ALT1C
firmware = (empty)
Version = (empty)

show what i did! i found next version driver which was on test version but worked fine!!!

driver was l1c-linux-v1.0.0.11-test.tar.gz


1)first remove old driver using modprobe -r atl1c
2)download l1c-linux-v1.0.0.11-test.tar.gz driver from https://bugzilla.redhat.com/attachment.cgi?id=355728
3)untar it with tar -zxvf l1c-linux-v1.0.0.11-test.tar.gz
4) enter src directory with cd src
5) compile driver with make install
6) enable it modprobe atl1c
7)enable eth0 ifconfig eth0 up

and it works fine

type ethtool -i eth0

driver: ATL1C
version 1.0.0.11-test
firmware-version: L1e
bus-info: 0000:03:00.0

i hope this will help you
 
2 members found this post helpful.
Old 10-24-2009, 12:56 PM   #4
dizon
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Original Poster
Rep: Reputation: 0
thanks for ur explain

Last edited by dizon; 10-24-2009 at 12:59 PM.
 
Old 02-01-2010, 04:46 AM   #5
desire147
LQ Newbie
 
Registered: Jan 2010
Posts: 1

Rep: Reputation: 0
linux driver for acer aspire d250

thank u for suggesting but it not works i have red hat enterprise edition 5.2 and it does 't detect lan automatically ,please help me how cam i do this ?
 
Old 02-02-2010, 04:41 AM   #6
dizon
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by desire147 View Post
thank u for suggesting but it not works i have red hat enterprise edition 5.2 and it does 't detect lan automatically ,please help me how cam i do this ?
try to using the new release kernel (i'am using 2.6.31.6 kernel version) and it's detect and can be used now
 
Old 02-18-2010, 11:09 AM   #7
vsaggu
LQ Newbie
 
Registered: Feb 2010
Posts: 8

Rep: Reputation: 0
I have installed Centos 5.4 and lan / wan nothing is working. now how do i run yum ? like this how will i update kernal and other things.

as seen in other posts also, how they are able to run yum
 
  


Reply

Tags
slackware12


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer Aspire One Atheros wireless: No scan results Nylex Slackware 23 01-22-2009 01:13 PM
How to install Atheros Wi Fi for an Acer Aspire 5715Z Laptop using Ubantu? ahamb Linux - Newbie 2 12-06-2008 06:28 AM
Atheros Wireless card won't work on Acer Aspire 4520, Ubuntu Gutsy utonvan96 Linux - Hardware 8 04-27-2008 10:15 PM
Buil in Atheros WL not working - Acer Aspire 5100 starter_07 Linux - Wireless Networking 7 08-22-2007 04:55 PM
Atheros card not working in opensuse 10.2 Acer Aspire 5570Z chief_officer Linux - Laptop and Netbook 16 07-20-2007 10:20 AM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration