LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Asus P8H77-I with Intel i5-3470T (http://www.linuxquestions.org/questions/linux-hardware-18/asus-p8h77-i-with-intel-i5-3470t-4175440490/)

dolphs 12-07-2012 04:34 PM

Asus P8H77-I with Intel i5-3470T
 
Hi guys, I am running debian and compiled vanilla kernel 3.6.9.
After executing a "lspci -v", I noticed following two have no Kernel driver in use.
Can one guide me which modules I missed out please?

1/
00:00.0 Host bridge: Intel Corporation Device 0150 (rev 09)
Subsystem: ASUSTeK Computer Inc. Device 84ca
Flags: bus master, fast devsel, latency 0
Capabilities: [e0] Vendor Specific Information: Len=0c <?>


2/
00:1f.3 SMBus: Intel Corporation Device 1e22 (rev 04)
Subsystem: ASUSTeK Computer Inc. Device 84ca
Flags: medium devsel, IRQ 11
Memory at f7c15000 (64-bit, non-prefetchable) [size=256]
I/O ports at f040 [size=32]

TobiSGD 12-07-2012 06:26 PM

Please launch the command
Code:

update-pciids
as root, so that lspci shows the real names of those devices.

dolphs 12-15-2012 09:07 AM

cheers for that, it shows now:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
Subsystem: ASUSTeK Computer Inc. Device 84ca
Flags: bus master, fast devsel, latency 0
Capabilities: [e0] Vendor Specific Information: Len=0c <?>

00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
Subsystem: ASUSTeK Computer Inc. Device 84ca
Flags: medium devsel, IRQ 18
Memory at f7c11000 (64-bit, non-prefetchable) [size=256]
I/O ports at f040 [size=32]

TobiSGD 12-15-2012 10:55 AM

I wouldn't bother with that, those devices don't need extra drivers.

dolphs 12-16-2012 09:30 AM

ok clear, I thought the " SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04) " could have been one of the modules somewhere under "Device Drivers-> I2C support-> I2C Hardware Bus support-> ... " - Cheers

dolphs 10-15-2013 12:33 PM

Hi it seems for the Asus P8H77-I following modules are in use using kernel 3.10.16:

Kernel driver in use: pcieport
Kernel driver in use: i915
Kernel driver in use: xhci_hcd
Kernel driver in use: mei
Kernel driver in use: ehci_hcd
Kernel driver in use: snd_hda_intel
Kernel driver in use: ehci-pci
Kernel driver in use: lpc_ich
Kernel driver in use: ahci
Kernel driver in use: r8169


I was expecting to see Kernel driver "i2c_i801" also in use, also based on several hits on google .. However till today NOK:


lspci -v:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller (rev 09)
Subsystem: ASUSTeK Computer Inc. P8H77-I Motherboard
Flags: bus master, fast devsel, latency 0
Capabilities: [e0] Vendor Specific Information: Len=0c <?>


00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
Subsystem: ASUSTeK Computer Inc. P8H77-I Motherboard
Flags: medium devsel, IRQ 18
Memory at f7d15000 (64-bit, non-prefetchable) [size=256]
I/O ports at f040 [size=32]


a modprobe "i2c-dev" shows: " [ 1657.167990] i2c /dev entries driver "
After that a modprobe on " i2c-i801 " shows nothing, no error and indeed module is compiled in to kernel ...


All times are GMT -5. The time now is 10:30 AM.