LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   any way to increase CD-ROM buffer, increase spindown delay, XMMS buffer (http://www.linuxquestions.org/questions/linux-hardware-18/any-way-to-increase-cd-rom-buffer-increase-spindown-delay-xmms-buffer-527151/)

r00tb33r 02-09-2007 07:01 PM

any way to increase CD-ROM buffer, increase spindown delay, XMMS buffer
 
I do not know if such settings exist, but here is what I have:
NEC ND-3540A 16x DVD-+RW drive with 2MB cache
XMMS 1.2.10
2.6.18.5-i686 kernel
ALSA version 1.0.11 (reported by alsaconf)
...
The problem is that when I listen to mp3s from the above drive, everything is fine for like 5mins then suddenly music stops and I hear the drive spin up and then the music continues after like 3secs. This tells me that buffer of whatever(I don't know what buffer XMMS uses) runs out. Also I would like to increase the time before the drive spins down(I do want it to spin down eventually but not so soon).
This does not happen on windows with winamp. Any clues?
Basically what I am trying to achieve is continuous reading. Also when played from hard drive I don't get interrupts.
Any help appreciated.

David the H. 02-10-2007 06:20 AM

Is it just an xmms problem, or have you tried it with other media players as well? You might be interested in trying out audacious, which is an updated gtk2 fork of xmms. It might work better for you.

r00tb33r 02-11-2007 01:23 AM

Uhh... I wish it was as simple as you say - heres the story:
I downloaded audacious(1.2.2)... compiled successfully. plugins compiled and installed(1.2.5) It seems like a project that has alot going for it. But it is LONG WAYS till being remotely usable. It is so buggy that I am not going to even bother filing the bugs - that would require me first looking over the current submissions and then write detailed description for each one... Sorry maybe another day.
The major flaws:
Crashes on manipulations with file manager, such as dragging in folders(Thunar) xmms does not.
Crashes when I press any button in playlist actions (+,-, list, etc)
audacious has no directory interpretation (ie. does not play files inside a directory if you just specify the derectory unlike xmms)
in every other respect it is much like XMMS but impossible to use.
I could not use it long enough to tell if I have problems since the playlist barely works.
I downloaded and compiled Amarok but unfortinately it does not function without KDE. I do not have KDE installed and I am not planning to.
Any other players you can think of? (I dont have wine installed yet and Winamp was a b1tch to get to work completely on wine... actually it never did, but I got pretty close)
Please, please, please keep posting ideas regarding this - I can clearly see the drive spin down like a minute after music starts playing. Perhaps there is a way to make XMMS to access and replenish the buffer earlier, before it runs out.

r00tb33r 02-12-2007 02:02 AM

Never mind the media players - I have the same problem with VLC. It ran out of buffer and there was a pause in music while the drive was spinning up. This is totally a hardware configuration issue.
Any ideas?

virtualx 06-12-2009 12:33 AM

cd spin down issues - meetoo
 
I'm having very similar issues.

I tried to disable spin-down on both my drives

hdparm -S 0 /dev/sr1
hdparm -S 0 /dev/cdrom

Now the drive spins down to 1x but the problem persists (though the pauses between when music stops and restarts is much less)

I tried disabling read ahead caching

hdparm -A1 /dev/sr1

but apparently changing look-ahead is not supported.

I don't remember ever having this problem with debian so it could be and OpenSUSE thing, but I honestly don't remember the last time I tried to play a CD on this machine either.

virtualx 06-12-2009 01:10 AM

Solved!
 
Set the CDROM speed to 1x

hdparm -E 1 /dev/sr1
(/dev/sr1 should be your cdrom device; most likely /dev/cdrom or /dev/cdrom0)

Setting this will last until the next reboot.


All times are GMT -5. The time now is 10:19 AM.