LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-03-2004, 11:49 AM   #1
jkmin
LQ Newbie
 
Registered: Jul 2002
Location: Los Angeles, CA
Distribution: RH7.1
Posts: 29

Rep: Reputation: 15
any monitor flickering problem with Intel® Extreme Graphics 2 & Redhat 9.0?


Has anybody experienced any monitor flickering problem with Intel® Extreme Graphics 2 & Redhat 9.0?

I aseembled a pc with Intel D865GLC MB, and P4 3.0 HT. I use on board video, which is Intel® Extreme Graphics 2.

I configured the video properly, using the redhat-config-xfree86, setting the vertical & horizontal sync rate properly for the monitor Samsung Syncmaster 793MB. But still the monitor seems to flicker.

When I boot the same machine with WinXp, I see that vertical refresh rate is 85Hz, and it does not flicker at all.

Could you please help on what I can do to fix this flicker problem?

THank you very much.
 
Old 11-03-2004, 11:55 PM   #2
jkmin
LQ Newbie
 
Registered: Jul 2002
Location: Los Angeles, CA
Distribution: RH7.1
Posts: 29

Original Poster
Rep: Reputation: 15
I have the following in the XFree86 log of the Intel D865GLC motherboard. It uses the INtel extreme graphics 2 on board video.

It says
"(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Failed to set refresh rate to 84Hz."

How can I fix this?

---------
(II) I810(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(II) I810(0): xf86BindGARTMemory: bind key 7 at 0x00fdf000 (pgoffset 4063)
(II) I810(0): xf86BindGARTMemory: bind key 0 at 0x07fff000 (pgoffset 32767)
(II) I810(0): xf86BindGARTMemory: bind key 2 at 0x07fee000 (pgoffset 32750)
(II) I810(0): xf86BindGARTMemory: bind key 1 at 0x07ffe000 (pgoffset 32766)
(II) I810(0): xf86BindGARTMemory: bind key 3 at 0x07800000 (pgoffset 30720)
(II) I810(0): xf86BindGARTMemory: bind key 4 at 0x07400000 (pgoffset 29696)
(II) I810(0): xf86BindGARTMemory: bind key 5 at 0x073f8000 (pgoffset 29688)
(II) I810(0): xf86BindGARTMemory: bind key 6 at 0x072f8000 (pgoffset 29432)
(WW) I810(0): PGTBL_ER is 0x00000029
(WW) I810(0): Extended BIOS function 0x5f05 not supported.
(WW) I810(0): Failed to set refresh rate to 84Hz.
(II) I810(0): Display plane A is enabled.
(II) I810(0): Display plane B is disabled.
(II) I810(0): PIPEACONF is 0x80000000
(II) I810(0): Mode bandwidth is 47 Mpixel/s
(WW) I810(0): Extended BIOS function 0x5f28 not supported.
(WW) I810(0): Extended BIOS function 0x5f61 not supported.
(II) I810(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
---------

THank you very much for your help.
 
Old 07-20-2005, 07:10 AM   #3
sashahd
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
Hi,
In section "Device" replace Driver "i810" with Driver "vesa":

Section "Device"

#no known options
Identifier "Intel 810"
Driver "vesa"
VendorName "Intel 810"
BoardName "Intel 810"
VideoRam "65536"
#BusID

EndSection


Good luck !
 
Old 08-01-2005, 04:30 PM   #4
jkmin
LQ Newbie
 
Registered: Jul 2002
Location: Los Angeles, CA
Distribution: RH7.1
Posts: 29

Original Poster
Rep: Reputation: 15
Thank you for the reply.

I changed to vesa and it works fine.

Thank you.
 
Old 08-23-2005, 12:07 PM   #5
simon_w
Member
 
Registered: Jun 2004
Location: UK
Distribution: Debian Etch
Posts: 71

Rep: Reputation: 15
Quote:
Originally posted by sashahd
Hi,
In section "Device" replace Driver "i810" with Driver "vesa":
Thanks, I found this after some googling and I now have "hardware acceleration" on pc at work

Last edited by simon_w; 08-23-2005 at 12:09 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Intel Extreme Graphics 2 on mandrake 10.1 official OdeToMadness Linux - Laptop and Netbook 0 10-08-2005 01:41 AM
PROBLEM!-Slackware10.1/Xorg on Dell Laptop video:intel Extreme Graphics 2 for mobile nofx_scotti Slackware 4 03-16-2005 09:46 PM
Intel Extreme Graphics problem squidyy Linux - Laptop and Netbook 2 01-16-2005 03:16 PM
: Intel® 865G Chipset with Intel® Extreme Graphics 2 -driver for linux7.0 ker 2.4.1 schandak Red Hat 1 10-28-2004 12:43 AM
dell intel extreme graphics steady Linux - Laptop and Netbook 0 08-07-2004 04:41 PM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration