LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-06-2010, 09:27 AM   #1
Gallifrey
Member
 
Registered: Feb 2010
Distribution: Ubuntu 10.04 - Lucid Lynx, Fedora 13, OpenSUSE 11.2
Posts: 46

Rep: Reputation: 16
Another (NEW) Canon Printer Problem


Hi all,
havig struggled for nearly a week to get my Canon Pixma ip1900 to work on Ubuntu, I finally did, thanks to a lot of googling and forum browsing. Extracted drivers, changed references to libcupsys2, changed filter permissions, dpkg -i --force-architecture (I'm on 64 bit), etc. And it worked wonderfully. Until last week.

Now, when I try and print, I get nothing. Zip. Just a message in Printing:

/usr/lib/cups/filter/pstocanonij failed

pstocanonij is present in the directory. I haven't, to my knowledge changed anything. I have reinstalled the drivers, restarted cups, but to no avail.

Anybody have any ideas?? I really need to get this going. I would get a more linux friendly printer, but I am on a tight budget for the time-being.

Would be most grateful for assistance!
 
Old 08-06-2010, 02:11 PM   #2
Gallifrey
Member
 
Registered: Feb 2010
Distribution: Ubuntu 10.04 - Lucid Lynx, Fedora 13, OpenSUSE 11.2
Posts: 46

Original Poster
Rep: Reputation: 16
Update:

Tried adding the printer via the Cups server (localhost:631).

Problem persists, but this time I checked the error log, and found these messages:

/usr/lib/cups/filter/pstocanonij: No such file or directory
(/usr/lib/cups/filter/pstocanonij) stopped with status 22!

I have checked, the file is definitely present where it should be, and also appears in /lib64. Permissions are set correctly.

I am at my wits end. Incidentally, I tried the printer on my desktop (running 10.04 i386), and it works fine, so this seems to be an amd64 issue.

Any ideas??
 
Old 08-07-2010, 11:31 AM   #3
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 251

Rep: Reputation: 26
same here

hi, just to let you know i'm in the same boat

i got my canon mp620 working in slackware 32 13.1 hcl post here following same procedures i could not get it to work with slackware 64 13.1

gave up because i have work arounds
 
  


Reply

Tags
canon, failed


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer Problem-Canon Pixma MP170 commandante Linux - Software 4 10-28-2007 03:39 PM
Canon networked printer installation problem bapa Linux - Hardware 0 02-15-2007 04:10 PM
problem with Canon LASER SHOT PRINTER makkintosh Linux - Hardware 6 10-24-2004 02:35 PM
Canon i560 printer problem Accordion Linux - Newbie 1 09-26-2004 05:49 AM
Canon i950 printer problem stonehurstX11 Linux - Hardware 0 12-05-2003 05:28 PM


All times are GMT -5. The time now is 03:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration