LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   alsamixer fails to load on SUSE 9.3 (http://www.linuxquestions.org/questions/linux-hardware-18/alsamixer-fails-to-load-on-suse-9-3-a-354743/)

Hrothgar15 08-18-2005 10:40 PM

alsamixer fails to load on SUSE 9.3
 
When I try to run alsamixer from the shell (even as root), I get the following:

alsamixer: function snd_mixer_load failed: Invalid argument

If it is of any help, my lsmod is the following:

Module Size Used by
snd_seq_dummy 7684 0
snd_seq 62992 1 snd_seq_dummy
snd_seq_device 12940 2 snd_seq_dummy,snd_seq
snd_hda_intel 20960 0
snd_hda_codec 57472 1 snd_hda_intel
snd_pcm 109828 2 snd_hda_intel,snd_hda_codec
snd_timer 31108 2 snd_seq,snd_pcm
snd 71172 7 snd_seq_dummy,snd_seq,snd_seq_device,snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
ipt_LOG 11392 7
ipt_limit 6528 7
ipt_pkttype 5760 1
subfs 12416 2
usbserial 34024 0
speedstep_lib 8324 0
freq_table 8832 0
thermal 18184 0
processor 28648 1 thermal
fan 8836 0
button 11024 0
battery 14084 0
ac 9220 0
nvram 13576 0
af_packet 26760 0
usbhid 48096 0
edd 14560 0
joydev 13888 0
st 43676 0
evdev 12928 0
sr_mod 21284 0
sg 42912 0
ipt_state 6016 12
ip6t_REJECT 11008 3
ipt_REJECT 11008 3
iptable_mangle 6912 0
iptable_filter 6912 1
ip6table_mangle 6528 0
ip_nat_ftp 7168 0
iptable_nat 27452 1 ip_nat_ftp
ip_conntrack_ftp 76944 1 ip_nat_ftp
e100 43392 0
ip_conntrack 48360 4 ipt_state,ip_nat_ftp,iptable_nat,ip_conntrack_ftp
mii 9088 1 e100
ehci_hcd 37896 0
ip_tables 25728 8 ipt_LOG,ipt_limit,ipt_pkttype,ipt_state,ipt_REJECT,iptable_mangle,iptable_filter,iptable_nat
uhci_hcd 37008 0
i2c_i801 12556 0
hw_random 9492 0
usbcore 121688 5 usbserial,usbhid,ehci_hcd,uhci_hcd
i2c_core 26624 1 i2c_i801
ip6table_filter 6784 1
ip6_tables 23552 3 ip6t_REJECT,ip6table_mangle,ip6table_filter
parport_pc 44356 0
lp 15396 0
parport 40392 2 parport_pc,lp
soundcore 13664 1 snd
snd_page_alloc 14340 2 snd_hda_intel,snd_pcm
ipv6 273920 19 ip6t_REJECT
ntfs 180368 0
dm_mod 64768 0
reiserfs 262896 1
ide_cd 44036 0
cdrom 42784 2 sr_mod,ide_cd
ide_disk 22400 0
ata_piix 13444 1
libata 56068 1 ata_piix
piix 14468 0 [permanent]
ide_core 131904 3 ide_cd,ide_disk,piix
sd_mod 23168 2
scsi_mod 136008 5 st,sr_mod,sg,libata,sd_mod

I have already tried repairing my system. I need to be able to use alsamixer in order to get my computer to play sound. I'm on SUSE 9.3, if that helps.

TomalakBORG 08-18-2005 11:05 PM

hmm, do you have any multimedia playback at all? It's all broken in suse 9.3, tyou need to dl yast online update packaged from some german ftp.

I had a wierd problem where the AC'97 driver was completely shot. Try reinstalling and not doing any YOU. That worked for us.


All times are GMT -5. The time now is 05:36 PM.