LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-27-2004, 01:29 AM   #1
toastydeath
LQ Newbie
 
Registered: May 2004
Location: Gaithersburg, Maryland
Distribution: Slackware 9.1
Posts: 6

Rep: Reputation: 0
alsa sound problem


I am attempting to install the ALSA sound drivers for the nForce sound/video/network chip. After reading in many places that the nForce drivers are more trouble than they are worth (and after attempting, i agree), I tried the alsa driver set and alsaconfig. This failed miserably.

the snd-ac97-codec.o module is loaded. However, when i attempt to load snd-intel8x0 via modprobe, i get this set of errors:

/lib/modules/2.4.22/kernel/sound/acore/snd-rawmidi.o: unresolved symbol snd_register_oss_device
/lib/modules/2.4.22/kernel/sound/acore/snd-rawmidi.o: unresolved symbol snd_oss_info_register
/lib/modules/2.4.22/kernel/sound/acore/snd-rawmidi.o: unresolved symbol snd_unregister_oss_device
/lib/modules/2.4.22/kernel/sound/acore/snd-rawmidi.o: insmod /lib/modules/2.4.22/kernel/sound/acore/snd-rawmidi.o failed
/lib/modules/2.4.22/kernel/sound/acore/snd-rawmidi.o: insmod snd-intel8x0 failed

Many of the other modules I attempt to insert also fail with the first message (or only message) unresolved symbol snd_register_oss_device. I compiled alsa with ./configure --with-oss=yes.

Any help is appriciated!
 
Old 05-27-2004, 03:09 AM   #2
postmaik
Member
 
Registered: May 2004
Location: @ Lake Constance, Germany
Distribution: FC3, Kernel 2.6.10
Posts: 46

Rep: Reputation: 15
Hey,

I think then you should configure alsa without oss. oss is deprecated with kernel of version 2.6.x.
That could be the problem that there is a conflict between alsa and oss.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa sound problem verbose Linux - Hardware 6 08-22-2005 01:48 PM
ALSA, Sound Problem. VemeC Slackware 4 08-04-2005 06:39 PM
sound/ alsa problem noir911 Slackware 3 11-24-2004 12:05 AM
ALSA sound problem Rarrum Linux - Software 2 11-02-2004 01:44 PM
alsa sound problem... jownas Linux - Hardware 4 05-12-2004 12:49 PM


All times are GMT -5. The time now is 05:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration