LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 03-09-2006, 01:06 AM   #1
yodes
LQ Newbie
 
Registered: Mar 2006
Distribution: Slackware 10.2
Posts: 3

Rep: Reputation: 0
Question ALSA providing mono master output only for Audigy 2


Hi,

Has anyone come across this issue where amixer reports the following for an Audigy2 card:
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined
Playback channels: Mono
Limits: Playback 0 - 100
Mono: Playback 53 [53%]

I'd really prefer stereo output.

I'm very sure I've got the emu10k1 driver running, as this is what lsmod reports:

Module Size Used by Tainted: P
fglrx 385864 6
snd-pcm-oss 36736 0
snd-mixer-oss 12376 0 [snd-pcm-oss]
usbkbd 2936 0 (unused)
keybdev 1892 0 (unused)
mousedev 4020 1
hid 20868 0 (unused)
usbmouse 1880 0 (unused)
input 3200 0 [usbkbd keybdev mousedev hid usbmouse]
pciehp 66868 0 (unused)
pci_hotplug 15236 1 [pciehp]
uhci 24284 0 (unused)
ehci-hcd 17516 0 (unused)
usbcore 59148 1 [usbkbd hid usbmouse uhci ehci-hcd]
tg3 57868 1
snd-emu10k1 78788 5
snd-hwdep 4352 0 [snd-emu10k1]
snd-util-mem 1136 0 [snd-emu10k1]
snd-ac97-codec 58556 0 [snd-emu10k1]
snd-pcm 54344 1 [snd-pcm-oss snd-emu10k1 snd-ac97-codec]
snd-timer 13764 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 12480 0 [snd-emu10k1]
snd-seq-device 3812 0 [snd-emu10k1 snd-rawmidi]
snd 32772 4 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-hwdep snd-util-mem snd-ac97-codec snd-pcm snd-timer snd-rawmidi snd-seq-device]
soundcore 3396 8 [snd]
snd-page-alloc 4712 0 [snd-mixer-oss snd-emu10k1 snd-hwdep snd-pcm snd-timer snd-rawmidi snd-seq-device snd]
emu10k1-gp 1192 0 (unused)
gameport 1420 0 [emu10k1-gp]
ohci1394 23888 0 (unused)
ieee1394 41636 0 [ohci1394]
ide-scsi 9392 0
apm 9452 2

Any thoughts or other avenues I should be trying would be very much appreciated. If it helps, I'm running Slack 10.2 on a 2.4 kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-2.6.3 compiled with alsa but xmms alsa output dont plays demmylls Linux - General 3 09-01-2006 04:32 AM
Alsa stereo to mono mix kdogksu Linux - Software 1 11-30-2005 11:37 PM
ALSA went mono on me! AAnarchYY Linux - General 0 09-24-2004 12:12 AM
Via AC'97 5.1 Optical Output or Audigy 4.1 Output Nza Fedora 3 06-01-2004 07:49 AM
mono xmms output majortool Linux - Software 1 10-23-2003 09:20 AM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration