LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-20-2004, 10:07 AM   #1
tedcox
LQ Newbie
 
Registered: Jan 2004
Distribution: Fedora Core
Posts: 23

Rep: Reputation: 15
Unhappy ALSA - Kernel - Aureal problem? Unresolved symbol wait_ms


I'm trying to build a Mythtv system on Fedora Core 2. However I've been having intermittent sound issues. Playback is sometimes too fast. It turns out this is a bug in the iteration of the openvortex aureal driver that went out with kernel 2.6.5. Since I've been struggling with other issues with this kernel, I upgraded to 2.6.7-1.499_7.rhfc2.at from ATrpms. Unfortunately, now I can't install the module for my sound card at all. When I try I get the following message:

snd_au8830: Unknown symbol wait_ms

I thought this might be an issue with the prebuilt alsa module for this kernel, so I downloaded the latest alsa, 1.0.6a, and built it from source (driver, lib and utils). Unfortunately I still get the above error message. No change.

My trouble is I can't find a solution to this problem anywhere. It is mentioned in several mailing lists related to networking hardware, and in one case even as an aureal card issue, but in every case the error is one of a number of errors, and they are trying to solve a different one. I can't find anyone else trying to fix this!

Anyhow, if anyone has any thoughts, I'd sure appreciate it! (At least, thoughts other than "buy a new soundcard." I have an old SB Live! laying around, but the aureal has more convenient connections -- and has been working fine in this machine for years -- at least before I upgraded to FC2.)

The machine: Duron 650@800 MHz, 512MB PC133, Asus A7V (Via KT133), GeForce2 GTS, Yuan MPG600 IVTV -- working fine on both the old and new kernel, Turtle Beach Montego 2 Quadzilla (Aureal 8830), Linksys 10/100 Ethernet card, a Maxtor 10GB, and a Maxtor 9GB both running on the onboard promise controller.

# lsmod
Module Size Used by
saa7115 11780 0
tuner 15892 0
ivtv 786084 0
i2c_algo_bit 7497 1 ivtv
i2c_core 17345 3 saa7115,tuner,i2c_algo_bit
snd_seq_oss 32512 0
snd_seq_midi_event 7552 1 snd_seq_oss
snd_seq 54032 4 snd_seq_oss,snd_seq_midi_event
nvidia 4822196 14
snd_pcm_oss 44072 0
snd_mixer_oss 14976 1 snd_pcm_oss
snd_pcm 84360 1 snd_pcm_oss
snd_page_alloc 8968 1 snd_pcm
snd_timer 25860 2 snd_seq,snd_pcm
snd_ac97_codec 61700 0
gameport 4033 0
snd_mpu401_uart 7808 0
snd_rawmidi 22308 1 snd_mpu401_uart
snd_seq_device 7048 3 snd_seq_oss,snd_seq,snd_rawmidi
snd 46820 11 snd_seq_oss,snd_seq_midi_event,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_ac97_codec,sn d_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 7713 1 snd
videodev 7105 1 ivtv
parport_pc 21249 1
lp 9132 0
parport 35977 2 parport_pc,lp
autofs4 20677 0
sunrpc 141861 1
tulip 40929 0
sg 28385 0
dm_mod 47317 0
sd_mod 17473 0
usb_storage 58121 0
scsi_mod 105361 3 sg,sd_mod,usb_storage
uhci_hcd 28505 0
button 4825 0
battery 7117 0
asus_acpi 9177 0
ac 3533 0
ipv6 216325 14
ext3 96937 2
jbd 66521 1 ext3
 
Old 08-25-2004, 04:33 AM   #2
Shinichi KOnish
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Excuse me but my English is worst:-0

I was in the same trouble.
My card is Vortex2.Kernel-2.6.8 Debian Sid.
So something may be deferent.

wait_ms defined in the game_port.
So I disabled game support of the kernel.
recompiled kernel and alsa-modules. Then rebooted,redo alsaconf.
And I got the sound.
 
Old 08-25-2004, 06:29 PM   #3
tedcox
LQ Newbie
 
Registered: Jan 2004
Distribution: Fedora Core
Posts: 23

Original Poster
Rep: Reputation: 15
Thanks for responding! Honestly, I had already given up and gone back to 2.6.5 and resolved the playback speed issues by upgrading the version of alsa I was running against this kernel.

I'll keep this in mind though, as I'm sure I'll decide to go for a newer kernel again in the not too distant future.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unresolved symbol with hpt374.o (highpoint rocketraid 1640, debian, kernel 2.4.27) sp3ktr4l Linux - Hardware 5 09-27-2006 04:29 PM
DISCUSSION: Kernel Compilation and Avoiding ‘Unresolved Symbol’ HOWTO vikram_cvk LinuxAnswers Discussion 5 01-15-2005 08:46 PM
Aureal AU8810 Sound Card not working (using ALSA with Kernel 2.6.5-rc2) linchip Linux - Hardware 30 10-19-2004 02:16 PM
ALSA: Here is the answer to 'unresolved symbol schedule_work' BWebb Linux - Newbie 1 01-27-2004 07:33 PM
ALSA Drivers: unresolved symbol snd_verbose_printk dale_lix Linux - Hardware 1 09-14-2003 06:09 PM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration