LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 12-28-2006, 01:29 AM   #1
alandd
LQ Newbie
 
Registered: Sep 2003
Location: Gilbert, AZ, USA
Distribution: Was Fedora Core but now on OpenSUSE
Posts: 13

Rep: Reputation: 0
ALSA + Intel HDA + Recording = bad squealing!


I got a new headset with a microphone for Christmas. I want to record audio and use VOIP applications, etc. However, I have a very pronounced, high pitched screeching or squealing in the recording no matter what ALSA settings I attempt. I'd like some ideas on how to proceed with figuring out the problem.

Here are some facts and things I have found or tried:
- The computer has a built-in microphone and an external microphone jack.
- alsamixer and KMix show only one "capture" control and one "mic" input.
- Screaching noise is present when using either the built-in microphone or the external.
- KRecord's level meter set to the "log" scale is constantly bouncing from 39 to 43 or so dBs.
- KRecord's frequency meter shows the background screech all the time, especially when on "log" display.

Big Hints:
- By closing X and getting to a text only terminal, I can use the "rec" and "play" command line programs to record and play back a .WAV file. In this environment the recording is mostly clean (just a few very low volume pops or clicks) with either the built in mic or the external mic.
- Based on a suggestion from someone in my LUG, I tried the same above commands from a terminal window in KDE. This also resulted in good a recording.
- Based on the clean results from the command line, I thought KDE aRTs was fighting with ALSA or something of that nature is going on when in the GUI environment. After setting the KDE sound system to ALSA and killing artsd, I still get screeching in the recording.

I am running:
- Computer: Toshiba M105-S3041 (Download detailed specs from this page: http://www.csd.toshiba.com/cgi-bin/t...ListType=Model)
- Linux 2.6.18.2-34-default i686
- openSUSE 10.2 (i586)
- KDE: 3.5.5 "release 45"

lspci -v output shows:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
Subsystem: Toshiba America Info Systems Unknown device ff00
Flags: bus master, fast devsel, latency 0, IRQ 217
Memory at d0340000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [70] Express Unknown type IRQ 0
Capabilities: [100] Virtual Channel
Capabilities: [130] Unknown (5)

alsamixer shows "Card: HDA Intel"

I've fiddled with all the settings that I know. Does anyone have hints on where to go from here?
 
Old 12-28-2006, 01:59 AM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Just a guess, but I once encountered terrible high pitched squealing/shrieking, and the solution was to get into alsamixer and lower the PCM volume level. That was with playback; I didn't try recording, but if you're getting interference during recording you might try lowering the input level on the mic, etc.

Again, just a guess.
 
Old 12-28-2006, 02:57 AM   #3
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I suggest using audacity for setting up for recording because it provides near professional VU levels. VU levels are from -200 to +6 dB. During recording, you should be around -3 dB to 0 dB, but you should not go over +3 dB or else other audio systems will distort.

Try using "alsamixer -V all". This will give you all the mixer settings.

The squealing is caused by the audio coming out of the speakers and being received by the the microphone. Adjust the master volume until the squealing stops. The best way to have the same loudness level is to use cupped headphones. To minimize it for good, search for a setting in alsamixer that does not output to the speakers. If you heard a high pitch tone all the time even when the microphone is muted or disconnected, you will have to adjust the settings or provide a module option.

I suggest a dynamic microphone because they can minimize squealing from their directional designed. When using dynamic microphones, try not to drop them or else their performance will worsen.
 
Old 12-28-2006, 08:24 AM   #4
alandd
LQ Newbie
 
Registered: Sep 2003
Location: Gilbert, AZ, USA
Distribution: Was Fedora Core but now on OpenSUSE
Posts: 13

Original Poster
Rep: Reputation: 0
Good advice, but...

The microphone is on a headphone headset. I have tried it without the headphones plugged in.

And I tried with the headphones plugged in but using the built-in microphone, which stops all sound from the speakers and means the headphone and microphone are about 2 feet apart.

AND, I have used this headset (headphone and microphone combined) on another system without problem.

AND, I used the other microphone from the other system on this one in question with the same results, both with and without the headphones.

That said, I will try manipulating the volume settings as suggested. Thanks for the responses!
 
Old 12-29-2006, 12:26 AM   #5
alandd
LQ Newbie
 
Registered: Sep 2003
Location: Gilbert, AZ, USA
Distribution: Was Fedora Core but now on OpenSUSE
Posts: 13

Original Poster
Rep: Reputation: 0
Hints from Audacity

I have done some playing around with Audacity, among other things. There are some significant hints here but I am not sure what the information is telling me. By changing the Audacity Preferences-->Audio I/O I can get different results, neither of which are acceptable.

Changing the Playback Device seems to make no difference to the sound quality so I am just manipulating the Recording Device setting.

Setting: "OSS: /dev/dsp"
Result: As before, loud screeching overpowering the recorded audio.

Setting: "ALSA: HDA Intel: ALC861 Analog (hw:0,0)"
Result: Sound is very clean but very slow! Applying an Effect-->Change Speed of +100% (ie. double speed) results in clean and correct playback.

What does this mean? I have not a clue! There are many other ALSA choices but they either don't work at all or result in the same slow playback.

I guess I can record and speed up as a workaround when recording things but that is silly. There is something fundamental going on here, a simple setting somewhere, but I don't know where.
 
Old 12-29-2006, 01:46 AM   #6
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
I have found that "most" of these sound issues are due to unsupported or wrongly configured sound codecs (not a user or distribution issue).

I looked at the current tip for the drivers, and your system is not currently listed in the ALC861 patch, although there is a "toshiba" listed with a similar subsystem ID. Try downloading alsa-driver-1.0.14rc1.tar.bz2, compile, and install it. When you load the modules, add "model=toshiba" to the modprobe command line. If that works, I'll add your subdevice id.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux + Intel HDA + ALSA = bad sound quality... stelek Linux - Hardware 7 12-25-2006 09:32 PM
Can't adjust playback volume on HDA Intel card (Alsa 1.0.13, Linux 2.6.18.2) lithiumfx Linux - Laptop and Netbook 17 12-08-2006 06:26 PM
Alsa and probing snd-hda-intel aikempshall Slackware 2 10-29-2006 05:28 AM
Alsa hda-intel Sigmatel Audio Amuro-Ray2020 Linux - Newbie 2 05-02-2006 07:19 AM
Intel HDA and ALSA problems SLaCk_KiD Linux - Software 0 09-22-2005 03:22 PM


All times are GMT -5. The time now is 09:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration