LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-19-2004, 02:36 PM   #1
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Rep: Reputation: 15
alsa installation driving me mad


Argh why can't the sh*t work!? :( :( :(
I have a C-media AC97 soundcard and after the installation of FC2 it sometimes work, sometimes
it doesn't (and all channels are un-muted and on max).
I tried following this tutorial which i found on alsa-project.org:
http://myweb.cableone.net/eviltwin69...ml#Downloading
But it's out-of-date and complicated. I just copied the script, ran it, realized that it didn't work
(no sound) and to make things even better system-config-soundcard doesn't work now:


[root]: system-config-soundcard
ALSA lib conf.c:1142:9(parse_def) d does not exists
ALSA lib conf.c:1565:(snd_config_load1) _toplevel_:17:10:No such file or directory
ALSA lib conf.c:2807:(snd_config_hook_load) /root/.asoundrc may be old or corrupted: consider to remove or fix it
ALSA lib conf.c:2671:(snd_config_hooks_call) function snd_config_hook_load returned error: No such file or directory
ALSA lib conf.c:3036:(snd_config_update_r) hooks failed, removing configuration
amixer: Mixer attach default error: No such file or directory
ALSA lib conf.c:1142:(parse_def) d does not exists
ALSA lib conf.c:1565:(snd_config_load1) _toplevel_:17:10:No such file or directory
ALSA lib conf.c:2807:(snd_config_hook_load) /root/.asoundrc may be old or corrupted: consider to remove or fix it
ALSA lib conf.c:2671:(snd_config_hooks_call) function snd_config_hook_load returned error: No such file or directory
ALSA lib conf.c:3036:(snd_config_update_r) hooks failed, removing configuration
amixer: Mixer attach default error: No such file or directory
-9
[root]:

Why does it have to be so complicated? Isn't there a alsa-RPM or something that fixes
everything? I have a teacher who has a C-media AC97 soundcard (not sure if it is exactly the
same card though) and it works for him on Gentoo with genkernel install (he tried to install
gentoo on my computer but the bootloader couldn't load the kernel).

This is REALLY driving me nuts and even though i hate microsofts so-called "ethics" and love
XFCE im going back to Win2k if i can't get the sound working.

Hasn't anyone here installed ALSA from scratch?
PLEASE help, I don't want to be forced to go back to Win2k :cry:

uname -r = 2.6.5-1.358
Distro = Fedora Core 2
CPU = AMD Athlon Thoroughbred 2Ghz (i586)
Motherboard = MSI KT6 Delta
Soundcard = C-Media AC97 (on motherboard)
 
Old 11-19-2004, 03:57 PM   #2
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
OK, first things first. First you need to upgrade your kernel to the latest Fedora has to offer, that might solve the whole problem on its own. If that doesn't work post the output of /etc/modprobe.conf and /sbin/lsmod, and we'll go from there.
 
Old 11-19-2004, 05:45 PM   #3
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Original Poster
Rep: Reputation: 15
I typed "yum install kernel" which updated the system and downloaded (and installed) the latest kernel.
I then ran alsaconfig-something-.rpm (which didn't return any errors or warnings) but when i typed
system-config-soundcard i got the same error again.

My podprobe.conf :

alias eth0 tg3
alias scsi_hostadapter sata_via
alias snd-card-0 snd-via82xx
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-1 audio
install audio /sbin/modprobe --ignore-install audio && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove audio { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove audio
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias char-major-195* nvidia

----

The "install install snd-via82xx ..." and " remove snd-via82xx { ... " lines are really wierd.
And if memory serves, my teachers modprobe.conf file is MUCH larger (it was generated by genkernel
install) and his card is working perfectly.

lsmod :

[root@eniac2003 root]# lsmod
Module Size Used by
snd_pcm_oss 47865 0
snd_mixer_oss 17217 3 snd_pcm_oss
snd_via82xx 27365 2
snd_ac97_codec 64529 1 snd_via82xx
snd_pcm 98761 2 snd_pcm_oss,snd_via82xx
snd_timer 30021 1 snd_pcm
snd_page_alloc 9801 2 snd_via82xx,snd_pcm
gameport 5057 1 snd_via82xx
snd_mpu401_uart 8897 1 snd_via82xx
snd_rawmidi 26853 1 snd_mpu401_uart
snd_seq_device 8137 1 snd_rawmidi
snd 54949 9 snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_ac97_c
odec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 10145 3 snd
nvidia 3472412 12
parport_pc 24577 1
lp 11565 0
parport 42249 2 parport_pc,lp
autofs4 24261 0
sunrpc 161701 1
ppp_synctty 10305 0
ppp_async 11457 1
crc_ccitt 2241 1 ppp_async
ppp_generic 35797 6 ppp_synctty,ppp_async
slhc 7105 1 ppp_generic
tg3 85445 0
floppy 58609 0
sg 32609 0
dm_mod 55253 0
uhci_hcd 31577 0
ehci_hcd 31557 0
button 6609 0
battery 8645 0
ac 4933 0
md5 4161 1
ipv6 237569 8
ext3 121033 1
jbd 75481 1 ext3
sata_via 7237 0
libata 40389 1 sata_via
sd_mod 16449 0
scsi_mod 119825 3 sg,libata,sd_mod
[root@eniac2003 root]#

(modprobe snd-via82xx doesnt help).
 
Old 11-19-2004, 06:14 PM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
It looks like the modules are loaded, have you tried a mixer, have you tried alsamixer? You might also try alsaconf.
good luck.
 
Old 11-19-2004, 06:28 PM   #5
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Original Poster
Rep: Reputation: 15
Quote:
...and all channels are un-muted and on max...
I ran alsaconf and selected the VIA-something and C-media CM8-something based soundcards (didn't
know what DMA et.c. settings to enter for the last so i just pressed enter) and it returned:

Loading driver:
Starting sound driver: snd-via82xx done
Starting sound driver: audio FATAL: Module audio not found.
done
No mixer config in /etc/asound.state, you have to unmute your card!
Setting the PCM volume to 100% and the Master output volume to 50%
ALSA lib conf.c:1142:(parse_def) d does not exists
ALSA lib conf.c:1565:(snd_config_load1) _toplevel_:17:10:No such file or directo
ry
ALSA lib conf.c:2807:(snd_config_hook_load) /root/.asoundrc may be old or corrup
ted: consider to remove or fix it
ALSA lib conf.c:2671:(snd_config_hooks_call) function snd_config_hook_load retur
ned error: No such file or directory
ALSA lib conf.c:3036:(snd_config_update_r) hooks failed, removing configuration
amixer: Mixer attach default error: No such file or directory
Could not initialize the mixer, the card was probably
not detected correctly.
[root@eniac2003 bin]#

---

I need all the luck i can get :( .
 
Old 11-19-2004, 06:58 PM   #6
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
Alsa might be loading the wrong module. You need to look at (and post) the output of /sbin/lspci to see exactly what sound chip you have. the reason I say this is because I looked at this alsa page: http://www.alsa-project.org/alsa-doc...C-Media#matrix

and it shows the snd-cmi8330 and snd-cmipci modules being used for C-Media cards. So look at the output of /sbin/lspci and see what card you have.
 
Old 11-20-2004, 05:39 AM   #7
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Original Poster
Rep: Reputation: 15
[root@eniac2003 root]# /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0b.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
00:0e.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
01:00.0 VGA compatible controller: nVidia Corporation NV31 [GeForce FX 5600] (rev a1)
[root@eniac2003 root]#
 
Old 11-20-2004, 08:43 AM   #8
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
OK, I think I see the problem. Looking at your modprobe.conf file again and I think you need to comment out the "install audio" and the "remove audio" lines (just add a # sign to the beginning of each line) like so:

#install audio /sbin/modprobe --ignore-install audio && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
#remove audio { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove audio

I use FC2 and my modprobe.conf doesn't have those lines and I'm positive I'm using Alsa. According to lspci you have the right modules loaded for your card. Try it and see if it works.
 
Old 11-20-2004, 12:33 PM   #9
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Original Poster
Rep: Reputation: 15
I did that a couple of weeks ago and the sound then
stopped working (so the wierd lines are needed).
 
Old 11-20-2004, 08:28 PM   #10
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
Here's a link to a more up to date Alsa configuration page: http://ccrma.stanford.edu/planetccrm...00000000000000

This page is to the CCRMA website at Stanford. The directions are for FC1 and the 2.4 kernel but almost all of them can be used with FC2 and the 2.6 kernel, the only differences is that /etc/modules.conf on 2.4 kernels, is now /etc/modprobe.conf on the 2.6 kernels. If all else fails you might want to think about starting from scratch and reinstalling.
 
Old 11-21-2004, 07:39 AM   #11
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Original Poster
Rep: Reputation: 15
How do i reinstall from scratch?
 
Old 11-21-2004, 03:23 PM   #12
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
I mean't to reinstall linux again. When I first started using linux I would find that simce I didn't know very much about it I would make a mistake and mess the system up somehow. So I would start over from the beginning and reinstall, that way I knew I hadn't mistakenly messed the system up. I must have reinstalled about 10 times before I really started feeling confident about what I was doing and that I wasn't going to screw my system up somehow. That might be your problem right now, you might have inadvertantly done something to mess your sound up and troubleshooting it is very hard even when you have help over the internet. You could try one more thing though, try commenting out the alsa lines in your modprobe.conf file. These are the ones I mean:

alias snd-card-0 snd-via82xx
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx

Then reboot. You have been rebooting after making these changes right?
 
Old 11-21-2004, 03:51 PM   #13
BBB
Member
 
Registered: Aug 2004
Location: sweden
Distribution: Slackware 10.2 and Win2k
Posts: 127

Original Poster
Rep: Reputation: 15
Yes i have rebootet (dude, im migrating from windows so im used to reboot ). Hehe, i have reinstalled
FC2 probally 8 times or so. Now sound works and i figured out how to raise and lower the volume,
but it can stop working after any reboot.

Futhermore i have one more problem. I start XMMS and sound
works great, but there is no sound in Opera. I tried chaning to eSound Daemon in Multimedia System
Selection but then everything sounds horrible and i can't change the volume.

I downloaded the eSound source (why don't people release more binaries? They are so much easier
then source) but when i tried to compile it it sed that it couldn't create a harddlink (permission denied).
 
Old 11-21-2004, 04:43 PM   #14
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Quote:
but it can stop working after any reboot.
Have you tried running alsactl store after setting your mixer up? If so, try adding alsactl restore to your startup scripts.

Quote:
Futhermore i have one more problem. I start XMMS and sound
works great, but there is no sound in Opera. I tried chaning to eSound Daemon in Multimedia System
Selection but then everything sounds horrible and i can't change the volume.
Have a look at this for setting up software mixing.

http://alsa.opensrc.org/index.php?page=FAQ018

Quote:
I downloaded the eSound source (why don't people release more binaries? They are so much easier
then source) but when i tried to compile it it sed that it couldn't create a harddlink (permission denied).
Were you doing this as root or su -?
good luck.
 
Old 11-21-2004, 05:18 PM   #15
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
I wish I had a simple answer for you but I don't. All I can say is that the 2.6 kernel is new and there are bound to be problems like this. But it sounds like your well on your way to learning linux. Do you use apt-get? If not you should look into installing it as it is generally easier to use than other package managers. Look into installing one of the CCRMA kernels also as their especially made for sound and are faster than vanilla kernels because they have performance increasing patches added. Peacedog gave you good advice make sure you follow it. If you start using apt-get here are the CCRMA repositories you need to add to your /etc/apt/sources.list file:

rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 core updates
rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetccrma
rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetcore
rpm-src http://www-ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetccrma
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS driving me mad kkiedrowski Linux - Networking 1 11-27-2005 05:46 PM
battstat driving me mad oookiezooo Linux - Newbie 1 04-15-2005 06:22 AM
kernel is driving me mad luqman Linux - Newbie 6 02-18-2005 05:05 AM
kernel is driving me mad luqman Red Hat 2 02-17-2005 07:00 AM
Alsa driving me mad siphi Linux - Newbie 1 02-19-2004 08:21 PM


All times are GMT -5. The time now is 03:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration