LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-21-2005, 03:50 AM   #1
lhstes
LQ Newbie
 
Registered: Apr 2005
Distribution: FC3,Mandr...iva
Posts: 3

Rep: Reputation: 0
Agere Systems ac'97 modem ? Am I doomed ?


Hi, I've been trying to get my laptop's (acer aspire 1524) modem to work with Fedora Core 3 64-bit. In the WinXP taskmanager it says Agere Systems ac'97 and from the at commands i found : ATI3 : Agere SoftModem Version 2.1.47.9, ATI5 : 2.1.47.9, AMR Via MB, AC 97, ATI7: AMR Via MB
and the following
MODEM #1:
PCI CONFIGURATION INFORMATION READ:
VENDOR ID : 1106
DEVICE ID : 3068
SUBVENDOR ID : 1025
SUBDEVICE ID : 0046
REVISION ID : 80

DEDUCED INFORMATION:
VENDOR NAME : VIA
DEVICE NAME : VIA
SUBVENDOR NAME : ACER --]
MODEM TYPE : UNKNOWN
WINXP INBUILD SUPPORT : NO

Should I gather any more info (and how) ? Is there anything to be done or is it never going to work ? Please, keep it simple, I'm a total noob with linux. Thank you very much and congrats on the great job done in here !
 
Old 05-07-2005, 12:49 PM   #2
lhstes
LQ Newbie
 
Registered: Apr 2005
Distribution: FC3,Mandr...iva
Posts: 3

Original Poster
Rep: Reputation: 0
Nothing ? Not even a few links for me to start searching ?? Thanks !
 
Old 05-07-2005, 02:23 PM   #3
piscikeeper
Member
 
Registered: Jul 2003
Location: indiana,usa
Distribution: SuSE 11,Slack,Mint
Posts: 425

Rep: Reputation: 30
how about if i told you agre was in the process of writing a linux driver?unfortunately that process has gone on for nearly 4 years without a single release from them.basicly,you're doomed.
a nice external serial modem would do wonders to simplify the install.
 
Old 05-07-2005, 05:25 PM   #4
lhstes
LQ Newbie
 
Registered: Apr 2005
Distribution: FC3,Mandr...iva
Posts: 3

Original Poster
Rep: Reputation: 0
Not exactly the worst of cases then, maybe in the future it will work. In the meanwhile, any suggestions for a pcmcia rather than a serial modem ? Thank you very much for the answer !
 
Old 07-09-2005, 03:13 AM   #5
fani
LQ Newbie
 
Registered: Jul 2005
Location: Greece
Posts: 13

Rep: Reputation: 0
slmodem-2.9.9d.tar.gz

I have the same modem in Acer 1360. It works if you download and install slmodem-2.9.9d.tar.gz. I use mandriva.

After installation you must run 'modprobe slamr' and 'slmodemd -c=YourCountry' and leave the shell open

After that you can use Kppp. It works
 
Old 07-09-2005, 06:50 AM   #6
ntpatati
LQ Newbie
 
Registered: Jul 2005
Location: vietnam
Distribution: SUSE 9.3
Posts: 4

Rep: Reputation: 0
With the sourcepack for slmodem come some startup scripts, for mandrake too, as far as I rember: they load the module and start the daemon in the background during startup, so you do not have to have the shell with the process open.
 
Old 07-15-2005, 11:05 AM   #7
doctorberen
LQ Newbie
 
Registered: Jul 2005
Location: Tennessee, United States
Posts: 3

Rep: Reputation: 0
Fani,

I'm using xandros and I installed the xandros version of the file you specified.

My modem was detected and is now usable.

However, it's quite quirky. It disconnects easily. Also at times, it is very difficult to connect. Have you encountered similar problems?
 
Old 07-17-2005, 05:00 AM   #8
fani
LQ Newbie
 
Registered: Jul 2005
Location: Greece
Posts: 13

Rep: Reputation: 0
No, I didn't have that problem. At first I was connected but couldn't browse. I unistalled everything about the firewall and then I could browse.
I don't know maybe if you try to change firewall settings??
Or try the scenario option from Kppp???
I don't know. Sorry!!!!
 
Old 08-10-2005, 08:32 AM   #9
Etenil
LQ Newbie
 
Registered: Aug 2005
Location: France
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
Hello,

I have the same problem on my notebook Presario R3000 and I just downloaded the slmodem. But I can't install it, the konsole says:

make[2]: Entering directory `/home/guillaume/slmodem-2.9.9d/drivers'
make modules -C /lib/modules/2.6.11.4-21.7-default/build SUBDIRS=/home/guillaume/slmodem-2.9.9d/drivers
make[3]: Entering directory `/usr/src/linux-2.6.11.4-21.7-obj/i386/default'
make[3]: *** Pas de règle pour fabriquer la cible « modules ». Arrêt.
make[3]: Leaving directory `/usr/src/linux-2.6.11.4-21.7-obj/i386/default'
make[2]: *** [all] Erreur 2
make[2]: Leaving directory `/home/guillaume/slmodem-2.9.9d/drivers'
make[1]: *** [all] Erreur 2
make[1]: Leaving directory `/home/guillaume/slmodem-2.9.9d/drivers'
make: *** [drivers] Erreur 2

Is there sombody to help me? I have the Suse 9.3 in 32 bits. thanks
 
Old 08-10-2005, 11:56 PM   #10
fani
LQ Newbie
 
Registered: Jul 2005
Location: Greece
Posts: 13

Rep: Reputation: 0
Have you installed the kernel source from your linux cds?
 
Old 08-11-2005, 04:44 AM   #11
Etenil
LQ Newbie
 
Registered: Aug 2005
Location: France
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
Well, I don't think so, I'll do it and try again, thank you
 
Old 08-16-2005, 09:02 AM   #12
Etenil
LQ Newbie
 
Registered: Aug 2005
Location: France
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
I just installed the kernel sources and I installed slmodem easily. I just have a problem with the configuration.

konsole says the following lines when I try to setup the modem country

linux:/home/guillaume # slmodemd --country=FRANCE /dev/slamr0
error: mdm setup: cannot open dev `/dev/slamr0': No such device
error: cannot setup device `/dev/slamr0'

and, when I run dmesg, I read this lines about slamr:

slamr: unsupported module, tainting kernel.
slamr: module license 'Smart Link Ltd.' taints kernel.
slamr: SmartLink AMRMO modem.

I have read the readme of slmodem but I didn't find anything to make it work. If somebody has an idea...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
difficulties in modem instalation Agere systems PCI soft modem mcstanoye Suse/Novell 2 02-01-2007 10:48 AM
Agere Systems AC'97 Modem on HP Compaq nx9105 RealSQUALL Linux - Laptop and Netbook 2 04-15-2005 03:21 PM
Install Agere AC'97 Modem on IBM R40 in Fedora Core 1? gorillaman99 Linux - Laptop and Netbook 0 04-18-2004 10:43 AM
Can I access internet with Agere AC'97 Modem, RH 9.0, on IBM A31 Laptop? halmin Linux - Newbie 0 07-27-2003 10:05 AM
Can I access? internet with Agere AC'97 Modem, RH 9.0, on IBM A31 Laptop? halmin Linux - Laptop and Netbook 0 07-27-2003 09:46 AM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration