LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-02-2007, 06:53 PM   #1
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 218

Rep: Reputation: 30
Adding event node for Synaptics touchpad


Hi!
I managed to make my synaptics driver work by creating some event nodes in /dev/input, with mknod. After I restarted X, the touchpad worked perfectly with all synaptics functions. After I rebooted, the nodes weren't there anymore, and the synaptics driver wasn't loaded.
How do i tell the kernel to create those event nodes at boot-time?
Thanks to everyone!
 
Old 01-02-2007, 07:01 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
How are you doing each of these things you are doing? From a command line as root or as a user? List the commands you are using. How and where are you loading the synaptics module?

Brian
 
Old 01-03-2007, 06:10 AM   #3
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 218

Original Poster
Rep: Reputation: 30
I did everthing as root. First of all, I edited xorg.conf:
I added:

Code:
Section "InputDevice"
        Identifier  "Synaptics Mouse"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "ZAxisMapping" "4 5"
        Option      "LeftEdge" "1700"
        Option      "RightEdge" "5300"
        Option      "TopEdge" "1700"
        Option      "BottomEdge" "4200"
        Option      "FingerLow" "25"
        Option      "FingerHigh" "30"
        Option      "MaxTapTime" "180"
        Option      "MaxTapMove" "220"
        Option      "VertScrollDelta" "100"
        Option      "MinSpeed" "0.09"
        Option      "MaxSpeed" "0.18"
        Option      "TapButton2" "3"
        Option      "TapButton3" "2"
        Option      "AccelFactor" "0.0015"
        Option      "SHMConfig" "on"
#  Option       "Repeater"      "/dev/ps2mouse"
EndSection

And, in section ServerLayout:

Code:
InputDevice    "Mouse1" "CorePointer"
InputDevice    "Synaptics Mouse" "AlwaysCore"
InputDevice    "Keyboard1" "CoreKeyboard"
But at first, this didn't work, and 'cat /var/log/Xorg.0.log | grep Synaptics' said that:

Code:
(**) |-->Input Device "Synaptics Mouse"
(II) Synaptics touchpad driver version 0.14.4 (1404)
Synaptics Mouse no synaptics event device found (checked 10 nodes)
Synaptics Mouse The /dev/input/event* device nodes seem to be missing
Query no Synaptics: 6003C8
(EE) Synaptics Mouse no synaptics touchpad detected and no repeater device
(EE) Synaptics Mouse Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Synaptics Mouse"
So I googled for this, and somebody said that the problem was the absence of /dev/input/eventX, where X is 0,1,2, the first one available...
In /dev/input there were mice, event0, mouse0, and I added (with mknod) event1. I restarted X (DIDN'T REBOOT!) and the Synaptics driver was loaded correctly by X. Then I rebooted, and the event nodes weren't there anymore!

I thought of editing my /etc/rc.d/rc.local (it's loaded at boot-time) in order to run mknod, but I wanted to know if there is a better way to solve this problem.

Thanks!
 
Old 01-03-2007, 06:16 AM   #4
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 218

Original Poster
Rep: Reputation: 30
When I say mknod, i mean:

Code:
# mknod /dev/input/event0 c 13 64
# mknod /dev/input/event1 c 13 65
# mknod /dev/input/event2 c 13 66
...
 
Old 01-03-2007, 04:57 PM   #5
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
If all you need to do was to run the mknod commands and then start X then the best place is to place them in /etc/rc.local. Use the full path to the mknod command when inserted in the rc.local file. Usually in /bin but may differ distro to distro.

Brian
 
Old 01-05-2007, 04:45 AM   #6
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 218

Original Poster
Rep: Reputation: 30
Thank you, it works now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 04:15 PM
synaptics touchpad with 2.6.14 dracolich Linux - General 10 11-11-2005 02:46 PM
Synaptics touchpad beatupbilly Linux - Hardware 6 11-28-2004 12:43 PM
Synaptics Touchpad beatupbilly Fedora 2 01-15-2004 12:14 AM
synaptics touchpad d_lake Linux - Hardware 5 02-09-2003 12:01 AM


All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration