LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Adding event node for Synaptics touchpad (http://www.linuxquestions.org/questions/linux-hardware-18/adding-event-node-for-synaptics-touchpad-515720/)

simopal6 01-02-2007 05:53 PM

Adding event node for Synaptics touchpad
 
Hi!
I managed to make my synaptics driver work by creating some event nodes in /dev/input, with mknod. After I restarted X, the touchpad worked perfectly with all synaptics functions. After I rebooted, the nodes weren't there anymore, and the synaptics driver wasn't loaded.
How do i tell the kernel to create those event nodes at boot-time?
Thanks to everyone!

Brian1 01-02-2007 06:01 PM

How are you doing each of these things you are doing? From a command line as root or as a user? List the commands you are using. How and where are you loading the synaptics module?

Brian

simopal6 01-03-2007 05:10 AM

I did everthing as root. First of all, I edited xorg.conf:
I added:

Code:

Section "InputDevice"
        Identifier  "Synaptics Mouse"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "ZAxisMapping" "4 5"
        Option      "LeftEdge" "1700"
        Option      "RightEdge" "5300"
        Option      "TopEdge" "1700"
        Option      "BottomEdge" "4200"
        Option      "FingerLow" "25"
        Option      "FingerHigh" "30"
        Option      "MaxTapTime" "180"
        Option      "MaxTapMove" "220"
        Option      "VertScrollDelta" "100"
        Option      "MinSpeed" "0.09"
        Option      "MaxSpeed" "0.18"
        Option      "TapButton2" "3"
        Option      "TapButton3" "2"
        Option      "AccelFactor" "0.0015"
        Option      "SHMConfig" "on"
#  Option      "Repeater"      "/dev/ps2mouse"
EndSection


And, in section ServerLayout:

Code:

InputDevice    "Mouse1" "CorePointer"
InputDevice    "Synaptics Mouse" "AlwaysCore"
InputDevice    "Keyboard1" "CoreKeyboard"

But at first, this didn't work, and 'cat /var/log/Xorg.0.log | grep Synaptics' said that:

Code:

(**) |-->Input Device "Synaptics Mouse"
(II) Synaptics touchpad driver version 0.14.4 (1404)
Synaptics Mouse no synaptics event device found (checked 10 nodes)
Synaptics Mouse The /dev/input/event* device nodes seem to be missing
Query no Synaptics: 6003C8
(EE) Synaptics Mouse no synaptics touchpad detected and no repeater device
(EE) Synaptics Mouse Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Synaptics Mouse"

So I googled for this, and somebody said that the problem was the absence of /dev/input/eventX, where X is 0,1,2, the first one available...
In /dev/input there were mice, event0, mouse0, and I added (with mknod) event1. I restarted X (DIDN'T REBOOT!) and the Synaptics driver was loaded correctly by X. Then I rebooted, and the event nodes weren't there anymore!

I thought of editing my /etc/rc.d/rc.local (it's loaded at boot-time) in order to run mknod, but I wanted to know if there is a better way to solve this problem.

Thanks!

simopal6 01-03-2007 05:16 AM

When I say mknod, i mean:

Code:

# mknod /dev/input/event0 c 13 64
# mknod /dev/input/event1 c 13 65
# mknod /dev/input/event2 c 13 66
...


Brian1 01-03-2007 03:57 PM

If all you need to do was to run the mknod commands and then start X then the best place is to place them in /etc/rc.local. Use the full path to the mknod command when inserted in the rc.local file. Usually in /bin but may differ distro to distro.

Brian

simopal6 01-05-2007 03:45 AM

Thank you, it works now!


All times are GMT -5. The time now is 04:25 PM.