LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-12-2004, 07:32 PM   #1
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Rep: Reputation: 30
Adding drive / Linux won't recognize


[Fedora Core 1]

After installing a second drive with exsisting data ( Windows) on secondary master IDE controller, linux will not recognize it.

When in list the ide devices I get

[root@mikedlinuxbox /]# ls /proc/ide
ali drivers hda hdb hdc ide0 ide1
[root@mikedlinuxbox /]#

Which it "sees" hdc - secondary hard drive


But when I try to view partition table I get:
[root@mikedlinuxbox /]# /sbin/fdisk -l /dev/hdc1
[root@mikedlinuxbox /]#

When I try to view sectors I get:
[root@mikedlinuxbox /]# /sbin/fdisk -u /dev/hdc1

Unable to open /dev/hdc1
[root@mikedlinuxbox /]#

This drive is set to master, it is in working order.

I am hoping to export data from this drive to my linux box, but linux does not see it?
Could this be a permissions issue since windows is installed on it?

What should I try next?

Thanks!

Mike D.
 
Old 04-12-2004, 07:48 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,575

Rep: Reputation: 184Reputation: 184
" /sbin/fdisk -l /dev/hdc1"
"What should I try next?"

Try refering to the hard drive as /dev/hdc. /dev/hdc1 is a partition.

/sbin/fdisk -l /dev/hdc

/sbin/fdisk -u /dev/hdc

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-12-2004, 07:49 PM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
try fdisk /dev/hdc
hdc1 is the first partition of that drive, not the device. You have to mount the device.

To "see" the Windows drive and be able to mount it, you'll have to add it to /etc/fstab.
Open the file with your favorite editor and add a line to refer to the partition. Sorry, but the only way I know to have it properly mounted and available is to reboot when you're done. I know there is a way to do it without rebooting, but I haven't needed to read that much. Try this:
Make a "mountpoint" in /mnt, say, /mnt/win
Open /etc/fstab with your favorite editor.
add
Code:
/dev/hdc1 /mnt/win ntfs users,ro 0 0
If fat32, replace ntfs with vfat.
Should work. After this, we'll work on getting Windows from the bootprompt, if you want.
 
Old 04-12-2004, 07:51 PM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Heh heh. We've bumped into the same answer before.
 
Old 04-12-2004, 08:04 PM   #5
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
Thanks

Thanks for the advice!!!!

First thanks for correcting me on the hdc1/ hdc.

Rebooted

After correcting that i got:
[root@mikedlinuxbox mnt]# /sbin/fdisk -l /dev/hdc
[root@mikedlinuxbox mnt]#

Here is a copy of my etc/fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/downloads /downloads ext3 defaults 1 2
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr/local /usr/local ext3 defaults 1 2
/dev/hdb7 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,user,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,user,kudzu,ro 0 0
/dev/hdd /mnt/cdrom auto ro,noauto,user,exec 0 0
/dev/scd0 /mnt/cdrom1 auto ro,noauto,user,exec 0 0
/dev/hdc /mnt/win vfat user,ro 0 0

When I try to mount hdc as root I get

Something like mount : /dev/hdc is not a valid block device

I have added the directory
hdc and win to /mnt

Thanks in advance!

Mike

Last edited by mikedeatworld; 04-12-2004 at 08:18 PM.
 
Old 04-12-2004, 08:12 PM   #6
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
drive format

This drive was from a Windows ME machine. I am pretty sure that it is FAT32.
 
Old 04-12-2004, 08:26 PM   #7
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,575

Rep: Reputation: 184Reputation: 184
"[root@mikedlinuxbox mnt]# /sbin/fdisk -l /dev/hdc
[root@mikedlinuxbox mnt]#"

I don't think that Linux is detecting your drive. You can list any boot messages that pertain to /dev/hdc with:

dmesg | grep hdc

and see what Linux thought of hdc at boot, if it even noticed it.

If dmesg comes up empty then look at your BIOS and see if the BIOS knows that hdc exists. If it does not then the best BIOS setting is probably AUTO which means auto-detect.

Once you detect /dev/hdc correctly then you have to solve the partition format type in /etc/fstab or the mount command as described by vectordrake.

vectordrake:

Where in N.B. do you live? I lived for 12 years in Passakeag which is half way between Sussex and Saint John.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

Last edited by jailbait; 04-12-2004 at 09:43 PM.
 
Old 04-12-2004, 08:33 PM   #8
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
Thanks!

[root@mikedlinuxbox miked]# dmesg | grep hdc
Kernel command line: ro root=LABEL=/ hdc=ide-scsi rhgb
ide_setup: hdc=ide-scsi
ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdcMA, hddio
hdc: FUJITSU MPE3064AT, ATA DISK drive
hdc:end_request: I/O error, dev 16:00 (hdc), sector 0
end_request: I/O error, dev 16:00 (hdc), sector 2
end_request: I/O error, dev 16:00 (hdc), sector 4
end_request: I/O error, dev 16:00 (hdc), sector 6
end_request: I/O error, dev 16:00 (hdc), sector 0
end_request: I/O error, dev 16:00 (hdc), sector 2
end_request: I/O error, dev 16:00 (hdc), sector 4
end_request: I/O error, dev 16:00 (hdc), sector 6
[root@mikedlinuxbox miked]#



That doesn't look good....
 
Old 04-12-2004, 09:01 PM   #9
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Oromocto, actually. Between St John and Fredericton. Lived around here since 1988. Didn't list my location very closely before, but got pissed about someone coming in here once with mean things to say about another forum member and wouldn't reveal anything about themselves at all. I decided that I'd tell where I'm from. Heh heh. Kinda come-and-get-me thing. Only live once.
 
Old 04-12-2004, 09:07 PM   #10
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Try turning off plug and play in your BIOS and see if that helps. BTW, I have a similar drive. Looks like the same modelling, different size. Mine had some kind of Ontrack boot software on it and it was a real bitch to get rid of. Once I succeeded in overwriting it, I got a decent drive out of the deal.

May sound silly, but are the jumpers set right?
 
Old 04-12-2004, 09:49 PM   #11
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,575

Rep: Reputation: 184Reputation: 184
"Kernel command line: ro root=LABEL=/ hdc=ide-scsi rhgb
ide_setup: hdc=ide-scsi"

You still have /dev/hdc set up as a cd-rw. You need to edit /etc/lilo.conf or /boot/grub/grub.conf and change hdc=ide-scsi to wherever your cd-rw went. According to fstab it went to /dev/hdd.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-12-2004, 10:01 PM   #12
mikedeatworld
Member
 
Registered: Nov 2003
Location: Farmington Michigan
Distribution: UBUNTU - Slackware - SuSE 9.1 - Knoppix - Fedora
Posts: 828

Original Poster
Rep: Reputation: 30
I will post my results tomorrow...going to bed. Thanks a ton for the advice!!!!!!!!!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you get Suse linux 9.0 to recognize a USB ZIP Drive Awwwesome Linux - Hardware 2 11-15-2004 04:28 PM
How do I get different Linux OS to recognize my C:/ (c drive is a fat32)? sjia Linux - Newbie 3 02-22-2004 10:07 AM
Adding windows to linux drive fstreed Linux - General 3 01-09-2003 09:22 PM
adding new hard drive to existing linux box jaysan Linux - Newbie 2 08-09-2001 07:27 PM
Adding a new hard drive to a win98 box to install linux jcrash Linux - Newbie 3 01-14-2001 04:27 AM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration