LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-20-2006, 07:35 PM   #1
ash.furrow
LQ Newbie
 
Registered: Jul 2006
Distribution: Kubuntu
Posts: 10

Rep: Reputation: 0
Acer 5002 wireless radio disabled


Hi, there. I'm using an Acer 5002, and I recently switched from FC5 to Kubuntu. In FC5, I had ndiswrapper installed and working fine, but when I installed kubuntu, it recognized my wireless nic. Cool. SO, anyways, I think that everything's working, but whenever I'm in systemsettings and enable eth1 (wireless), it enables for just a moment, and then disables again. I believe that my radio is disabled, as my lshw output is:
*-network:1 DISABLED
description: Wireless interface
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: b
bus info: pci@00:0b.0
logical name: eth1
version: 02
serial: <snip>
width: 32 bits
clock: 33MHz
capabilities: bus_master ethernet physical wireless
configuration: broadcast=yes driver=bcm43xx multicast=yes wireless=IEEE 802.11b/g
resources: iomemory:e2000000-e2001fff irq:217
iflist eth1 scanning says that eth1 doesn't support scanning. Wierd.

TIA for the help.
 
Old 08-20-2006, 08:25 PM   #2
darthmandeep
LQ Newbie
 
Registered: Nov 2005
Posts: 12

Rep: Reputation: Disabled
(K)Ubuntu comes with the bcm43xx driver for Broadcom cards, which requires you to get and install firmware for it to work.

IMHO, for now you're better off disabling the bcm43xx driver by adding it to /etc/modprobe.d/blacklist and typing "rmmod bcm43xx" in a terminal, then using ndiswrapper as normal.
 
Old 08-20-2006, 09:09 PM   #3
ash.furrow
LQ Newbie
 
Registered: Jul 2006
Distribution: Kubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
Ok. I blacklisted the module, and did a clean install of the windows drivers.

ndiswrapper -i bcmwl5a.inf
ndiswrapper -l
<everything ok>
depmod -a
modprobe ndiswrapper
<ok>
dmesg | grep -i ndiswrapper ** returned the following text:

[17179592.520000]ndiswrapper version 1.8 loaded (preempt=yes, smp=no)
I'm going to reset the machine for ood mesure and get back to you.
Thanks again
 
Old 08-20-2006, 09:27 PM   #4
ash.furrow
LQ Newbie
 
Registered: Jul 2006
Distribution: Kubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
OK - I restarted the computer, but it's still not working. dmesg returns ok and says that ndiswrappedr is loaded as alias wlan0. However, wlan0 is not listed in iwconfig. it's really weird. modprobe -l shoes ndiswrapper is loaded, but I can't config it - the only wireless extension is eth1, which is the one that came with the installation. Please help
 
Old 08-21-2006, 08:13 AM   #5
ash.furrow
LQ Newbie
 
Registered: Jul 2006
Distribution: Kubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
ok - when I install the drivers for windows, here is my exact command output:

root@ash-laptop:/home/ash# ndiswrapper -i /home/ash/drivers/80211/bcmwl5a.inf
Installing bcmwl5a
Forcing parameter IBSSGMode|0 to IBSSGMode|2
Forcing parameter IBSSGMode|0 to IBSSGMode|2
root@ash-laptop:/home/ash# depmod -a
root@ash-laptop:/home/ash# modprobe ndiswrapper
root@ash-laptop:/home/ash# dmesg | grep -i ndiswrapper
[17179591.332000] ndiswrapper version 1.8 loaded (preempt=yes,smp=no)
[17179591.440000] ndiswrapper: driver bcmwl5a (Broadcom,12/22/2004, 3.100.46.0) loaded
[17179591.448000] ndiswrapper: using irq 217
[17179592.452000] wlan0: ndiswrapper ethernet device <snip> using driver bcmwl5a, 14E4:4318.5.conf
root@ash-laptop:/home/ash# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSIDff/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

root@ash-laptop:/home/ash#

As you can see, ndiswrapper is using the alias wlan0, but kubuntu is only seeing it's eth1 as wireless. Please help
 
Old 08-21-2006, 01:02 PM   #6
darthmandeep
LQ Newbie
 
Registered: Nov 2005
Posts: 12

Rep: Reputation: Disabled
I can't remember how to set wlan0 to be an alias to eth1, sorry.

Does the eth1 interface work though? Does "iwlist eth1 scan" pickup anything? If so, I wouldn't worry about what name it's using. I've got a couple of machines using ndiswrapper with Broadcom cards in Ubuntu that have the wireless device called eth0 or eth1. Makes no real difference as far as I can tell.
 
Old 08-21-2006, 10:54 PM   #7
ash.furrow
LQ Newbie
 
Registered: Jul 2006
Distribution: Kubuntu
Posts: 10

Original Poster
Rep: Reputation: 0
iwlist eth1 scanning says returns "No Results". It's weird, because the eth1 alias was there before I installed the river for ndiswrapper, but the ndiswrapper hasn't added any alias's. I've tried manually editing the /etc/ndiswrapper/bcmwl5a/<config file> in order to enable the radio, but to no avail.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acer TM2420 wireless radio not switching on but driver seems fine in Mandriva 2006 pigdogza Linux - Wireless Networking 2 07-12-2006 11:31 AM
Wireless LAN on the Acer Aspire 5002 Macxpower Linux - Hardware 1 05-25-2006 07:26 PM
Wireless in ubunto or inprocom wireless in a acer theman990 Ubuntu 0 10-04-2005 05:01 AM
Wireless Radio - What is it? Arrowx7 Linux - Wireless Networking 2 08-14-2005 09:50 PM
IBM T40 Wireless ... 'radio is disabled' wa03 Linux - Wireless Networking 0 10-23-2003 12:01 AM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration