Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 04-05-2003, 08:45 AM   #1
LQ Newbie
Registered: Apr 2003
Location: Finland
Distribution: Slackware 8.1
Posts: 1

Rep: Reputation: 0
ac97+alsa problems

I'm having some trouble with the sound. When I'm trying to play a song(.mp3) the soundreproduction is irregular. The sound repeats itself many times before it "moves on". It's kind of hard to explain, especially when I'm not so good at English. For example if a song should sound like "pling-plong" I hear at least twenty plings before I hear the first plong. I have installed alsa's drivers v.0.9.1(driver,lib,tools,utils). I have an ac97 sound card integrated in a via8233 southbridge and I'm using mpg321 and mp3blaster to play my mp3's.

My /etc/modules.conf:
# --- BEGIN: Generated by ALSACONF, do not edit. ---# --- ALSACONF verion 0.9.0 ---
alias char-major-116 snd
alias snd-card-0 snd-via82xx
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
options snd major=116 cards_limit=1 device_mode=0666
options snd-via82xx index=0
# --- END: Generated by ALSACONF, do not edit. ---

Module Size Used by Not tainted
snd-pcm-oss 37316 1 (autoclean)
snd-mixer-oss 11576 1 (autoclean) [snd-pcm-oss]
snd-via82xx 10412 2
snd-pcm 54912 0 [snd-pcm-oss snd-via82xx]
snd-timer 14440 0 [snd-pcm]
snd-ac97-codec 31264 0 [snd-via82xx]
snd-mpu401-uart 2736 0 [snd-via82xx]
snd-rawmidi 12896 0 [snd-mpu401-uart]
snd-seq-device 3988 0 [snd-rawmidi]
snd 27268 0 [snd-pcm-oss snd-mixer-oss snd-via82xx snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3556 4 [snd]
snd-page-alloc 4224 0 [snd-via82xx snd-pcm]

I hope you understand my problem, and manage to solve it to


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
(AC97) VIA sound [alsa] driver okasion Linux - Hardware 2 12-23-2004 03:14 AM
Sound driver but not ALSA for AC97 caovankhanhvn Slackware 6 08-15-2004 05:11 AM
Alsa problems AC97!!! GoinEasy9 Linux - General 10 03-23-2004 02:52 PM
AC97 on A7V8X-X, alsa .. help please~~~ Tunick Linux - Hardware 1 08-04-2003 03:24 PM
Debian, ALSA, AC97 = no sound Caidence Linux - Hardware 2 07-24-2003 03:52 PM

All times are GMT -5. The time now is 09:11 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration