LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-27-2005, 08:05 PM   #1
Vexamus
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Rep: Reputation: 0
AC'97 Conexant audio (aka, AC-Link Audio) (Gateway 7510GX)


Hey folks, been fighting with this for a few hours now, I was hoping I wasn't the first one. I've been doing a ton of searching and I thought I'd give it a go.

A little background on my hardware and it's quirks.

The laptop is a Gateway 7510GX with a Conexant AC-Link audio.

FC4 sees the card as unknown device number (some 4 digits here). But.. the sound works beatifully. Why don't I use FC? It's not SuSe 10 64 bit, which is what I"m using now, I have everything running great on here. Clock's running at normal earth speed, lol, I have full 3d accelleration from my ATI x600, the touch pad works properly, but there's no sound...

Background on the issue with sound. When I had XP Pro x64 installed the sound wouldn't work unless I put the computer to sleep first then it would work, there were no errors of any type and it was able to properly detect and access the card.

I have roughly the same issue here. The card is detected in x86_64 SuSe 10 as "ATI IPX AC97" with the chip being noted as the Conexant id 30.

The lappy has the ATI SB400 mobo and thus all the devices are ATI branded.

There are no errors when initializing the sound or running alsaconf, etc it LOOKs as though it should be working, however, it doesn't sound like it.

Does anyone have any ideas for me? I'm fairly new to linux but learning fast. I'm a Micro$oft engineer.. I've reinstalled linux on this laptop a good 20 times getting it right and right. Once I get everything working I'd like to recompile my kernal to help streamline my system.

On a side note.. What's the big advantage of recompiling all your drivers into your kernal? What are the big risks? could I say, possibly share my kernel with other users of the 7510GX?

Anyway, thanks for any help!!
 
Old 10-28-2005, 01:31 PM   #2
Wally68
Member
 
Registered: Dec 2003
Location: BC, Canada
Distribution: slack
Posts: 40

Rep: Reputation: 15
"Expanding my horizons for the sake of the free world... Good bye windows.."


Sorry I can't help you, but I'm glad the butterflies are out of your head. You'll be able to see much clearer now. Let me be the first to welcome you to the free world.
 
Old 10-28-2005, 11:46 PM   #3
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Re: AC'97 Conexant audio (aka, AC-Link Audio) (Gateway 7510GX)

Sorry to hijack your thread. I also have a 7510GX. I started with Suse 10 64-bit, but I scrubbed that project after I could get neither sound nor integrated wireless correctly to work. I then turned to Suse 10 32-bit and experienced similar results. I am now running FC4 32-bit. I have sound, wired networking, and hardware acceleration for the x600, but I would really like to get wireless networking to work as well.

I haven't been able to get the 7510GX's integrated wireless to work under any linux distro. Would you mind briefly outlining your approach?
 
Old 10-29-2005, 05:34 AM   #4
mbeltagy
Member
 
Registered: Oct 2005
Distribution: SUSE
Posts: 31

Rep: Reputation: 15
Unhappy

I am also struggling trying to get my 7510gx to fully function under SUSE 10 using 64 bit distro. I looked up various forums for all the different pieces of hardware, but I still can not get most of the stuff to work.

For the ATI x600 video card, I tried the most recent drivers from ATI, but 3d is still is not working. I was disheartened to know that it may never be possible to do that http://forums.suselinuxsupport.de/in...8&hl=ati+x600.

For wireless, I tried ndswrapper but that still does not work. I dont know if I using the correct driver or what.

The modem doesnt work, and neither does the sound. I have suspicion that the two are related.

I am new to linux, and getting all the bits and pieces to work is proving to be a great challenge.

Please advise.
 
Old 10-29-2005, 05:55 AM   #5
Vexamus
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Stand by guys, I'll give you a detailed post as to how I got my wifi working when I get off work later today. Yes, that's right... my wifi works under SuSE 10 64-bit. I'd like sound too...
 
Old 10-29-2005, 08:03 AM   #6
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by mbeltagy
I am also struggling trying to get my 7510gx to fully function under SUSE 10 using 64 bit distro. I looked up various forums for all the different pieces of hardware, but I still can not get most of the stuff to work.

For the ATI x600 video card, I tried the most recent drivers from ATI, but 3d is still is not working. I was disheartened to know that it may never be possible to do that http://forums.suselinuxsupport.de/in...8&hl=ati+x600.

For wireless, I tried ndswrapper but that still does not work. I don�t know if I using the correct driver or what.

The modem doesn�t work, and neither does the sound. I have suspicion that the two are related.

I am new to linux, and getting all the bits and pieces to work is proving to be a great challenge.

Please advise.
This is great to find other 7510gx-ers out there. I could never get wireless drivers to work. I tried six or seven different options with no luck. The Conexant drivers almost worked--but I never got a IP lease from my DHCP server, and I didn't want to pay money for a license.

For sound under Suse 10-64, have you tried muting the "External Amp" line? Although I never got sound working under Suse 10, I initially had similar problems when I switched to FC4, and muting that line seemed to fix them (in particular, it seems like muting the line through Gnome's volume control utililty worked, but muting it through the similar KDE tool, or alsamixer didn't? I know that sounds confusing and probably just wrong, but that is my recollection). I never got a chance to try it under Suse 10. Might be worth a shot.

Ok, looking forward to reading about how wireless can be done...

Edit: Oh yeah, I was able to get integrated wireless working for the first time last night under the Knoppix LiveCD! Good grief. Yes, I am actually tempted to install it to a bootable partition . . . (I am a student, which makes me very mobile during the day. No wireless means no Internet for much of the time that I need it)

Last edited by mikeh2; 10-29-2005 at 08:17 AM.
 
Old 10-29-2005, 01:44 PM   #7
mektigmuse
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
No sound with AC-Link Audio

Although, I don't have a Gateway 7510GX, I do have a Gateway 7322GZ. I too am having problems with my AC-Link Audio. No sound whatsoever. I am running SUSE 10. I have been able to get my integrated wireless card (Broadcom 54g) to work using ndiswrapper. I am currently installing the HSF Softmodem drivers from linuxant which will hopefully help. If not, I'm going to try another distro. I'm waiting until mandriva releases their 2006 images. If that works, I'll go with them. I'll check out Fedora too...
 
Old 10-29-2005, 04:15 PM   #8
mbeltagy
Member
 
Registered: Oct 2005
Distribution: SUSE
Posts: 31

Rep: Reputation: 15
Quote:
Originally posted by mikeh2

For sound under Suse 10-64, have you tried muting the "External Amp" line? Although I never got sound working under Suse 10, I initially had similar problems when I switched to FC4, and muting that line seemed to fix them (in particular, it seems like muting the line through Gnome's volume control utililty worked, but muting it through the similar KDE tool, or alsamixer didn't? I know that sounds confusing and probably just wrong, but that is my recollection). I never got a chance to try it under Suse 10. Might be worth a shot.
it)
Cheers mikeh2, I am glad there is are a few of 7510gx-ers out there too. I have been googling for weeks looking for anything on running Linux on 7510gx and came up with nothing useful.

Muting the external-amp worked !!!! ..... I used KMix and it did the trick. It sure feels great to have sound. If only I could get wirless, modem, and 3-D graphics to work as well !!! Hope Vexamus will show us the way.

Cheers
 
Old 10-29-2005, 06:14 PM   #9
Vexamus
LQ Newbie
 
Registered: Oct 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Turning off the external amp worked for me, YES YES YES YES!!!! I now have every device functioning properly.... 100% w00t!!!!

Ok...

Now, steps for getting wifi to work, (3d accelleration to come next).

K, To be clear the 7510GX comes with a Broadcom 4318 chipset dubbed "AirForce One" Ghey, I know. And this tut is for SuSE 10.0 64 bit running 2.6.13-15 Kernel. Anyway, you'll want to use the lastest 64 bit driver(you 32 bit kids are out of luck as I have yet to mess with 32 bit linux on this machine so i don't know, this may or may not work for you.). With either ndiswrapper or driverloader you have to use the 64 bit binaries of the windows drivers. For 64 bit you're only going to need the bcmwl5.inf and the bcmwl568.sys or some shit... it's not like the others, anyway. Just download the latest 64 bit driver from my site, so I know you can get to them. http://www.dev-hack.com/wifi64.zip

once you get them on your linux box extract them wherever you want.

First things first. Login as or su to root, you're gonna need it. If you get compile errors, chances are you're not root. I've had little success with ndiswrapper on suse 10-64, it worked fine on FC4 and may work with this method that I use for initializing the card manually in the proper order. You do this wrong and it really does a number on your kernal(machine won't boot again normally, have to safemode it and manually remove the module). I used Linuxant driverloader, but for me it's been worth the 20 bucks because it really is worry free it takes care of linking your modules with your kernal source directory in case you didn't already.

But.. before you start compiling anything, run this command(remember su root first)

Code:
ln -s /usr/src/linux-<kernel-version> /lib/modules/VERSION/build
If it says the file already exists then it's already done and we can move on, if it says nothing, then you've just done it and we can move on. HINT: use the <tab> key to help guess the directory structure since everyone's flavor is different.

Next thing is next. If you have wired access with your lappy(And in Suse 10 it should already be setup, just have to ifup eth0, etc) then you can get the latest cvs of ndiswrapper which I've heard good things about and have used in FC4(successfully, I might add).

Code:
cvs -z3 -d:pserver:anonymous@cvs.sourceforge.net:/cvsroot/ndiswrapper co ndiswrapper
or download the source tarball on http://ndiswrapper.sourceforge.net

That will get you the latest distro and dump it into a directory called "ndiswrapper".

First thing is now first for ndiswrapper, uninstall any version you might have on your machine at the moment simply use "make uninstall" to remove the old version, it should suffice in successfully removing the old version and the source as well.

Now type the following commands:

Code:
make distclean
This clears out all variables that may or maynot have been in use as well as clears any temp files for compiling.

Code:
make
This compiles the program.

Code:
make install
This installs the module

ndiswrapper should now be installed but not active, not yet... now type:

Code:
depmod -a
..to check for any other dendencies.

Then go ahead and modprobe ndiswrapper

now change to the dir where you extracted your 7510gx 64-bit wifi drivers.

type the following commands:

Code:
ndiswrapper -i bcmwl5.inf
You should get one or two warnings about something being forced to mode 2 or some shit, it's irrelavent. As long as it doesn't say that the the hardware isn't there or the driver doesn't work... etc.

next,
Code:
ndiswrapper -m
next,
Code:
ndiswrapper -l
You should get the driver that's installed and it should say, "Driver Present, Hardware Present". Now, if you've followed the install wiki you're probably confused by now(my reports indicate the wiki steps works great for 32 bit SuSE, please keep that in mind.)
You're confused because the little wifi light isn't on. There's a reason for that that I'll get into later.

k, next if you have the wifi toolkit installed(comes with SuSE 10) then type iwconfig and see if wlan0 is there. It should be if it works. -=-OR-=- you'll see eth0 with wifi extensions. Don't as me why but with FC4 and sometimes SuSE it will make the wifi card eth0 instead of wlan0.

Now if you don't see anything that has wifi extensions on it don't panic. we're only half done. (but it's not looking too great from here).

Try hitting Function F2 on your machine(the wifi hard switch) if THIS doesn't turn on the light, then it's time to move on to something else. That's just about all I can say, kids... Lemme splain... Ndiswrapper does a great job of utilizing NDIS standards in windows drivers, however... with our laptops it's not a problem with ndiswrapper's ability to translate the win binary OR to interface with the card, it is simply not setup to handle the hardswitch in most cases. I think the hardswitch works with ndiswrapper in kernel 2.6.11 but not in 13 dunno, maybe it's just my distro... I've spent hours and hours to no avail, and that seems to be the case... Here's why I see that. Because ifconfig doesn't show it, iwconfig doens't show it but the driver sees the hardware, that's because the radio is still off and you can't ifup wlan0/eth0/1 because it's not on. The card is on, but the card is reporting that it's disabled to the OS(which it doens't understand and errors). So, if your light doesn't come on, sorry about your luck. Get your 20 bucks ready and skip to the next section.

ndiswrapper -cont... If your light did come on, great, now type ifup wlan0 or ifup eth0 if for some reason you got the eth0 as your wifi.

From here scroll down to post config, which applies to both.

**********************************************************

Linuxant DriverLoader

Simple... go to www.linuxant.com and download the latest version WLAN driverloader rpm and run that badboy(use YaST to install the module) Much easier than compiling manually.

Point your browser to http://127.0.0.1:18020 login as root

First thing upload your windows drivers, first it will ask you for your INF file and then your SYS file. Simple as that, go ahead and ignore any initial errors it gives you about not being able to access the hardware or the drivers messed up, it's a bug in the program caused by the hardware switch mentioned above.

Once you've loaded your windows drivers, you'll need a license. go back to linuxant.com and at the very least get a trial license. But I think it's worth saving the headache to just drop the 20 bucks and get a permi license. If you guys are REALLY hardup someone can shell out the cache and I'll write a keygen(since I think shit like that should be open source anyway... the bastards). Anyway for this case, I really think it's worth the 20 bones. So, get yourself a license, which is based on your mac address and your email address(make sure you use a valid email). When you go into your driverloader config page, click settings and enter your driver information.

How to get your MAC address.:

Code:
Since driverloader will let you get almost all the way up without a license then you'll follow these steps to bring up the interface and get the mac.  
The first thing you MUST do before ANYTHING ELSE is to hit Fn-F2 to bring up the wifi, the hardswitch works with driverloader, it's just not automatic.
Right after loading your windows drivers, you want to open up a term window, su to root, and type "ifup wlan0".  
Now type "ifconfig wlan0" you'll see the hardware address which is the MAC address of your card.  Copy that to the form for the license and continue.
Now that you have your license installed it's time to bring the interface up again. If you brought it up to get the license then it is already working and you may now skip down to the post install notes.

If it's not then here's what you must do. First thing you MUST do before ANYTHING else is hit Fn-F2 to bring the wifi up. The hardswitch works with driverloader it's just not automatic.

Now, as root, type "ifup wlan0" and you're in business. Move on to post install notes.


******Post*******

Now you're in business, go into your kde or gnome wifi/internet connection wizard and setup your wireless settings. You MUST specify an IP address, it has to be static. But it's not as bad as some might think. Those of you not down with the networking, here's how it goes..

If your routers IP address is 192.168.0.1 and it's setup to divvie out IP addresses then here's what you're going to do.. Set your IP address to anything above 100, ex. : 192.168.0.140, subnet mask will be 255.255.255.0 in 95% of cases.

Make sure you setup DNS/Host lookup. Primary DNS will be 192.168.0.1 or the same IP as your router. Leave secondary and trinary blank(if there). Change your host name to something else, domain name is optional, and domain search is optional, if you have a domain on your network, I probably don't have to tell you this but you ought to match your linux machine to the domain if you're going to browse the network(create administrator computer accounts in Windows Active Directory or linux LDAP, no local config is needed).

Now.... If you restart the machine, your wifi radio will be off... Don't start panicking when you're booting and notice that the wifi light isn't on. And WHATEVER YOU DO UNDER ANY CIRCUMSTANCES DON'T HIT FUNCTION F2 WHILE THE MACHINE IS BOOTING. You'll crash your shit so hard it's not funny.. Go ahead and read that one more time for me, I'll wait.

When you bring up your machine(restart or cold boot), let it boot. Driverloader/Ndiswrapper will come up properly and load your winblows drivers in despite the card reporting that it's disabled... Now, when you get to an IDLE desktop, THEN you may safely turn on the wifi radio using the hard buttons. This is the only time you can do it. If you're booting or shutting down it'll crash hard and won't boot again. I've installed both FC4 and SuSE so many times on this laptop, trust me I know, don't dick with it while booting or shutting down.

K, so you waited until you had an idle desktop turned your wifi on now open up a terminal and su root, then type "ifup wlan0" or eth0 for your weirdos out there. You're in business.. It should very quickly connect to the last AP you were connected to, etc.

You can do a quick shell script to do this for you, just keep in mind the ifup command won't work properly if the wifi isn't switched on. (but it's not a big deal if it's not on and you ifup, just don't do it while booting or shutting down, last warning)

DISCLAIMER, don't ask me about WEP, WPA, or Network Keys because I couldn't tell you the slightest thing about how to get those to function properly in linux(windows is a different story, I lub me some wifi security). For the purposes of this experiment it may be wise to disable all security on your AP/router save for mac filter(which allows only specified MAC addresses to connect). Should relieve some headaches.

Hope this helps. Please try to remember, I'm a newbie too so I'm just doing the best I can.

-Vex

EOF
 
Old 10-30-2005, 09:24 AM   #10
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
YES! I'm thrilled. I really, really wanted to use Suse 10-64, but after I couldn't get sound and wifi working, I ditched it. After you guys verified that the external amp mute enables sound in Suse, I reinstalled Suse 10-64--and sound now works! I also used the wifi drivers Vexamus posted. They work perfectly with ndiswrapper. I'm currently posting using the integrated wifi card; my cable isn't even plugged in.

I also have 3d hardware acceleration working (I think--not exactly sure how to check, though). I used the drivers here: https://support.ati.com/ics/support/...ge&folderID=27

Here's why I think that 3d hardware acceleration is working. There is a 3d xscreensaver called "atunnel." (just go to a terminal and type "xscreensaver," and "settings" to access it). Under the settings for the screensaver, there is an option to show the fps as it plays. Before installing the ati drivers, the highest fps I could achieve was ~15. After installing the ati drivers, I can get well over 100 fps. Could this mean anything? How should I test to see if acceleration is working?

Have either of you tried e17? It looks very nice on the bright screens.

Do you guys think we should spend a few mins to type up a how-to for suse 10-64 on the 7510gx? Maybe we could each take a section?
 
Old 10-31-2005, 04:00 AM   #11
mbeltagy
Member
 
Registered: Oct 2005
Distribution: SUSE
Posts: 31

Rep: Reputation: 15
ndiswrapper doesn't work !!

mikeh2,

Did you use the ndiswrapper that came with the SUSE 10-64 distro or did you download the lastest version as Vexamus pointed out?
I tried the drivers on the SUSE 10-64 distro's ndiswrapper and it didn't work, then I uninstalled it usign YAST and I got latest ndiswrapper files (version 1.4).
I did the linking as Vexamus pointed out

Code:
ln -s /usr/src/linux-2.6.13-15-obj /lib/modules/2.6.13-15-default/build
but when I tried to run make, I got
Code:
Can't find kernel sources in /lib/modules/2.16.13-15-default/build
not sure where to go from here, any suggestions ?
 
Old 10-31-2005, 06:09 AM   #12
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Re: ndiswrapper doesn't work !!

Quote:
Originally posted by mbeltagy
mikeh2,

Did you use the ndiswrapper that came with the SUSE 10-64 distro or did you download the lastest version as Vexamus pointed out?
I tried the drivers on the SUSE 10-64 distro's ndiswrapper and it didn't work, then I uninstalled it usign YAST and I got latest ndiswrapper files (version 1.4).
I did the linking as Vexamus pointed out

Code:
ln -s /usr/src/linux-2.6.13-15-obj /lib/modules/2.6.13-15-default/build
but when I tried to run make, I got
Code:
Can't find kernel sources in /lib/modules/2.16.13-15-default/build
not sure where to go from here, any suggestions ?
I've had a ton of trouble with this card, so I was shocked when it worked so quickly. I used version 1.5rc2 of ndiswrapper. I didn't have any trouble with building, so I'm not sure what is going on there. I need to leave to catch a train, but I'll be back tomorrow and will offer more suggestions if you're still working on it.
 
Old 11-01-2005, 02:11 AM   #13
mbeltagy
Member
 
Registered: Oct 2005
Distribution: SUSE
Posts: 31

Rep: Reputation: 15
Cool I got it wirless to work

Thanks guys, I now have wirless up and running.

I missed one important step which was the cause of my troubles. I didn't have the kernal source installed, once I installed it, I had no trouble building the ndiswrapper.


Cheers...
 
Old 11-01-2005, 03:20 AM   #14
mbeltagy
Member
 
Registered: Oct 2005
Distribution: SUSE
Posts: 31

Rep: Reputation: 15
3d hardware acceleration

I downloaded the drivers from the ati site. I typed

./ati-driver-installer-9.18.6-x86_64.run

That gives you a colorful installation screen. I first generated an installation specific rpm for SUSE 10_64 and installed using YaST. I followed the instructions and I switched to
Code:
init 3
logged in as super user, then typed
Code:
sax2 r m 0=fglrx b /usr/share/doc/packages/fglrx/sax2-profile
I set my screen to the correct resolution. But then when I rebooted nothing happened !!! No 3d hw acceleration.

I than reran the installer ./ati-driver-installer-9.18.6-x86_64.run and had setup to install thing automatically, that followed by switching to init 3 and running the sax2 command above.

This time I got 3d to work. I now have fgl_glxgears running at around 537 fps. The screen saver atunnel runs at 83 fps.

This was roundabout sort of way to installation. But I am sure many of you have a better way.

Now if I could also get my modem to work !!! Then I am all set...

BTW. did anyone check if the various media readers on the 7510gx are working or get video capture through the firewire port.
 
Old 11-01-2005, 08:39 AM   #15
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Didn't check video capture, but SD and CF work fine for me, out of the box.

Did anyone fool around with hibernate/suspend? There are settings in kcontrol, but I don't think they work for me. Not positive, though--I need to spend some more time with them.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio AC'97 Problem linux_freak01 Linux - Hardware 3 02-09-2005 05:46 PM
Configuring AC'97 Audio on RHL8.0 divoibs Linux - Software 5 09-07-2004 04:57 PM
Audio AC'97 not work on redhat 9 goal2guy Linux - Hardware 4 11-11-2003 09:16 PM
82801AA AC'97 Audio Trying to install ALSA newmandrakeuser Linux - Newbie 3 12-25-2002 05:19 PM
Via Ac'97 Audio Controller (wdm) wonderpun Linux - Hardware 4 10-14-2002 06:53 AM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration