LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-09-2010, 10:28 AM   #1
Jaysonfw
LQ Newbie
 
Registered: Apr 2010
Location: Chesapeake Virginia
Distribution: Slackware
Posts: 7
Blog Entries: 2

Rep: Reputation: 0
A Solution for Disabling the Annoying PC Beep (Ubuntu)


When in a virtual tty, Ubuntu has an extremely annoying audible beep alert to notify the user that he is trying to do something that can't be done. Say for instance, hitting the backspace key at the command prompt. The cursor can not back up from there, so the system issues out a loud obnoxious BEEP in response. I am in a virtual tty often, and have found myself on a quest to eradicate that annoying BEEP from my system, if it is the last thing I do. After trying several modprobe, and other solutions, that did not work, I have found a solution that does.

alsamixer has a setting for 'PC Beep' that can be muted, silencing all audible system complaints from a virtual tty.

It would be a pain to do this every time, so...

amixer is a command line interface to alsamixer. By placing the following command in my .bashrc file, I have solved my problem.

amixer set 'PC Beep' disable

Hope that helps someone else.
 
Old 04-09-2010, 11:27 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949Reputation: 1949
The beep in the bash shell is generally issued by the readline library, and can be disabled in its configuration settings. Just add "set bell-style none" to your ~/.inputrc file and it should disable the readline notifications, while leaving the system speaker enabled for use by other commands (such as issuing 'echo -e "\a"' ).

You can read more about readline in the bash man page.

FYI, kde's konsole also has settings for configuring how the bell/system notification behaves.
 
Old 04-09-2010, 12:04 PM   #3
Jaysonfw
LQ Newbie
 
Registered: Apr 2010
Location: Chesapeake Virginia
Distribution: Slackware
Posts: 7
Blog Entries: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by David the H. View Post
The beep in the bash shell is generally issued by the readline library, and can be disabled in its configuration settings. Just add "set bell-style none" to your ~/.inputrc file and it should disable the readline notifications, while leaving the system speaker enabled for use by other commands (such as issuing 'echo -e "\a"' ).
I knew there had to be something!
Thanks for the proper way to do this.
 
  


Reply

Tags
alsamixer, beep


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off the annoying beep puzz_1 Linux - Hardware 3 02-22-2009 12:46 AM
How to disable that annoying BEEP? icy-flame Linux - Newbie 19 05-01-2007 06:16 PM
That annoying beep zchoyt Linux - Newbie 6 01-05-2007 08:38 PM
annoying beep using Mozilla cccc *BSD 3 08-23-2006 07:54 AM
Annoying beep in slackware Havox Slackware 2 02-04-2003 11:37 PM


All times are GMT -5. The time now is 09:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration