LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-30-2005, 06:00 AM   #16
alisic
LQ Newbie
 
Registered: Aug 2005
Location: Utrecht, Netherlands
Distribution: SuSe 9.3 + KDE 3.4
Posts: 10

Rep: Reputation: 0

Quote:
Originally posted by jcmaco
I tried /bin/bash's technique but every time I press a key there's a new taskbar item that appears named 'Pause', 'Previous', etc (depending on wich keys I pressed). The item has a revolving sand-clock, after 30 seconds it closes the window. I am using the command "xmms -p". I have also tried this command "xmms-shell -e previous" with the same effect.

Hi there,

Great tutorials here! I fixed the special buttons on my Logitech Cordless Desktop, thanx! First I had the same problems with the commands for XMMS, but I found a way around that. I use KDE 3.4 on SuSe 9.3, with XMMS 1.02.10. I did the same thing with putting extra items in the K menu and linking those items with commands and then to shortcut keys assigned earlier, the K menu editor:

Code:
xmms --stop &
etcetera, now INCLUDING the ampersand at the end of the command. I UNchecked the box for 'Enable launch feedback'; and the command is linked to a shortcut key 'XF86AudioStop' as was described in the tutorials.

I am not sure which part of the above did the trick , but now everything works perfectly for XMMS, no revolving sand-clocks and no extra taskbar items! I hope that this helps for you as well....
 
Old 08-30-2005, 09:41 AM   #17
leodp
LQ Newbie
 
Registered: Aug 2005
Posts: 6

Rep: Reputation: 0
Hi all,
another nice solution is xbindkeys;
lots on info on its homepage:
http://hocwp.free.fr/xbindkeys/xbindkeys.html

You can associate arbitrary commands to multimedia buttons, keys or keys association, in a file .xbindkeysrc located in the home dir.
Autostart the program (in kde) putting in $HOME/.kde/Autostart a file with the next 2 lines:

#!/bin/sh
xbindkeys

and giving exec. permission:
chmod 744 Your_filename_here


Leo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multimedia keys killerbob Slackware 2 05-20-2005 10:21 PM
Logitech Multimedia keys don't generate scancodes Itzac Linux - Hardware 1 03-22-2005 02:28 PM
logitech cordless keyboard configuration for multimedia keys milad126 Suse/Novell 1 03-09-2005 05:24 PM
Multimedia Keys in KDE 3.2 GameboyHippo Linux - Software 2 12-15-2003 02:41 PM
Using multimedia keys from bash belial Linux - Distributions 1 05-09-2003 07:24 AM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration