LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-31-2003, 05:13 AM   #1
zidour
LQ Newbie
 
Registered: Mar 2003
Distribution: Red Hat 9
Posts: 6

Rep: Reputation: 0
Question 6-channel C-Media 9739 on-board audio chip: only 2 channels playing


I have a problem with my on-board 6 channel audio chip CMI9739 with 5.1 speakers connected. I installed the driver from C-Media succesfully, but only 2 channels are playing. In the "cmconfig" utility (supplied with the drivers) I toggled the first two options to switch from line-in and mic to rear-out and center/subwoofer out. But still nothing happens - I get sound only from front left and right speakers.
When I toggle the third option, I get sound only from rear speakers. Toggling the second option (mic in <-> center/sw out) makes a strange noise in the subwoofer but that's all.

Anybody with the same problem? Thaks for your advice.
Zidour
 
Old 09-03-2003, 09:49 PM   #2
marchYeh
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
Hi, zidour:

I found that you have post a message about problem of C-Media 9739 onboard audio chip, and i see that you can use it for 2 channels playing. I am use the same chip CMI9739A under linux with kernel 2.4.21, but i can't make it work now. Did you use the driver the C-Media provide? And would you please tell me how to make it work(only 2 channel playing). Please mail me. Thx.
 
Old 09-24-2003, 04:46 AM   #3
zidour
LQ Newbie
 
Registered: Mar 2003
Distribution: Red Hat 9
Posts: 6

Original Poster
Rep: Reputation: 0
Hi,
well, I am using RedHat 9 with kernel 2.4.20.
RedHat detected my card as SiS7012 PCI Audio Accelerator and used module i810_audio.
I tried to use the original driver from C-Media and the result was the same - the soundcard was playing, but only 2 channels.
I compiled it and edited modules.conf to use cmaudio module instead of i810_audio. That's all...
 
Old 09-24-2003, 09:30 PM   #4
kitty
LQ Newbie
 
Registered: Sep 2003
Location: STHLM-SWE
Distribution: Red Hat 9
Posts: 4

Rep: Reputation: 0
Hello
I have also the same audio chipset (C-Media CMI9739A) and
running under Red Hat 9 kernel 2.4.20. However my linux
could not find my chip and i am now in proceed of finding the
correct drivers, i tried to find them on Micro-Star Internationals
own page but they had no linux download mirror. Any help
please?
 
Old 09-25-2003, 02:13 PM   #5
zidour
LQ Newbie
 
Registered: Mar 2003
Distribution: Red Hat 9
Posts: 6

Original Poster
Rep: Reputation: 0
Hi Kitty,
try http://www.cmedia.com.tw/e_download_01.htm
choose your chip and then click Linux... Then just follow the instructions... good luck!
 
Old 11-07-2003, 08:25 PM   #6
FatiMama
LQ Newbie
 
Registered: Nov 2003
Distribution: RH8
Posts: 1

Rep: Reputation: 0
Hi zidour,
I have the C-Media 9739 audio card and 2.4.20 kernel as well. I downloaded the Linux driver from C-Media and I followed the instructions as best as I could. I am a new Linux user, so I am not sure what I need to do next to get audio working. I'd be happy to get 2 channels working... Any suggestions?
 
Old 11-07-2003, 08:36 PM   #7
kitty
LQ Newbie
 
Registered: Sep 2003
Location: STHLM-SWE
Distribution: Red Hat 9
Posts: 4

Rep: Reputation: 0
codec 97`

To tell you all the truth, i cant get it the soundcard to work,
i have tried several things, one thing was the ALPA sound
system neither did it work. Im starting to think of getting
me a better sound card that is seperatly build in to the
computer or if someone could help me out it would get
me on better thoughts

btw fatimama i dont think those drivers works couse they
were made for rh 6.0 and a very early kernel. I tried those
drivers, did not work, not for me at least..

Last edited by kitty; 11-07-2003 at 08:37 PM.
 
Old 12-03-2003, 05:41 PM   #8
lenup
LQ Newbie
 
Registered: Dec 2003
Posts: 2

Rep: Reputation: 0
Hello

I resently bought MSI Kt6 delta lsr which have this cmedia 9739 chip.
Im running Mandrake 9.2 and tried to compile the drivers from cmedia
website. There was error about modules and make failed to error.
SO i fired up >pico Makefile
and edited line

SYSINCLUDE = /usr/src/linux-2.4/include

to

SYSINCLUDE = /usr/src/linux/include

save
make
make install
modprobe cmaudio
and sounds worked.
 
Old 04-15-2004, 04:11 PM   #9
Ibexor
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
I have a problem with the same sound card too. I have 2 channels working fine, but when I try to make 6 channels work, I can't do it no matter what.

Help me if you can.
 
Old 05-23-2004, 08:14 PM   #10
hongweig
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Hi, lenup

I have the same board.

but I use alsa . the modules use via82xx. it is oK!

go : http://www.alsa-project.org/

download :
alsa-driver
alsa-lib
alsa-oss
alsa-utils

and tar jxvf , ./configure, make; make install

alsaconf, it is auto config your card. and it will auto edit your /etc/modules.conf or /etc/modproble.conf

alsamix , alsactl ....

good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can anyone recommend an Embedded computer board or chip? rjlee Linux - Hardware 5 09-13-2004 05:51 AM
6 channels audio AKded Linux - Hardware 0 07-29-2004 11:32 AM
on board sound chip ES1887 fig Linux - Hardware 1 07-18-2003 01:36 PM
rtl8139 on board chip not working on laptop!? realos Linux - Networking 4 06-02-2003 12:07 PM
C Media Sound Chip geoff-taylor@ho Linux - Hardware 4 05-28-2002 02:13 AM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration