LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-17-2005, 09:08 PM   #1
DownloadTHIS
LQ Newbie
 
Registered: Nov 2004
Distribution: Ubuntu
Posts: 14

Rep: Reputation: 0
5 button mouse problems in Ubuntu


On Ubuntu 4.10, I cannot get my 5 ("7") button USB mouse to work properly. My two side buttons are being detected as my mouse wheel, and my mouse wheel is being detected as the two side buttons.. What can I do to fix this?

Last edited by DownloadTHIS; 01-17-2005 at 09:49 PM.
 
Old 02-08-2005, 05:09 PM   #2
Cyborg16
LQ Newbie
 
Registered: Feb 2005
Distribution: Debian "Sarge" testing
Posts: 19

Rep: Reputation: 0
I think you want to use:
xmodmap -e "pointer = 1 2 3 6 7 4 5"
to swap 4 and 5 with 6 and 7. You should (I think) be able to save this as a shell script in ~/.kde/Autostart or put just pointer = 1 2 3 6 7 4 5 in ~/.Xmodmap according to what I've read to apply this automatically at startup, but I haven't tested these (they may be distro specific).
EDIT: Actually, I now have the same problem. I can run a script, but how do I make it run automatically at start, or how else can I make the change automatic (neither of my methods above work for me)?
I've just managed to solve one problem though, and to help anyone else with the same problem: My left and right mouse buttons were always triggering my middle and right mouse buttons rather than their own. I solved this by changing the protocol in XF86Config file to ExplorerPS/2 (was ImPS/2).

Last edited by Cyborg16; 02-09-2005 at 01:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Scroll Button doesn't work with Logitech PS/2 MOuse. duffmckagan Slackware 10 12-02-2008 11:27 PM
[Ubuntu] Problems setting Microsoft Intellimouse mouse and network pocetnik Linux - Software 0 11-25-2005 01:38 PM
3 button mouse (scroll button) Spyiish Slackware 24 07-23-2005 01:37 PM
Mouse setup problems for a 8 button mouse. Devboy Linux - General 3 12-25-2004 04:53 PM
middle mouse button is paste.. but what if i dont have a mid mouse button? kublador Linux - Newbie 4 09-02-2003 08:59 AM


All times are GMT -5. The time now is 01:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration