LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-27-2007, 01:00 AM   #1
nitaish
LQ Newbie
 
Registered: Oct 2003
Posts: 17

Rep: Reputation: 0
4 G RAM not detected by Fedora 7


Hello,

We recently setup a server with 4 gigs of RAM and installed Fedora core 7 32-bit version in it. After installing the OS, I have found that Fedora is able to detect only 2 GB and not 4 GB of RAM. I installed the kernel-PAE and kernel-PAE-devel modules and restart the server and made sure that the the OS with the PAE switch starts at boot time. However, the OS still does not detect the 4 GB RAM. Any idea what else can be done apart from installing the 64-bit OS in the system?
 
Old 11-27-2007, 01:28 AM   #2
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
I think the answer is NO.
The only solution is the 64-bit OS.
 
Old 11-27-2007, 12:13 PM   #3
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
It should be able to detect it with the PAE kernel. Is the bios detecting it? How are you determining how much memory linux finds? When asking for help it is always extremely helpful to mention what distro you are using.
 
Old 11-27-2007, 12:36 PM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,

I've had a similar issue. 4 Gb installed, kernel setting also on 4Gb (CONFIG_HIGHMEM4G): only 2 Gb was detected.

Only way I could solve the problem was by telling the kernel I had up to 64 Gb (CONFIG_HIGHMEM64G=y). Now all 4 Gb are detected.

Hope this helps.

PS: This is a 32 bit box.

Last edited by druuna; 11-27-2007 at 03:47 PM.
 
Old 11-27-2007, 03:44 PM   #5
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
Quote:
Originally Posted by zhoun View Post
I think the answer is NO.
The only solution is the 64-bit OS.

Well I am running opensuse 10.3 32 bit with 4 gigs of ram and it works just fine.
 
Old 11-27-2007, 09:02 PM   #6
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
Quote:
Originally Posted by druuna View Post
Hi,

I've had a similar issue. 4 Gb installed, kernel setting also on 4Gb (CONFIG_HIGHMEM4G): only 2 Gb was detected.

Only way I could solve the problem was by telling the kernel I had up to 64 Gb (CONFIG_HIGHMEM64G=y). Now all 4 Gb are detected.

Hope this helps.

PS: This is a 32 bit box.
I am wrong.
Linux kernel support 64G RAM.
You need recompile the kernel to support the big ram.
 
  


Reply

Tags
fedora, gb, ram


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
256m out of 512m RAM detected pengu Linux - Hardware 13 07-14-2007 09:34 AM
Soundcard Not Detected In Fedora 5 atrvarma Linux - Hardware 2 05-20-2006 07:27 PM
soundcard not detected on fedora 5 theuser666 Linux - Hardware 7 05-17-2006 05:15 AM
Only 884MB / 1024MB ram detected? Keyser Sose Linux - Hardware 2 04-07-2005 06:02 AM
826MB ram instead of 1024MB detected Coolrunr Linux - Hardware 8 09-08-2003 09:25 PM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration