LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-01-2006, 05:51 AM   #1
hate29
Member
 
Registered: Oct 2005
Location: Finland, Tampere
Distribution: Debian
Posts: 47

Rep: Reputation: 15
2 soundcards, wrong order (debian)


I have two soundcards, sound blaster audigy and some integrated intel. Now, everytime I start debian it uses that intel card and I want to use the sound blaster. With alsaconf I can change this, until I reboot. Then it's back again. I could disable the other from bios but I want to (need) use both, but SB as my first card.
 
Old 12-01-2006, 07:11 AM   #2
scorpion_gr
Member
 
Registered: Nov 2006
Location: London, UK
Distribution: openSUSE 11.1, openSUSE 10.3
Posts: 67

Rep: Reputation: 15
I think I have the exact same problem.


EDIT:
Here is what I tried: I deleted both configurations. Then reconfigured them in the order I wanted them. Then rebooted just to make sure. The Soundblaster is still first in priority.

Last edited by scorpion_gr; 12-01-2006 at 07:22 AM.
 
Old 12-01-2006, 07:40 AM   #3
hate29
Member
 
Registered: Oct 2005
Location: Finland, Tampere
Distribution: Debian
Posts: 47

Original Poster
Rep: Reputation: 15
I think I change my sound cards priorities quite easily in suse 9.3, from the mixer, or somewhere else. Don't remember anymore. I thought this shouldn't be so hard to do, but I don't find answer even in google.
 
Old 12-03-2006, 07:21 AM   #4
scorpion_gr
Member
 
Registered: Nov 2006
Location: London, UK
Distribution: openSUSE 11.1, openSUSE 10.3
Posts: 67

Rep: Reputation: 15
Did you try to reconfigure the soundcards from zero in the correct order like I said? It worked for me.
 
Old 12-03-2006, 09:49 AM   #5
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Using Etch, I fixed it by making /etc/modprobe.d/sound look like this:
Code:
## Creative
alias snd-card-0 snd-ca0106
options snd-ca0106 index=0
### On-board
alias snd-card-1 snd-atiixp
options snd-atiixp index=1
I don't know if Sarge uses modprobe.d tho. IMO you should be using Etch anyway for a desktop PC. Sarge's time has come and gone.
 
Old 12-03-2006, 12:07 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by rickh
Using Etch, I fixed it by making /etc/modprobe.d/sound look like this:
Code:
## Creative
alias snd-card-0 snd-ca0106
options snd-ca0106 index=0
### On-board
alias snd-card-1 snd-atiixp
options snd-atiixp index=1
I don't know if Sarge uses modprobe.d tho. IMO you should be using Etch anyway for a desktop PC. Sarge's time has come and gone.
Sarge with a 2.6 kernel would use the file in the /etc/modprobe.d directory if using a 2.4 kernel then the file would be /etc/modutils/alsa if I remember correctly once done editing the alsa file you would need to run the update-modules to have the new settings put into the /etc/modules.conf for use on next boot/or reload of alsa.
 
Old 12-03-2006, 01:01 PM   #7
hate29
Member
 
Registered: Oct 2005
Location: Finland, Tampere
Distribution: Debian
Posts: 47

Original Poster
Rep: Reputation: 15
I did try to delete both and reconfigure but no help with that. I have kernel 2.6.8-3-686 so I edited /etc/modprobe.d/sound to look like this:

Code:
alias snd-card-0 snd-emu10k1
options snd-emu10k1 index=0
alias snd-card-1 snd-intel8x0m
options snd-intel8x0m index=1
It didn't much good though. Still stuck with that damn integrated.

I've heard etch is coming stable soon and I'm changing to that. But should I start with clean install or distroupdate, which is easier to do?

One last thing. What is the difference between /etc/modprobe.d/sound and /etc/modrprobe.d/alsa-base?
 
Old 12-03-2006, 01:23 PM   #8
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by hate29
I did try to delete both and reconfigure but no help with that. I have kernel 2.6.8-3-686 so I edited /etc/modprobe.d/sound to look like this:

Code:
alias snd-card-0 snd-emu10k1
options snd-emu10k1 index=0
alias snd-card-1 snd-intel8x0m
options snd-intel8x0m index=1

It didn't much good though. Still stuck with that damn integrated.
That should work you did restart or /etc/init.d/alsa reload right? One other thing to try is putting the snd-emu10k1 and snd-intel8x0m on a line by themselves in the file /etc/modules with the emu10k1 listed first.

Quote:
I've heard etch is coming stable soon and I'm changing to that. But should I start with clean install or distroupdate, which is easier to do?
The dist-upgrade is the easiest to do and keeps your install pretty much the same as it is now only removing/upgrading the packages as needed.
Quote:
One last thing. What is the difference between /etc/modprobe.d/sound and /etc/modrprobe.d/alsa-base?
The sound file contains the settings for your card(s) the alsa-base is installed by the alsa package with the generic settings needed to run/install the driver for the various cards out there.
 
Old 12-03-2006, 01:38 PM   #9
hate29
Member
 
Registered: Oct 2005
Location: Finland, Tampere
Distribution: Debian
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
That should work you did restart or /etc/init.d/alsa reload right? One other thing to try is putting the snd-emu10k1 and snd-intel8x0m on a line by themselves in the file /etc/modules with the emu10k1 listed first.
I did restart and try /etc/init.d/alsa reload, both of them. Nothing. I put intel8xm to /etc/modules (emu10k1 was already there) and reboot. Still nothing. Still intel as my first soundcard. Could the problem be somewhere else? Or it just seems that I use wrong kind of hardware to linux world.
 
Old 12-03-2006, 02:01 PM   #10
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by hate29
I did restart and try /etc/init.d/alsa reload, both of them. Nothing. I put intel8xm to /etc/modules (emu10k1 was already there) and reboot. Still nothing. Still intel as my first soundcard. Could the problem be somewhere else? Or it just seems that I use wrong kind of hardware to linux world.
No that is something weird going on with the hardware you have my install will set my audigy first then the onboard for second. Do you need the onboard at all? If not then see if you have a setting in your BIOS to disable the onboard sound then it will have no choice but to use the add in card.
 
Old 12-03-2006, 02:09 PM   #11
hate29
Member
 
Registered: Oct 2005
Location: Finland, Tampere
Distribution: Debian
Posts: 47

Original Poster
Rep: Reputation: 15
This would be really easy if I wouldn't need that other card. But I use my pc for many different multimedia processes same time so I need both cards that different sounds don't get mixed. Maybe I should disable my inboard card, install again and install first my sound blaster and then after that my inboard card. I don't know if that helps or not.
 
Old 12-03-2006, 02:42 PM   #12
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by hate29
This would be really easy if I wouldn't need that other card. But I use my pc for many different multimedia processes same time so I need both cards that different sounds don't get mixed. Maybe I should disable my inboard card, install again and install first my sound blaster and then after that my inboard card. I don't know if that helps or not.
Well that could be a solution as long as it does not start choosing the onboard as the first one again. A dirty little hack you could try is edit the /etc/init.d/bootmisc.sh file and at the bottom just before the exit 0 put the following lines.

Code:
## Added by me for proper loading of sound cards
/etc/init.d/alsa unload
modprobe -r snd-intel8x0m
modprobe -r snd-emu10k1
modprobe snd-emu10k1 
modprobe snd-intel8x0m
/etc/init.d/alsa reload
Don't know if it will work or not but it is worth a try before reinstall you need to restart for this.
 
Old 12-03-2006, 03:18 PM   #13
hate29
Member
 
Registered: Oct 2005
Location: Finland, Tampere
Distribution: Debian
Posts: 47

Original Poster
Rep: Reputation: 15
Now that sound blaster is my first sound card but when I tried to play xmms it gives me error:

Code:
Could not open sound device (not sure if it says like this, I have to translate it)

Please check that:

Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the soundcard
Ok, totem and kaffeine played fine. And when I changed xmms to use oss, it plays fine too. Does it matter does it use alsa or oss?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Partitions in wrong order?? king_scott_2 Linux - Hardware 4 12-11-2005 04:37 PM
Partitions in wrong order nukey Slackware 5 05-15-2005 05:50 AM
Filenames are sorted in wrong order Simoncifer Linux - Newbie 4 01-07-2005 12:52 AM
Wrong soundcards order Bothkill Slackware 11 07-22-2004 05:10 PM
ALSA Problem: 2 soundcards, wrong order PrivatePanic Linux - Hardware 4 09-04-2003 01:15 PM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration