LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-10-2005, 02:26 PM   #1
Intimidator
Member
 
Registered: Mar 2005
Distribution: FC4
Posts: 83

Rep: Reputation: 15
1152x864 in Fedora


hey

I am using FC3 and KDE as my Desktop manager

I want to work under 1152x864 resolution.I tried to edit the /etc/X11/xorg.conf .I added

1152x864 to the existing resolutions which made the line as


From xorg.conf
Modes "1152x864" "1024x768" "800x600" "640x480"

And when i right click on the desktop and choose 'Configure Desktop' and under 'display' tab

i am not able to see the screen size as 1152x864.It only shows the other three.

Ne idea how it works ?

Thanx

Last edited by Intimidator; 04-10-2005 at 02:28 PM.
 
Old 04-10-2005, 03:08 PM   #2
sludink
Member
 
Registered: Jan 2005
Location: Brabant, the Netherlands
Distribution: Gentoo 2004.x (2.6.10 hardened)
Posts: 91

Rep: Reputation: 15
You could try
Ctrl+Alt+Num_+ or
Ctrl+Alt+Num_-
(Num_ means on the numeric part of the keyboard)
Don't know if it works for KDE, but worth trying anyway.
 
Old 04-10-2005, 03:33 PM   #3
Intimidator
Member
 
Registered: Mar 2005
Distribution: FC4
Posts: 83

Original Poster
Rep: Reputation: 15
By doing

<CTRL><ALT><+>
<CTRL><ALT><->

It seems to switch to 640X480

ne more ideas ?

Thanx for replying
 
Old 04-10-2005, 04:18 PM   #4
sludink
Member
 
Registered: Jan 2005
Location: Brabant, the Netherlands
Distribution: Gentoo 2004.x (2.6.10 hardened)
Posts: 91

Rep: Reputation: 15
Could you post you're xorg.conf?
 
Old 04-11-2005, 02:36 AM   #5
Intimidator
Member
 
Registered: Mar 2005
Distribution: FC4
Posts: 83

Original Poster
Rep: Reputation: 15
xorg.conf

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "IBM 6541 G51"
	DisplaySize  280	210
	HorizSync    30.0 - 54.0
	VertRefresh  55.0 - 100.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "i810"
	VendorName  "Videocard vendor"
	BoardName   "Intel 865"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes   "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
I added 1152x864 to the Modes already there
 
Old 04-11-2005, 02:58 AM   #6
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
I run that exact resolution... Here is a sample of my xorg.conf file.

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 24
Virtual 1152 864
EndSubsection
EndSection

Curious? How much V-ram on that card? do you really want to run a default color depth 16...

Hope this helps a little.

KC
 
Old 04-11-2005, 03:42 AM   #7
Intimidator
Member
 
Registered: Mar 2005
Distribution: FC4
Posts: 83

Original Poster
Rep: Reputation: 15
hey

I have edited my xorg.conf

but after i killed the Xserver and restarted it.It ended with a screen showing

Xserver cannot be loaded.I had overwritten my xorg.conf to login back .

ne more ideas ??
 
Old 04-11-2005, 04:18 AM   #8
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,293

Rep: Reputation: 123Reputation: 123
I, too, have that "i810" card and it seems as it can't handle 1152x864!
Pretty strange, but that resolution hasn't worked in any distro tried on this computer.
 
Old 04-13-2005, 04:42 PM   #9
Intimidator
Member
 
Registered: Mar 2005
Distribution: FC4
Posts: 83

Original Poster
Rep: Reputation: 15
I solved the problem myself

Edited the Modes line

Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

and then

system-config-display

u can choose required resolution

Restart X-server


Last edited by Intimidator; 04-13-2005 at 04:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XOrg, intel onboard 865G and 1152x864. is it possible? asklepios Linux - General 2 03-13-2005 05:36 AM
fvwm + 1152x864@85.00 anchunlei Slackware 1 11-08-2004 12:18 AM
Q. ATI 3D Rage Pro and 1152x864@100Hz killerwh Linux - Hardware 0 08-22-2004 04:00 PM
XF86Config .. Won't run at 1152x864 FlatZ28 Linux - General 4 09-12-2003 03:43 PM
1152x864 won't work :( Fr3d Slackware 7 07-02-2003 04:48 PM


All times are GMT -5. The time now is 07:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration