LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-20-2006, 04:46 PM   #1
G00fy
Member
 
Registered: Jul 2004
Location: Herent, Belgium, Europe, Earth
Distribution: Ubuntu 7.04
Posts: 102

Rep: Reputation: 15
[ALSA]: no soundcards found...


Hi,


I don't know if this is the right forum, but here the question is ...


I have a problem that when I do:
Code:
root@steven:/home/steven# /etc/init.d/alsa-utils restart
 * Shutting down ALSA...  * /etc/init.d/alsa-utils: Warning: 'alsactl store' failed with error message 'alsactl: save_state:1163: No soundcards found...'.
                                                                                                                                                      [fail]
 * Setting up ALSA...  * /etc/init.d/alsa-utils: Warning: 'alsactl restore' failed with error message 'alsactl: load_state:1236: No soundcards found...'.
                                                                                                                                                      [ ok ]
But I do have sound in Linux... But it is called OSS I think.
Code:
root@steven:/home/steven# lsmod | grep snd
snd_intel8x0           33344  0
snd_ac97_codec         84028  1 snd_intel8x0
snd_pcm_oss            53152  0
snd_mixer_oss          19392  1 snd_pcm_oss
snd_pcm                89032  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_page_alloc         10696  2 snd_intel8x0,snd_pcm
snd_seq_dummy           3716  0
snd_seq_oss            33664  0
snd_seq_midi            9184  0
snd_rawmidi            25056  1 snd_seq_midi
snd_seq_midi_event      7040  2 snd_seq_oss,snd_seq_midi
snd_seq                51024  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              24260  2 snd_pcm,snd_seq
snd_seq_device          8524  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    55172  10 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               9696  4 nvsound,snd

What can I do to make ALSA work?


Thanks a lot
 
Old 05-20-2006, 06:30 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,428

Rep: Reputation: 83
When did you install ALSA? and HOW?
 
Old 05-21-2006, 04:11 AM   #3
G00fy
Member
 
Registered: Jul 2004
Location: Herent, Belgium, Europe, Earth
Distribution: Ubuntu 7.04
Posts: 102

Original Poster
Rep: Reputation: 15
I don't know when, I don't know how .

I just installed Ubuntu 5.10, did all the upgrades. Installed this: http://www.nvidia.com/object/linux_nforce_1.0-0310.html [nforce chipset drivers]...

That's all I did. But to use Twinkle Phone (VOIP program), I have to use ALSA, but it seems like I can't get it to work...

That's why I am asking
 
Old 05-21-2006, 04:41 AM   #4
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
In KDE, Control Panel, Sound and multimedia, Sound System, Hardware, you can select which sound system you want to use.

There is probably something similar in Gnome but I wouldn't know as I avoid using it (no flames please)

However don't be surprised if ALSA is already selected! I used to get this message too and attributed it to a timing problem, ie the sound system took longer to initialise than the boot process was willing to wait.

Never caused any problems.
 
Old 05-22-2006, 12:18 AM   #5
G00fy
Member
 
Registered: Jul 2004
Location: Herent, Belgium, Europe, Earth
Distribution: Ubuntu 7.04
Posts: 102

Original Poster
Rep: Reputation: 15
Hi davcefai,


In Gnome I found something under System > Administration > Device Manager. But there I only see what kind of hardware I have... Nothing to choose (and I see I have nVidia CK 804 capture/playback/... ALSA stuff).

The thing is that I have sound, but can't use twinkle phone . So I always have to boot to windows to call... Kinda stupid .


I just found System > Preferences > Multimedia Systems Selector. Seems what you meant...
When testing ALSA I get a rather high constant tone... So I guess that's OK?

I tried twinklephone after that and I heard it rang, and it didn't gave any error, so it's resolved by this small little trick of yours

Thanks a lot!
 
  


Reply

Tags
alsa, gnome, kde, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Soundcards in ALSA jp_ Slackware 7 12-11-2006 03:31 PM
alsa and udev-078 alsactl:load state No soundcards found... marekjs Slackware 5 02-26-2006 06:04 PM
alsa and udev-078 alsactl:load state No soundcards found... marekjs Linux - Software 2 02-22-2006 06:21 AM
No soundcards were found lonelyghost317 Linux - Hardware 2 06-06-2005 11:22 PM
Two soundcards and ALSA josiah Linux - Hardware 0 09-11-2004 02:57 PM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration