LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 12-20-2004, 10:46 AM   #1
Qwertie
LQ Newbie
 
Registered: Dec 2004
Distribution: Fedora Core 2
Posts: 23

Rep: Reputation: 15
'Unknown symbol usb_kill_urb'


I've been trying to get a PRISM 2.5 USB wireless device to work in this thread:

http://www.linuxquestions.org/questi...5&pagenumber=4

After a lengthy process that eventually seemed to install the driver successfully, I now get errors trying to start it:

Quote:
But when I run /etc/init.d/wlan start ...

[root@localhost dpiepgrass]# /etc/init.d/wlan start
Starting WLAN Devices: FATAL: Error inserting prism2_usb (/lib/modules/2.6.5-1.358/linux-wlan-ng/prism2_usb.ko): Unknown symbol in module, or unknown parameter (see dmesg)
[root@localhost dpiepgrass]# [ OK ]

...I figured I'd reboot to see if the init procedure would happen on startup. During bootup, a different error message came out, which was approximately:

usb_prism2 device wlan0 does not seem to be present. Delaying initialization.

I looked through dmesg's output and found

usb 1-1: new full speed USB device using address 2
prism2_usb: Unknown symbol usb_kill_urb

The latter message,

prism2_usb: Unknown symbol usb_kill_urb

appears several times in the file, but only once adjacent to that usb1-1 message, which seems to indicate the device is recognized (there is only one usb device attached, and that is the wireless thingie)
So, can anyone explain these errors?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
via_drv.o : unknown symbol vgaHWGetIndex theYinYeti Linux - Software 1 12-02-2005 06:30 PM
modprobe -> Unknown symbol in module sara_W Linux - Wireless Networking 1 09-13-2004 01:32 AM
unknown symbol sys_mknod in module? dklaming Linux - General 0 05-07-2004 12:55 PM
sbp2: Unknown symbol chichibabin Mandriva 0 02-17-2004 08:21 AM
megaraid.ko needs unknown symbol doing install_modules on 2.6.2 Toadie Linux - Software 0 02-15-2004 06:53 PM


All times are GMT -5. The time now is 12:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration