LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-25-2006, 03:36 AM   #1
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Rep: Reputation: 31
XTerm set font to "Courier"


I'd like to set the Xterm font to "Courier", is this possible? If not, is there any terminal [except gnome-terminal/konsole] that has this ability?
 
Old 07-25-2006, 04:11 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
man xterm. Run xfontsel -print. Select the font. Write down its code (will be printed). First option: type it in xterm (or cat a file with it), select, ctrl-rightclick and choose selection. Second option: command-line option.
 
Old 07-25-2006, 06:15 AM   #3
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Original Poster
Rep: Reputation: 31
I understood, with some difficulty how to use xfontsel. I run an xterm, run xfontsel -print, select the font options in the xfontsel window, click "select", go back to the xterm, ctrl+right click and choose selection. This seems to work. This is what xfontsel prints:

Code:
-*-courier-bold-r-normal--14-*-*-*-*-*-iso8859-
I don't know how I use this.

#2. Command line options. Good .. great.. which ones? I know about the "-fn"/"-font" switches, but I can't figure out the correct argument for "courier"

Code:
$ xterm -font courier
xterm:  unable to open font "courier", trying "fixed"....
A bit more details, if you wish raskin?
 
Old 07-25-2006, 06:28 AM   #4
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
The line is what you need - it is font identifier. The line (well, better surround with '') should be passed to -fn; or selected when displayed in xterm with ctrl-rightclick font->selection.
 
Old 07-25-2006, 06:37 AM   #5
introuble
Member
 
Registered: Apr 2004
Distribution: Debian -unstable
Posts: 700

Original Poster
Rep: Reputation: 31
Thanks a lot! I wasn't quoting the font string.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Could not init font path element""Unix /: 7100 removing from list/ zameer_india Linux - Networking 7 07-03-2006 06:11 AM
XTerm set font to "large" from command line introuble Linux - General 3 06-26-2006 04:11 AM
How to set the size of icons for "Starterbar" in "Gdekslets" Blue Jacket Linux - Software 4 11-23-2005 02:42 AM
Could not init font path element. Could not find default font "fixed" SidA Red Hat 0 06-19-2004 08:42 PM
Font "courier" shows as whitespace. What to do? mrTK Linux - General 3 10-08-2003 02:00 PM


All times are GMT -5. The time now is 10:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration