LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-24-2007, 09:43 AM   #1
anirudh.iitm
LQ Newbie
 
Registered: Jun 2006
Location: chennai , india
Distribution: ubuntu
Posts: 26

Rep: Reputation: 15
xset dpms force off does'nt turn off screen


hi,
i am using ubuntu dapper.
to turn off the screen ,i tried
xset dpms force off
but it did'nt work
then i tried
xset s standby
that and
xset dpms force standby
also dont work.
what i mean by not working is that nothing at all happens on typing these commands in bash.

but,
vbetool dpms off
and
vbetool dpms standby
both turned off the screen.However, i was only able to turn it back on using cntl+alt+del.
xset dpms force off worked for me earlier in a previous install of dapper.i had to recently reinstall it(over edgy that i did'nt like).Could the problem be related to that?
 
Old 02-24-2007, 10:46 AM   #2
marsm
Member
 
Registered: Aug 2005
Distribution: Ubuntu
Posts: 62

Rep: Reputation: 15
Hi, I have the same problem with my nx6310 laptop display. I had to do:

xset s off #turns off the screensaver function
vbetool dpms off (on) #to switch it off (on)

If you want to give your user access to vbetool, do this:
# chmod a+s /usr/sbin/vbetool

If you use Fluxbox, you can now map the vbetool command to a combination of keys. I have this in my ~/.fluxbox/keys file:
Mod1 x :ExecCommand /usr/sbin/vbetool dpms off
Mod1 c :ExecCommand /usr/sbin/vbetool dpms on

Now I can switch it on/off with Alt-X and Alt-C.
 
Old 02-24-2007, 11:18 AM   #3
anirudh.iitm
LQ Newbie
 
Registered: Jun 2006
Location: chennai , india
Distribution: ubuntu
Posts: 26

Original Poster
Rep: Reputation: 15
thanks man
 
Old 02-24-2007, 02:54 PM   #4
marsm
Member
 
Registered: Aug 2005
Distribution: Ubuntu
Posts: 62

Rep: Reputation: 15
No problem, anirudh, I hope it works for you.

For some reason my display still is getting switched back on again after a few minutes, although I've done: xset s off

gnome-screensaver and xscreensaver are off. So what is switching it back on again? Would somebody else please care to enlighten me?

Btw, I'm only using vbetool because that actually switches off my LCD backlight (which gnome-screensaver and xscreensaver don't).

On a side note: Why does even such a simple thing have to be such a PITA in Ubuntu? xscreensaver just did what it was told to do in Slackware, but Slackware won't even boot on my laptop :/

Last edited by marsm; 02-24-2007 at 03:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
dpms / screen shuddering celejar Linux - Software 0 11-10-2004 11:54 PM
xset -dpms and xset s off ericcarlson Fedora 1 10-01-2004 08:45 AM
Can't turn off screen blanking DaBayer Red Hat 0 01-23-2004 08:41 AM
Slackware 8.1 and xset dpms problem. tchang Slackware 0 04-28-2003 11:53 AM


All times are GMT -5. The time now is 12:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration