LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-17-2006, 06:21 AM   #1
Thaidog
Member
 
Registered: Sep 2002
Location: Hilton Head, SC
Distribution: Gentoo
Posts: 616

Rep: Reputation: 32
Question xorg + failed to initialize core devices


I am getting an xorg "failed to initialize core devices" error when trying to startx after installing ATI drivers and configuring the card with "aticonfig".

The Xorg log can be viewed here:
http://www.tyler.mcadams.com/Xorg.0.log
 
Old 12-17-2006, 10:59 AM   #2
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Check the mouse configuration in your xorg.conf

The problem is that '/dev/mouse' is not a correct path, at least for your system 'n' that's the error.

Maybe will be '/dev/mice' or '/dev/misc/psaux' or something similar....




Regards
 
Old 12-17-2006, 06:03 PM   #3
Thaidog
Member
 
Registered: Sep 2002
Location: Hilton Head, SC
Distribution: Gentoo
Posts: 616

Original Poster
Rep: Reputation: 32
Question

Quote:
Originally Posted by Acron_0248
Check the mouse configuration in your xorg.conf

The problem is that '/dev/mouse' is not a correct path, at least for your system 'n' that's the error.

Maybe will be '/dev/mice' or '/dev/misc/psaux' or something similar....




Regards
That was it! It was /dev/input/mouse1

THX!!!
 
Old 12-17-2006, 08:02 PM   #4
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
No problem....



Regards
 
  


Reply

Tags
ati, aticonfig, devices, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian startx Fatal Error : Failed to initialize core devices TextBrowserAddict Debian 2 08-21-2005 11:42 PM
nvidia + xorg = death (fails to initialize) scius Linux - Software 6 10-11-2004 10:36 AM
Failed to initialize AGP k_brother Slackware 3 10-18-2003 02:02 PM
Failed to initialize core devices kko88 Linux - Hardware 2 06-11-2003 07:07 PM
X won't start: "Fatal server error: failed to initialize core devices" ! Debianewb Linux - Newbie 14 08-27-2002 06:21 PM


All times are GMT -5. The time now is 11:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration