LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   XGL/Beryl Performance on Laptop with Intel GMA 950 Integrated graphics 945GM (http://www.linuxquestions.org/questions/linux-general-1/xgl-beryl-performance-on-laptop-with-intel-gma-950-integrated-graphics-945gm-586859/)

Jyneo 09-24-2007 01:16 AM

XGL/Beryl Performance on Laptop with Intel GMA 950 Integrated graphics 945GM
 
Hi, I'm not sure if this thread is in the right section but I didn't know where else to post it.
I'm having some performance problems with XGL/Beryl and I'm wondering if there's anything I can do to fix it.
Here are my specs:

Gateway NX570X Laptop
Intel Core 2 Duo 1.76 Ghz
DDR2 2.5 GB RAM
Integrated Intel 945GM Video Card with 256 Shared system memory
Intel GMA 950 Chipset

I installed openSUSE 10.2 and everything worked perfectly. I set up XGL with Beryl and again everything works fine except for when I try to play video. Once I start playing a video everything gets very choppy, not just the video, everything. Also, I noticed sometimes when the screensaver comes on it will cause some lag as well. Once I thought my computer froze up for a few minutes because the screensaver took so long to go away.

If anyone else has had this problem and knows how to fix it I'd greatly appreciate it. I don't know if there is a setting I can change in the xorg.conf file or maybe somewhere else that might fix the issue or if my hardware just can't handle XGL to its full extent when playing video.

If you need any more information (i.e. part of my xorg.conf file) let me know and I'll post it. Or if you know of a place on the internet with a fix then posting the link would be great too and I'll try it out. Thanks for any help.

lambchops468 09-24-2007 05:46 PM

just guessing here:

in your beryl icon in the system tray/kicker, do you have XGL rendering enabled (right click for menu, check the sub menus for something like that...the computer i am using doesn't have 3d, so i am guessing where the setting is). You should also try and get textures by pixmap.

beware that changing the settings may cause beryl to bug up when u log into KDE, so disable auto-start for testing (by deleting the auto-start entry.)


All times are GMT -5. The time now is 09:46 PM.