LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-30-2004, 07:48 PM   #1
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Rep: Reputation: 30
Question xfree86 isn't setting mtrr registers


I'm running Xfree86 4.1.01. kernel 2.4.17 Debian 3.0r2 (woody). I built a kernel with mtrr support, and dmesg contains:

mtrr: v1.40 ...
mtrr: detected mtrr type: AMD K6

Also, /proc/mtrr exists.
X isn't, however, setting up the registers (/etc/proc is empty). On an earlier install of the same system (hardware, software) it worked fine, but I reinstalled, and now it doesn't. Any ideas?
 
Old 11-03-2004, 10:17 PM   #2
celejar
Member
 
Registered: Oct 2003
Location: New York
Distribution: Debian Sid
Posts: 185

Original Poster
Rep: Reputation: 30
I think I've solved my problem. My system has onboard video with an SiS chipset, and I'd been using the vesa driver in Xfree86. I had done so since the SiS driver didn't seem to be working properly, and the vesa worked fine. The SiS driver sets the mtrrs and screen performance is better (perhaps consequently; video performance certainly improves as a result, as I found once when I followed mplayer's suggestion and rebuilt the kernel to include mtrr support, not changing anything within X), but I had a hard time getting the screen res right and eliminating artifacts. I eventually apparently succeeded, though, after reading the SiS file within the X docs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/proc/mtrr gomez Linux - General 4 12-21-2004 07:38 PM
setting up xfree86 djgerbavore Slackware 3 08-10-2004 10:21 AM
mtrr support abs Slackware 1 03-03-2004 12:17 AM
Setting up ATI Rage LT Pro card under XFree86 Oooska Linux - Newbie 1 02-27-2002 01:09 AM
setting up XFree86 on old comp, w/ old monitor! skotzko Linux - General 2 01-22-2001 07:23 PM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration