LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   XFCE keyboard shortcuts stop working (http://www.linuxquestions.org/questions/linux-general-1/xfce-keyboard-shortcuts-stop-working-4175425063/)

suicidaleggroll 08-31-2012 09:19 PM

XFCE keyboard shortcuts stop working
 
Wasn't sure whether to put this in General or in Linux - Distributions, Since I'm not sure if this is an OpenSUSE problem or an XFCE problem.

Anyway, running OpenSUSE 12.1 with XFCE. For the most part everything works great. Literally my only complaint is that the keyboard shortcuts are sporadic. I'll set up a new shortcut via Settings > Preferences > Personal Settings > Shortcuts and Gestures > Custom Shortcuts.

After setting up the shortcut, it will work for a while, but eventually it just stops working for no apparent reason. I haven't quite yet determined exactly when it stops, but I think it might be when the system is restarted. When it stops working, I can simply go back into Settings > Preferences > Personal Settings > Shortcuts and Gestures > Custom Shortcuts, and it works again. I don't even have to check any check boxes...click OK or Apply...all I have to do is OPEN the Shortcuts and Gestures window, and the shortcut is back up and running again.

I've tried this with multiple keyboard combinations for the shortcut I'm interested in. All I want to do is assign a simple key combination to open a terminal. In Gnome2 I usually assign the left Windows key to open a terminal, but apparently XFCE doesn't like that key, so I assign the Lenovo "ThinkVantage" button to a terminal, which works until it decides it doesn't want to work anymore.

DavidMcCann 09-02-2012 12:56 PM

I have Xfce (Salix) on my Thinkpad and I've never had that problem. I've never had any problems with the Super key, either, and I use Super+t for a terminal. I suspect it's an OpenSUSE thing, as I've noticed that distro does have problems when it's not KDE.

If the worst comes to the worst, you could always use xbindkeys.

suicidaleggroll 09-02-2012 01:24 PM

It looks like xbindkeys is going to do the trick.

It's not that XFCE couldn't use the Super key, it's that it wouldn't allow me to use the super key by itself. I could set up Super+t for a terminal, but I just want "Super".

Either way, I installed xbindkeys and set up a .xbindkeysrc file with the following:
Code:

"konsole"
  Super_L

And it seems to work great.


All times are GMT -5. The time now is 08:45 AM.