LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-06-2004, 05:13 AM   #1
akilles
Member
 
Registered: Sep 2004
Location: Vestfold, Norway
Distribution: Slackware
Posts: 139

Rep: Reputation: 15
X-Windows and Fluxbox


Hi.
I'm sure this question has been asked and answered many times before, but after several searceh I still haven't found a solution.

I would like to have my terminal windows (aterm) in the Workspace, with no scrollbars or borders. I've seen screenshots with this, but all the attempts I have made, failed.

The latest attempt was: Creating a file in ~/.fluxbox called apps.
This file should contain:
[app] (aterm)
[Sticky] {no}
[Deco] {NONE}
[end]

I created this file, reloaded and restarted fluxbox, but no change.
I am using Slackware 8.1, Fluxbox 0.1.14 and aterm 0.42

Best regards
Geir O.
 
Old 10-06-2004, 07:09 AM   #2
hkxx9
Member
 
Registered: Sep 2004
Location: Smoky Mtns
Distribution: Slackware 10
Posts: 64

Rep: Reputation: 15
Hmm Mine looks something like this:

[exec] (aterm) {aterm +sb -fg black -fb fixed}

has borders, but no scroll bars. Check the options to aterm.

hth

Last edited by hkxx9; 10-06-2004 at 07:11 AM.
 
Old 10-06-2004, 10:55 AM   #3
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
Options in aterm do not remove borders, so akilles is correct about using ~/.fluxbox/apps for that part.

Fluxbox 0.1.14 doesn't use the apps file. You will have to either add the "remember" patch, or upgrade to Fluxbox devel.
Personally I recommend upgrading.
 
Old 10-06-2004, 11:03 AM   #4
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
Here's mine:

Code:
aterm -bl -sh 70 -tr -fg white -bg black +sb -color4 white -color12 yellow
'-bl' - no borders

edit: am using pekwm now but just checked one of my old fluxbox screenshots - I can't remember if I was using '-bl' then or not so I could be wrong. Here's what my current aterm code looks like in pekwm (and also looks like that in openbox)

Last edited by cb_linus; 10-06-2004 at 11:08 AM.
 
Old 10-07-2004, 12:29 AM   #5
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
-bl doesn't exist as an option in my aterm (v0.4.2)
 
Old 10-07-2004, 03:51 AM   #6
akilles
Member
 
Registered: Sep 2004
Location: Vestfold, Norway
Distribution: Slackware
Posts: 139

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by mikshaw
Fluxbox 0.1.14 doesn't use the apps file. You will have to either add the "remember" patch, or upgrade to Fluxbox devel.
Personally I recommend upgrading.
Thanks mikshaw.
Guess I have to upgrade then. It's just as well really. I'm going to upgrade my system also, from Slack 8.1 to 9.1
8.1 came with Kernel 2.4.18, and my onboard VIA82c686 isn't supported until Kernelversion 2.4.20. Sound is a must when I'm at work. I might get an old SoundBlaster card, and use that instead, and only upgrade fluxbox.
 
Old 10-07-2004, 08:42 AM   #7
akilles
Member
 
Registered: Sep 2004
Location: Vestfold, Norway
Distribution: Slackware
Posts: 139

Original Poster
Rep: Reputation: 15
I just upgraded to devel version 0.9.10, and borderless is great.
However I have one "problem" (I also had it before, just forgot to mention it).
I use the /home/geir/.fluxbox/keys file and the entry:
Mod1 a :ExecCommand aterm -tr -trsb -fg green -sh 85
The aterm shows up, but the prompt says something like: bashxxxxxx
When I type bash --login it shows geir@geir$, like it should.
Is there a way of bypassing this problem?

On another note: I upgraded to XFree86 4.4.0, because I want to run WINE for one program we use here at work. The upgrade was painless, and everything appears to be working OK.

Geir O.
 
Old 10-07-2004, 11:04 AM   #8
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
Your bash prompt is apparently being set differently from bash_profile or profile (for login shells) and from bashrc (for non-login shells).
The quickest fix is to use the "-ls" aterm option to open a login shell which grabs the PS1 from profile or bash_profile.
Another option is to edit the PS1 variable in ~/.bashrc to your taste.
 
Old 10-08-2004, 02:13 AM   #9
akilles
Member
 
Registered: Sep 2004
Location: Vestfold, Norway
Distribution: Slackware
Posts: 139

Original Poster
Rep: Reputation: 15
The -ls option in aterm did something with the transparency, and bg color. I don't use the -bg option, but the
background was set to grey... Go figure.
Another thing is: I don't have the ~/.bashrc file.. Is that a problem, or just the way Slack 8.1 works?
I do however have ~/.bash_history

-Geir O.
 
Old 10-08-2004, 08:14 AM   #10
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
Just create a .bashrc file and add a line for your prompt then see what happens when you start up a new terminal Here's mine:

Code:
PS1='\[\e[1;33;27m[\[\e[1;32;27m\u@\h \W $\[\e[1;33;27m]\[\e[0m\] '
Alternatively you could start with something more simple like:

Code:
PS1='\u\h \W$ '
 
Old 10-08-2004, 08:31 AM   #11
akilles
Member
 
Registered: Sep 2004
Location: Vestfold, Norway
Distribution: Slackware
Posts: 139

Original Poster
Rep: Reputation: 15
Thanks.
I think I'll go for the simple one at first..

-Geir O.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Get DockApp under Fluxbox Windows?? nedson Linux - Software 1 01-15-2005 08:28 PM
Group windows in fluxbox Ephracis Linux - Newbie 4 10-18-2004 04:03 PM
Fluxbox : windows decoration angel_killah Linux - General 3 06-30-2004 08:43 AM
Fluxbox + Windows keyboard and menu/windows key ==> Any takers PGDubbin Linux - General 0 05-21-2004 01:56 PM
Can't see Windows computers in Fluxbox Vincent_Vega Linux - Networking 2 01-22-2004 04:31 AM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration