LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-15-2007, 04:40 AM   #1
lrieneck
LQ Newbie
 
Registered: Aug 2007
Location: Denmark
Distribution: Debian Lenny
Posts: 6

Rep: Reputation: 0
Solved: X cursor problem when i run dual head mode


Hello

I have installed a Debian Lenny on my IBM T43p Thinkpad Notebook. I have an X cursor problem when i run dual head mode.
My laptop screen is on my left hand side an I have a DELL screen on my right hand side, connected by a DVI cabel to the laptop docking station.
The problem is the cursor on my DELL screen it is a big square with random containt.
If I enable SWCursor in my /etc/X11/xorg.conf i get a small square on both ny laptop screen and on my DELL screen.

I am running with:
xserver-xorg 1:7.2-5

And I have build my own display driver from the ATI home page.

fglrx-control 8.38.6-2
fglrx-driver 8.38.6-2
fglrx-kernel-2.6.22.1lri-1 8.38.6-2
fglrx-kernel-src 8.38.6-2

My /etc/X11/xorg.conf looks like this:
Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "dk"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
#Option "OverlayOnCRTC2" "1"
#Option "HWCursor" "False"
#Option "SWCursor" "True"
#Option "oOVideverlay" "on"
#Option "DesktopSetup" "horizontal"
#Option "DesktopSetup" "LVDS,AUTO" #the types of monitors that is connected LVDS = LCD, CRT, AUTO
#Option "MergedFB" "true"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "fglrx"
Option "oOVideverlay" "on"
#Option "HWCursor" "False"
#Option "SWCursor" "True"
Option "ConnectedMonitor" "DFP"
Option "MergedFB" "true"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
#Option "VendorName" "ATI Proprietary Driver"
#Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
#Option "VendorName" "ATI Proprietary Driver"
#Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS"
#Option "SWCursor" "True"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1400x1050"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
#Option "SWCursor" "True"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1200"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
Screen 1 "aticonfig-Screen[1]" RightOf "aticonfig-Screen[0]"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
#Option "Xinerama" "true"
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection

Section "Extensions"
Option "Composite" "Disable"
Option "XVideo" "Enable"
EndSection

Last edited by lrieneck; 08-05-2008 at 11:35 PM.
 
Old 08-05-2008, 03:47 PM   #2
lrieneck
LQ Newbie
 
Registered: Aug 2007
Location: Denmark
Distribution: Debian Lenny
Posts: 6

Original Poster
Rep: Reputation: 0
Solution to the problem

I had to get a new version of the fglrx driver, it was a known issue.

/Lars
 
Old 08-05-2008, 04:19 PM   #3
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
To date, 563 people have read your Q, which is already solved. [& thanks for posting the solution]
Please edit the post title to read ..... [Solved] to save us all wasting time.
Thanks
 
Old 08-05-2008, 11:35 PM   #4
lrieneck
LQ Newbie
 
Registered: Aug 2007
Location: Denmark
Distribution: Debian Lenny
Posts: 6

Original Poster
Rep: Reputation: 0
Solved: X cursor problem when i run dual head mode

Is this the way to do it?

/Lars
 
Old 08-06-2008, 04:38 AM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
Is this the way to do it?
Yes. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Head Monitor Setup and Console Mode verdeboy2k Linux - Hardware 0 05-18-2006 09:10 PM
Mouse cursor visible on only one screen (dual head) pingu Mandriva 0 01-19-2006 10:29 AM
ATI Radeon 9800pro DUAL HEAD mode NOT working! grelle Linux - Hardware 2 02-14-2005 01:19 PM
Dual head mode radeon in XFree 4.4 xanas3712 Linux - Newbie 1 05-16-2004 04:57 AM
Dual Head Xinerama combined with Traditional mode tychop Linux - Hardware 1 05-02-2003 11:55 AM


All times are GMT -5. The time now is 01:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration