LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 03-03-2005, 08:49 PM   #1
tom221
LQ Newbie
 
Registered: May 2004
Location: CA
Distribution: Red Hat Linux
Posts: 11

Rep: Reputation: 0
X and Firefox don't recognize newly added fonts


X and Firefox don't recognize my newly added fonts. Here is what I did.

1. I added Bitstream fonts into an existing font directory in RedHat 8 and regenerated the index. The output is truncated.

[root@local TTF]# ls /usr/X11R6/lib/X11/fonts/TTF
fonts.dir luximri.ttf luxirri.ttf luxisri.ttf VeraIt.ttf VeraMono.ttf
fonts.scale luximr.ttf luxirr.ttf luxisr.ttf VeraMoBd.ttf VeraSeBd.ttf

[root@local TTF]# ttmkfdir > fonts.dir

2. I restarted the machine and use chkfontpatch and xlsfonts to check my new fonts.

[root@local root]# chkfontpath -l
Current directories in font path:
............
7: /usr/X11R6/lib/X11/fonts/cyrillic
8: /usr/X11R6/lib/X11/fonts/TTF
9: /usr/share/fonts/default/Type1
10:

[root@local root]#xlsfonts
-bitstream-bitstream vera sans mono-bold-i-normal--0-0-0-0-m-0-ascii-0
.......

3. I then check the new fonts in both Preference --> Font (Gnome Desktop) and Firefox but nothing comes up. What can I do to fix it?
 
Old 03-04-2005, 10:07 PM   #2
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Try adding your fonts into /usr/share/fonts/local then use the command 4fc-cache /usr/share/fonts/local

HTH
 
Old 03-08-2005, 04:19 PM   #3
tom221
LQ Newbie
 
Registered: May 2004
Location: CA
Distribution: Red Hat Linux
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i mount newly added H.D using SuSe 9.0 elbrens Linux - Software 3 08-14-2007 01:51 PM
man page access for newly added users puffinman Linux - Newbie 3 01-22-2005 09:58 PM
How to add an existing linux on a newly added disk to grub ? glenn69 Linux - Newbie 1 10-07-2004 09:16 PM
cant send email (using sendmail) to newly added domain user sirjosi Linux - Newbie 0 10-22-2003 01:12 AM
newly added harddrive not showing.... pdmackenzie Linux - Hardware 4 03-02-2003 05:18 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration