LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-25-2006, 01:06 PM   #1
Shioni
Member
 
Registered: Mar 2006
Posts: 182

Rep: Reputation: 30
witch distro has prism2_usb modules?


Hi!
Yeah, I know it's a stupid question, but I got an Netgear MA111 card, and I want to test it, without recompiling the kernel etc.. it would be great, if it's a live CD, but regular distro would also work! thank you!
 
Old 10-25-2006, 02:57 PM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Check your distros repositories for the Driver..

Code:
default@itg-debian:~$ apt-cache search Prism2
hostap-modules-2.4.27-2-686 - Host AP driver for Intersil Prism2/2.5/3 (kernel 2.4.27-2-686)
hostap-modules-2.6.8-3-686 - Host AP driver for Intersil Prism2/2.5/3 (kernel 2.6.8-3-686)
hostap-modules-2.6.8-3-686-smp - Host AP driver for Intersil Prism2/2.5/3 (kernel 2.6.8-3-686-smp)
hostap-source - Host AP driver for Intersil Prism2/2.5/3
hostap-utils - Utility programs for Host AP driver for Intersil Prism2/2.5/3
hostapd - user space IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator

So it's available in Debian or any debian based distro, such as Ubuntu, Kubuntu, Xandros, Knoppix, etc.. but is probably not loaded by default.

One Live CD that MAY have it available by default would be Auditor, since it is designed to work with wireless from a Live CD. http://www.remote-exploit.org/index.php/Auditor_main

Last edited by farslayer; 10-25-2006 at 02:59 PM.
 
Old 10-25-2006, 03:43 PM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,173

Rep: Reputation: 47
Knoppix 3.7 has it. I haven't tried any versions after 3.7. But just knowing that it's Prism2/2.5 isn't enough. I have three of these since before I started with Linux. The module that comes with the kernels never worked for me. If your kernel is before 2.6.15 wlan-ng is what you need. That's what Knoppix has. Later kernels have to settle for ndiswrapper. Neither involves recompiling the kernel, just the modules that get loaded by the kernel.

That's just my experience.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
prism2_usb joaquinbuendia Linux - Networking 0 09-11-2005 06:20 PM
32MbRam and glibc2.3. Witch distro? Lusitan Linux - Distributions 2 12-22-2004 11:18 PM
Witch distro to choose? Calenulma Linux - Newbie 10 09-17-2004 04:59 PM
Witch distro is the most compatible. CryptDragoon Linux - General 4 02-28-2004 12:42 AM
Witch linux distro? Devboy Linux - Distributions 4 12-11-2003 08:37 AM


All times are GMT -5. The time now is 10:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration