LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   windows keeps erasing boot flag (http://www.linuxquestions.org/questions/linux-general-1/windows-keeps-erasing-boot-flag-533896/)

zowey 03-02-2007 09:46 AM

windows keeps erasing boot flag
 
I read one topic about this problem and solution was something
like adding notice to windows that my linux paritition is active.
But in storage management i'm not able to set it active...
what shell i do?
Grub is installed, but windows changes flag to own parition so
grub can't say even word

pixellany 03-02-2007 10:50 AM

Linux does not use the "boot" or "active" flag. Set it on the Windows partition only.

zowey 03-02-2007 11:25 AM

WHy does it boots then?
I can't set anything active

pixellany 03-04-2007 09:09 AM

You can use any partition manager to set the active flag: fdisk, GParted (comes on a stand-alone live CD), QTParted (comes with many distros, including the Knoppix live CD)

The Linux bootloader (grub or lilo) sends the system to a specified partition--it does not care about the boot flag

zowey 03-06-2007 10:50 AM

even thought i put boot flag on linux, when i rise windows and reboot system it automaticaly goes to windows..
if i go to linux first and reboot the computer grub rises normaly.

osor 03-06-2007 11:52 AM

Quote:

Originally Posted by pixellany
Linux does not use the "boot" or "active" flag. Set it on the Windows partition only.

Unless linux’s bootloader is not in the MBR…

pixellany 03-06-2007 12:31 PM

Quote:

Originally Posted by osor
Unless linux’s bootloader is not in the MBR…

Are you saying that--if grub is in a partition boot sector and that partition is chain-loaded--that the active flag is required?

pixellany 03-06-2007 12:36 PM

Quote:

Originally Posted by zowey
even thought i put boot flag on linux, when i rise windows and reboot system it automaticaly goes to windows..
if i go to linux first and reboot the computer grub rises normaly.

I cannot visualize what you are doing. The computer will go the hard drive which the BIOS identifies as #1, and it will look in the mbr for boot code. ti does not matter how the active flags are set.

Windows does apparently need an active flag, but I am not sure at what stage of the process it matters.

What are you doing to "go to Linux first"?

Running from Linux, Please post the output of: (do these as root)

Code:

fdisk -l
cat /boot/grub/menu.lst


osor 03-06-2007 03:20 PM

Quote:

Originally Posted by pixellany
Are you saying that--if grub is in a partition boot sector and that partition is chain-loaded--that the active flag is required?

I’m saying if grub is on a primary partition’s volume boot sector, and the MBR has only the standard MS MBR code, and the aforementioned grub is desired to be chainloaded from the MBR, the corresponding partition should have the “active” flag set in the MBR’s partition table.

osor 03-06-2007 03:24 PM

Quote:

Originally Posted by pixellany
The computer will go the hard drive which the BIOS identifies as #1, and it will look in the mbr for boot code.

After it looks in the MBR for boot code, it will execute that code. If that code is standard PC MBR code (as opposed to grub or lilo code), that program will chainload the boot sector of the partition marked as active.

pixellany 03-06-2007 03:35 PM

Quote:

Originally Posted by osor
After it looks in the MBR for boot code, it will execute that code. If that code is standard PC MBR code (as opposed to grub or lilo code), that program will chainload the boot sector of the partition marked as active.

This would be a way of using the Windows mbr code to dual-boot Linux, n'est-ce pas?
Have you tried it? (I have never seen it mentioned in the bazillion of posts on dual-booting)


PS: Zowey; We have not forgotten you--we're just having a side discussion while waiting for some more info from you......

osor 03-06-2007 05:34 PM

Quote:

Originally Posted by pixellany
This would be a way of using the Windows mbr code to dual-boot Linux, n'est-ce pas?
Have you tried it? (I have never seen it mentioned in the bazillion of posts on dual-booting)

Yes I have (it has been).

zowey 03-17-2007 05:10 AM

i suppose that i should set grub in MBR. :p
strange, this time it works. I've just reinstalled grub and it works.

pixellany 03-17-2007 10:21 AM

Quote:

Originally Posted by zowey
i suppose that i should set grub in MBR. :p
strange, this time it works. I've just reinstalled grub and it works.

Hooray!!!

WIN-WIN: You solved your issue, and we learned something about the boot flag from Osor--I need to go play with this...


All times are GMT -5. The time now is 10:24 PM.