LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Win / Tux key no longer bound as a modifier in KDE 3.5 / FC 4 (http://www.linuxquestions.org/questions/linux-general-1/win-tux-key-no-longer-bound-as-a-modifier-in-kde-3-5-fc-4-a-418139/)

atarisan 02-21-2006 05:52 PM

Win / Tux key no longer bound as a modifier in KDE 3.5 / FC 4
 
The win/tux key is no longer bound as a key-press. I setup many keyboard shortcuts to be Win+PageUp or Win+C and none of them work anymore. Also I cannot bind new shortcuts to that or my right-hand Alt key. If I go into KDE Control Center under Regional & Accessibility - Keyboard Shortcuts -> Modifier Keys, it states that Modifier "win" is bound to X11-Mod "mod4"

However under the subheading "X Modifier Mapping" it shows nothing at all bound to mod4 and only Alt_L bound to mod1 and not Alt_R. It has both Control keys bound.

Is there a config text file somewhere I can edit these bindings directly? A search of /etc/X11/Xmodmap left me thinking that file was not used. I was also unable to locate anything in my home folder that seemed obviously to do with key bindings.

DeusExLinux 02-21-2006 09:51 PM

..what about the kbd rules in your xorg config?

atarisan 02-22-2006 11:18 AM

Do you mean this?

Quote:

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection
I couldn't find anything pertinent in the man pages on xorg.conf or kbd. XkbOptions would be more usefull if I could simply find a listing of what options are available. The man page was dissapointing at best. Is there some obvious place to look for this documentation that I am missing?

DeusExLinux 02-22-2006 04:14 PM

hmm.. odd.
What did you do immedieatly before it stopped workign?

Update Xorg, spill somethingon the keyboard? or did it "just [not] work"..?

atarisan 02-22-2006 04:34 PM

I believe Gnome may have been updated in the time between I last remember it definitely working(Feb. 17) and when I know it had stopped working(Feb. 20). I had updated Gnome to see if it fixed my "New Terminal" option having gone missing in the desktop context menu(it didn't). x.org I believe has stayed the same version. Updates come through yum from official fedora repos. All of this would be a non-issue if I could simply figure out where the configuration of the modifier key mapping is stored. Thus far have had no luck with that. The control center Regional & Accessibility - Keyboard Shortcuts -> Modifier Keys, doesn't appear to have the ability to actually "change" anything at all which I find immensely frustrating.

If anyone knows where I should be looking for additional documentation on how to setup/modify options for the kbd driver I would be very thankful.

atarisan 02-23-2006 03:52 PM

Problem solved

The program I needed all along is called xmodmap.

A quick read of the man page on xmodmap gave me all the information I needed to get on the way to remapping my windows key to mod4. I began by finding the keycode of the windows key with a program called showkey -k. Then i bound the keycode (125) to the keysymname ISO_Level3_Shift using the command

xmodmap -e "keycode 125 = ISO_Level3_Shift"

and then bound ISO_Level3_Shift to mod4 via the command

xmodmap -e "add mod4 = ISO_Level3_Shift"

Now the win/tux key finally works as a modifier key once more. I used the same procedure to regain functionality of my Right Alt key. I hope this helps anyone else with similar problems.

DeusExLinux 02-23-2006 06:24 PM

Still wondering what happened to take away the functionality, but cool that you got it!


All times are GMT -5. The time now is 09:39 PM.