LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-24-2004, 09:07 PM   #1
ONEderer
Member
 
Registered: Jan 2004
Location: USA
Distribution: Mandrake, Knoppix
Posts: 50

Rep: Reputation: 15
Question Why is this sound card only 1/2 mute?


The operating system: Mandrake 9.2
The CPU: Intel p6 3.06 hyperthreading chip (now running in single mode).
The kernel: The default kernel that came with the Mandrake 9.2 download.
The sound card: Creative Labs [SB Live! Value] emu10k1 sound card.
The system manufacturer: Dell Dimension 8250 tower.
The problem:

When running a CD music disk, the sound is beautiful!
When talking into the microphone, the sound comes out of the speakers.
When running a DVD movie, using either Totem or Ogle, the sound is MUTE!
When trying out systems sounds or clicks, there is only silence!
The aRts sound server when activated, dumps /dev/dsp into /dev/null. Or, it sends the CPU into 100% saturation, then shuts itself off(aRts). With aRts off, still no systems sounds or DVD movies sounds.
This is a fresh re-installation. This time, and the previous time, the symptons are exactly the same!
Trying out different combinations of drivers, ect... , did not cure the problem.
Running "setup" in command mode, the sound card was identified, but a warning was given that this card is not supported in Mandrake.

Below, you will read the results of a script to test the sound parameters, for clues as to what may be wrong. If you can understand the results of this test, I would gratefully like to hear the remedy to this problem. And BTW this card runs flawlessly in Win*.

So here goes.....

/home/wanderer/sndcheck.sh: line 6: needed: command not found
/home/wanderer/sndcheck.sh: line 9: much: command not found
soundchk.sh v1.04 - Running Sound Configuration Checks

Identifying System
Linux Dell.readyaim.myserver.org 2.4.22-10mdk #1 Thu Sep 18 12:30:58 CEST 2003
i686 unknown unknown GNU/Linux
model name : Intel(R) Pentium(R) 4 CPU 3.06GHz
cpu MHz : 3049.543
MemTotal: 773908 kB
SwapTotal: 506008 kB

Checking Devices
lr-xr-xr-x 1 root root 13 Jan 24 06:49 admmidi -> sound/admmi
di
lr-xr-xr-x 1 root root 10 Jan 24 06:49 adsp -> sound/adsp
lr-xr-xr-x 1 root root 11 Jan 24 06:49 amidi -> sound/amidi
lr-xr-xr-x 1 root root 12 Jan 24 06:49 dmmidi -> sound/dmmidi
lr-xr-xr-x 1 root root 9 Jan 24 06:49 dsp -> sound/dsp
lr-xr-xr-x 1 root root 10 Jan 24 06:49 midi -> sound/midi
lr-xr-xr-x 1 root root 11 Jan 24 06:49 mixer -> sound/mixer
drwxr-xr-x 1 root root 0 Dec 31 1969 sound

Checking Driver
agpgart : Intel Corporation|82850 850 (Tehama) Chipset Host Bridge (MC
H) [BRIDGE_HOST] (vendor:8086 device:2530 subv:1028 subd:0145)
snd-emu10k1 : Creative Labs|[SB Live! Value] EMU10k1X [MULTIMEDIA_AUDIO] (
vendor:1102 device:0006 subv:1102 subd:1003)

Checking Actual Driver in Use (/etc/modules.conf)
alias sound-slot-0 snd-emu10k1
above snd-emu10k1 snd-pcm-oss
above snd-sb16 snd-pcm-oss
above snd-sbawe snd-pcm-oss
above snd-sgalaxy snd-pcm-oss

Checking alsa /proc/asound
Advanced Linux Sound Architecture Driver Version 0.9.6.
Compiled on Sep 18 2003 for kernel 2.4.22-10mdk with versioned symbols.
0 [Live ]: EMU10K1 - Sound Blaster Live!
Sound Blaster Live! (rev.0) at 0xec40, irq 18
0: [0- 0]: ctl
4: [0- 0]: hardware dependent
8: [0- 0]: raw midi
19: [0- 3]: digital audio playback
26: [0- 2]: digital audio capture
25: [0- 1]: digital audio capture
16: [0- 0]: digital audio playback
24: [0- 0]: digital audio capture
1: : sequencer
9: [0- 1]: raw midi
10: [0- 2]: raw midi
33: : timer
00-00: EMU10K1 (FX8010)
00-00: emu10k1 : EMU10K1 : playback 32 : capture 1
00-01: emu10k1 mic : EMU10K1 MIC : capture 1
00-02: emu10k1 efx : EMU10K1 EFX : capture 1
00-03: emu10k1 : EMU10K1 FX8010 : playback 8

Checking alsa /dev/snd
controlC0 controlC3 controlC6 midiC0D0 pcmC0D0c pcmC0D2c timer
controlC1 controlC4 controlC7 midiC0D1 pcmC0D0p pcmC0D3p
controlC2 controlC5 hwC0D0 midiC0D2 pcmC0D1c seq

Checking if Module Loaded
snd-seq-midi 5056 0 (autoclean) (unused)
snd-emu10k1-synth 5276 0 (autoclean) (unused)
snd-emux-synth 31900 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 6924 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 4588 0 (autoclean) [snd-emux-synth]
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 42544 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emu
l snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 1
snd-mixer-oss 14200 0 [snd-pcm-oss]
snd-emu10k1 70948 3 [snd-emu10k1-synth]
snd-pcm 79588 0 [snd-pcm-oss snd-emu10k1]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-page-alloc 9044 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 17760 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-util-mem 3040 0 [snd-emux-synth snd-emu10k1]
snd-seq-device 5832 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synt
h snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd-hwdep 6304 0 [snd-emu10k1]
snd-ac97-codec 45720 0 [snd-emu10k1]
snd 41380 2 [snd-seq-midi snd-emux-synth snd-seq-virmidi
snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 s
nd-pcm snd-timer snd-rawmidi snd-util-mem snd-seq-device snd-hwdep snd-ac97-co
dec]
soundcore 6340 0 [snd]

Checking if services configured to be run on initlevel 3
Checking if Sound services configured
error reading information on service sound: No such file or directory

Checking if Alsa service configured
error reading information on service alsa: No such file or directory

Checking if Sound Volume muted
Test not available on this system

Checking artsd setup
wanderer 9088 4015 0 09:46 ? 00:00:00 /usr/bin/artsd -F 10 -S 4096 - d -D /dev/dsp -s 1 -m artsmessage -l 3 -f

Checking which program uses the sound card or cdrom

USER PID ACCESS COMMAND
/dev/dsp wanderer 9088 f.... artsd

End of Checks
[root@Dell wanderer]# #!/bin/sh
bash: !/bin/sh: event not found
[root@Dell wanderer]# # soundchk.sh
[root@Dell wanderer]# # Rev 1.00 2003-10-13 Initial Release - Mandrake 9.1 specific
[root@Dell wanderer]# # Rev 1.01 2003-10-13 Added Checking Devices
[root@Dell wanderer]# # Added grep steps to restrict output. Really
[root@Dell wanderer]# needed for Knoppix.
bash: needed: command not found
[root@Dell wanderer]# # Add file exists tests to find correct tools
[root@Dell wanderer]# # Completed port to Knoppix 3.3. Should also be
[root@Dell wanderer]# much better for UNKNOWN.
bash: much: command not found
[root@Dell wanderer]# # Rev 1.02 2003-10-14 Added test -x for aumix
[root@Dell wanderer]# # Fix bug in lspci greps
[root@Dell wanderer]# # Rev 1.03 2003-11-24 Add additional tests from alsa aadebug script
[root@Dell wanderer]# # Rev 1.04 2003-11-25 Fix typo in 1.03 lspci grep
[root@Dell wanderer]# # Add check for artsd
[root@Dell wanderer]# # Add check for using cdrom
[root@Dell wanderer]#
[root@Dell wanderer]# echo "soundchk.sh v1.04 - Running Sound Configuration Checks"
soundchk.sh v1.04 - Running Sound Configuration Checks
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Identifying System
Identifying System
[root@Dell wanderer]# uname -a
Linux Dell.readyaim.myserver.org 2.4.22-10mdk #1 Thu Sep 18 12:30:58 CEST 2003 i686 unknown unknown GNU/Linux
[root@Dell wanderer]# cat /proc/cpuinfo | grep -i "model name"
model name : Intel(R) Pentium(R) 4 CPU 3.06GHz
[root@Dell wanderer]# cat /proc/cpuinfo | grep -i "cpu mhz"
cpu MHz : 3049.543
[root@Dell wanderer]# cat /proc/meminfo | grep -i memtotal
MemTotal: 773908 kB
[root@Dell wanderer]# cat /proc/meminfo | grep -i swaptotal
SwapTotal: 506008 kB
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking Devices
Checking Devices
[root@Dell wanderer]# ls -l /dev | egrep -i dsp\|sound
lr-xr-xr-x 1 root root 13 Jan 24 06:49 admmidi -> sound/admmidi
lr-xr-xr-x 1 root root 10 Jan 24 06:49 adsp -> sound/adsp
lr-xr-xr-x 1 root root 11 Jan 24 06:49 amidi -> sound/amidi
lr-xr-xr-x 1 root root 12 Jan 24 06:49 dmmidi -> sound/dmmidi
lr-xr-xr-x 1 root root 9 Jan 24 06:49 dsp -> sound/dsp
lr-xr-xr-x 1 root root 10 Jan 24 06:49 midi -> sound/midi
lr-xr-xr-x 1 root root 11 Jan 24 06:49 mixer -> sound/mixer
drwxr-xr-x 1 root root 0 Dec 31 1969 sound/
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking Driver
Checking Driver
[root@Dell wanderer]# if test -x /usr/bin/lspcidrake ; then
> lspcidrake -v | egrep -i "(audio|multimedia|host bridge)"
> else
> lspci -v | egrep -i "(audio|multimedia|host bridge)"
> fi
agpgart : Intel Corporation|82850 850 (Tehama) Chipset Host Bridge (MCH) [BRIDGE_HOST] (vendor:8086 device:2530 subv:1028 subd:0145)
snd-emu10k1 : Creative Labs|[SB Live! Value] EMU10k1X [MULTIMEDIA_AUDIO] (vendor:1102 device:0006 subv:1102 subd:1003)
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking Actual Driver in Use "(/etc/modules.conf)"
Checking Actual Driver in Use (/etc/modules.conf)
[root@Dell wanderer]# if test -f /etc/modules.conf ; then
> cat /etc/modules.conf | egrep -i snd\|sound
> else
> echo Test not available on this system
> fi
alias sound-slot-0 snd-emu10k1
above snd-emu10k1 snd-pcm-oss
above snd-sb16 snd-pcm-oss
above snd-sbawe snd-pcm-oss
above snd-sgalaxy snd-pcm-oss
[root@Dell wanderer]#
[root@Dell wanderer]# if test -d /proc/asound ; then
> echo
> echo Checking alsa /proc/asound
> cat /proc/asound/{version,cards,devices,hwdep,pcm}
> fi

Checking alsa /proc/asound
Advanced Linux Sound Architecture Driver Version 0.9.6.
Compiled on Sep 18 2003 for kernel 2.4.22-10mdk with versioned symbols.
0 [Live ]: EMU10K1 - Sound Blaster Live!
Sound Blaster Live! (rev.0) at 0xec40, irq 18
0: [0- 0]: ctl
4: [0- 0]: hardware dependent
8: [0- 0]: raw midi
19: [0- 3]: digital audio playback
26: [0- 2]: digital audio capture
25: [0- 1]: digital audio capture
16: [0- 0]: digital audio playback
24: [0- 0]: digital audio capture
1: : sequencer
9: [0- 1]: raw midi
10: [0- 2]: raw midi
33: : timer
00-00: EMU10K1 (FX8010)
00-00: emu10k1 : EMU10K1 : playback 32 : capture 1
00-01: emu10k1 mic : EMU10K1 MIC : capture 1
00-02: emu10k1 efx : EMU10K1 EFX : capture 1
00-03: emu10k1 : EMU10K1 FX8010 : playback 8
[root@Dell wanderer]#
[root@Dell wanderer]# if test -d /dev/snd ; then
> echo
> echo Checking alsa /dev/snd
> ls --color=none /dev/snd
> fi

Checking alsa /dev/snd
controlC0 controlC3 controlC6 midiC0D0 pcmC0D0c pcmC0D2c timer
controlC1 controlC4 controlC7 midiC0D1 pcmC0D0p pcmC0D3p
controlC2 controlC5 hwC0D0 midiC0D2 pcmC0D1c seq
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking if Module Loaded
Checking if Module Loaded
[root@Dell wanderer]# /sbin/lsmod | egrep -i snd\|sound\|audio\|game
snd-seq-midi 5056 0 (autoclean) (unused)
snd-emu10k1-synth 5276 0 (autoclean) (unused)
snd-emux-synth 31900 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 6924 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 4588 0 (autoclean) [snd-emux-synth]
snd-seq-oss 32000 0 (unused)
snd-seq-midi-event 6080 0 [snd-seq-midi snd-seq-virmidi snd-seq-oss]
snd-seq 42544 2 [snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-oss snd-seq-midi-event]
snd-pcm-oss 43652 1
snd-mixer-oss 14200 0 [snd-pcm-oss]
snd-emu10k1 70948 3 [snd-emu10k1-synth]
snd-pcm 79588 0 [snd-pcm-oss snd-emu10k1]
snd-timer 18436 0 [snd-seq snd-pcm]
snd-page-alloc 9044 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 17760 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-util-mem 3040 0 [snd-emux-synth snd-emu10k1]
snd-seq-device 5832 0 [snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq-oss snd-seq snd-emu10k1 snd-rawmidi]
snd-hwdep 6304 0 [snd-emu10k1]
snd-ac97-codec 45720 0 [snd-emu10k1]
snd 41380 2 [snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-rawmidi snd-util-mem snd-seq-device snd-hwdep snd-ac97-codec]
soundcore 6340 0 [snd]
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking if services configured to be run on initlevel 3
Checking if services configured to be run on initlevel 3
[root@Dell wanderer]# if test -x /sbin/chkconfig ; then
> echo Checking if Sound services configured
> /sbin/chkconfig --list sound
>
> echo
> echo Checking if Alsa service configured
> /sbin/chkconfig --list alsa
> else
> echo Test not available on this system
> fi
Checking if Sound services configured
sound 0: Off 1: Off 2: On 3: On 4: On 5: On 6: Off

Checking if Alsa service configured
alsa 0: Off 1: Off 2: On 3: On 4: On 5: On 6: Off
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking if Sound Volume muted
Checking if Sound Volume muted
[root@Dell wanderer]# if test -x /usr/bin/aumix ; then
> aumix -q
> else
> echo Test not available on this system
> fi
Test not available on this system
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking artsd setup
Checking artsd setup
[root@Dell wanderer]# ps -A -f | grep -i artsd | grep -v grep
wanderer 9088 4015 0 09:46 ? 00:00:00 /usr/bin/artsd -F 10 -S 4096 -d -D /dev/dsp -s 1 -m artsmessage -l 3 -f
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo Checking which program uses the sound card or cdrom
Checking which program uses the sound card or cdrom
[root@Dell wanderer]# if test -x /sbin/fuser ; then
> /sbin/fuser -v /dev/dsp
> /sbin/fuser -v /dev/cdrom
> else
> /bin/fuser -v /dev/dsp
> /bin/fuser -v /dev/cdrom
> fi

USER PID ACCESS COMMAND
/dev/dsp wanderer 9088 f.... artsd
[root@Dell wanderer]#
[root@Dell wanderer]# echo

[root@Dell wanderer]# echo End of Checks
End of Checks
[root@Dell wanderer]# Checks

Thanks for your assistance!

ONEderer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound starts up as mute... seaking Linux - Newbie 12 10-18-2005 07:54 AM
Dell Inspiron 9200 Volume, Play, Mute Quick Buttons and Sound with Suse 9.3 elliotfuller Linux - Hardware 1 06-08-2005 10:38 PM
Es1869 Sound Card: Mute gani Slackware 15 09-26-2004 10:14 PM
mute sound alsa mixer - used to work TroelsSmit Linux - Newbie 4 09-02-2004 12:39 PM
Mute KDE startup sound? prompt Linux - Software 2 06-04-2004 03:33 PM


All times are GMT -5. The time now is 08:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration