Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 11-18-2005, 12:17 AM   #1
Senior Member
Registered: Mar 2002
Location: Los Angeles, CA
Distribution: Debian, Ubuntu
Posts: 1,334

Rep: Reputation: 51
Why is my load average so high when comp. is idle?

as reported by uptime:
load average: 3.08, 3.02, 3.01
as reported by top:
 09:44:07  up 2 days, 22:57,  3 users,  load average: 3.03, 3.01, 3.00
123 processes: 121 sleeping, 1 running, 1 zombie, 0 stopped
CPU0 states:   0.0% user   0.0% system    0.0% nice   0.0% iowait 100.0% idle
CPU1 states:   0.1% user   0.3% system    0.0% nice   0.0% iowait  99.1% idle
vmstat says:
   procs                      memory      swap          io     system      cpu
 r  b  w   swpd   free   buff  cache   si   so    bi    bo   in    cs us sy id
 0  3  0 111284  12840 197852 738904    0    1    70    52   41    47  1  4 11
man on vmstat say that the 'b' value is the number of processes in uninteruptable sleep, so I'm guessing that's where the load average of 3 is coming from - 3 processes waiting to do something... but what are they? why are they there? How can I find that info?

This machine just went down, btw, because of a raid card failure. The card is still in the machine, but not active (the array is not mounted). I wonder if this could have something to do with it?
Old 11-18-2005, 01:25 AM   #2
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,047
Blog Entries: 11

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
If the box was trying to write logs to a defunct RAID controller
that would be something that may put it into wait-state indeed.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Qmail problems - CPU load average rising too high xbaez Linux - Software 0 11-16-2005 01:23 PM
my Load Average is always 1.0 when processors are idle ouimet Linux - Hardware 2 12-15-2004 10:39 AM
RH8 Load Average High - No CPU Utilization jj91709 Red Hat 2 08-29-2004 01:28 AM
High load - but CPU 99% idle? Boss Hoss Linux - Hardware 6 05-24-2004 05:39 AM
High idle cpu load in 2.6.4? geekzen Linux - General 4 04-10-2004 12:54 PM

All times are GMT -5. The time now is 10:10 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration