LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Where to find the gpg keys for repos (http://www.linuxquestions.org/questions/linux-general-1/where-to-find-the-gpg-keys-for-repos-272851/)

spicyohaggis 01-02-2005 04:51 AM

Where to find the gpg keys for repos
 
I just installed FC3 on my system again and wanted to expand my yum repos. I have all of the repos recognized/enabled through yum, yet whenever I try to update I am asked for the public.gpg.key.

The list of repos is available from this site:
http://www.fedorafaq.org/samples/yum.conf

I don't quite know what to do with the public.gpg.key. Would I have to install??/enable??/config?? each individual one for each repo?? And does anyone know where these gpg keys are? Where should I put them if I do download them? yum folder?

I did a "yum search public.gpg.key" to see if it would return with anything, but I get :

[root@localhost ~]# yum search public.gpg.key
Searching Packages:
Setting up Repo: dries
repomd.xml 100% |=========================| 951 B 00:00
** THE REMAINDER OF THE REPOS GET SET UP**
Reading repository metadata in from local files
dries : ################################################## 622/622
**AGAIN THE REMAINDER OF THE REPOS GET READ**
freshrpms-release.noarch 1-1.1.fc3.rf dag
Matched from:
Freshrpms.net release file. This package also contains yum configuration to
use the freshrpms.net provided rpm packages, as well as the public gpg key
used to sign them.
**SAME THING EXCEPT IN THE FRESH-RPMS REPO**

[root@localhost ~]# yum update
You have enabled checking of packages via GPG keys. This is a good thing.
However, you do not have any GPG public keys installed. You need to download
the keys for packages you wish to install and install them.
You can do that by running the command:
rpm --import public.gpg.key
For more information contact your distribution or package provider.

[root@localhost ~]# rpm --import public.gpg.key
error: public.gpg.key: import read failed.


I have also gone into my yum.config file and have manually changed the gpgcheck to equal 0. Yet I still get the same response.
I can't find them in google or yahoo searches... and I looked around a bit before I posted this. I didn't see anything that addressed this "problem" though. So sorry if it's redundant!

Is there some way to override the gpgcheck??
What am I doing wrong? Ack!

-Spicy-o-Haggis

homey 01-02-2005 02:42 PM

You should have the keys on your system which will work for base and updates, in /usr/share/rhn
rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora

When I setup an new type of repo like livna, then I imported the GPG-Key for livna with this command:
rpm --import http://rpm.livna.org/RPM-LIVNA-GPG-KEY


All times are GMT -5. The time now is 09:07 PM.