LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 04-04-2006, 06:22 PM   #1
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Rep: Reputation: 15
when I use ftp://user@ftp.blah.com it works. But when I type just ftp.blah.com says..


vsftpd
FedoraCore4

I set up an ftp server using vsftpd. Everything's working fine except for one minor detail.
In my browsers, I type:
ftp://user@ftp.whatever.com
ftp://user@ip_address
They work, and I'm prompted for a password. Then I'm in.
but
When I try just this in the browser... "ftp.whatever.com" then it should prompt me for a user name and password, but it doesn't. It just says anonymous logins are not allowed. You do not have permission to access this directory.

What can I add, or remove from the vsftpd.conf file to resolve this issue??

Because users just want to type ftp.whatever.com and be prompted. It just confuses them when they have to put ftp://user@ftp.whatever.com... or even the ip address.

Please help!

Thanks!
 
Old 04-06-2006, 04:54 AM   #2
livewire98801
Member
 
Registered: Jun 2004
Location: Seattle, WA
Distribution: Fedora 3/5, Mdk 10, FlavorOfTheWeek
Posts: 77

Rep: Reputation: 15
Anytime I've run into this before, it's been a browser issue. The browser is trying to authenticate as 'anonymous' by default, and you have anonymous access turned off.

I just did a little testing on my machine, and Firefox 1.0.7 is trying anonymous and giving up when it gets the 530 authentication error while Opera 8.5 is displayig the user/pass dialog when it gets the error. I couldn't find a setting in FF to prompt for username, but a newer version might have it in the menus.

Maybe I'm missing something, but /etc/vsftpd/vsftpd.conf is pretty well commented.

Good luck
 
Old 04-06-2006, 05:07 AM   #3
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Maybe
http://fireftp.mozdev.org/
helps you too.
 
Old 04-06-2006, 09:23 AM   #4
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
Thanks for the replies.
Unfortunately non-technical users and customers don't want to install extra things. I'm sure if proftpd and several others can do it then vsftpd can too.
I just have to find or figure out a solution.


Thanks
 
Old 04-06-2006, 09:44 AM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
I think Livewire gave you the right answer.. Browsers authenticate as anonymous by deafult uniless you tell them otherwise.

There are other options..

- Setup the FTP for anonymous access, (you didn't specify if the information had to be secure or not.. ftp isn't that secure to begin with..)
- Embed the username in the ftp link, then customer simply has to provide password..
- Put files on a secured web page, allow users to download of files from the secured site via http.
- Use a real FTP client or better yet a SFTP client and SFTPD to serve the files..

just because a web browser can access a ftp site certainly doesn't make it the best tool for the job.


Quote:
To connect to a FTP server requiring a username with Internet Explorer,

1. Open Internet Explorer
2. In the address bar, type the ftp address such as ftp://ftp.xyz.com
3. Dismiss any error dialogs if needed.
4. From the File menu, select Login As …
5. In the Log On As dialog, type your username and password.
6. Click Log On.
For Firefox you must specify the usernam in the URL..
 
Old 04-06-2006, 02:51 PM   #6
livewire98801
Member
 
Registered: Jun 2004
Location: Seattle, WA
Distribution: Fedora 3/5, Mdk 10, FlavorOfTheWeek
Posts: 77

Rep: Reputation: 15
Another thing you might want to consider is setting up a webserver. A little research would let you set up httpd with password authentication. Unless you are posting paticularly large files, this would probably work the best for people downloading.

Using web browsers for FTP is never the best solution. I've found that it's easier to use the commandline half the time. FireFTP is a good integrated client, as mentioned above, and there's CoreFTP for the people that refuse to leave IE.

Also, I use vsftpd right now, but I used proftpd for a long time before, and I remember the same problem then. I could be wrong, but I don't think the server handles what you're trying to do. If I am wrong, let me know

Good luck.

Last edited by livewire98801; 04-06-2006 at 02:54 PM.
 
Old 04-06-2006, 03:46 PM   #7
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
Yeah, proftpd would prompt the user with a userid and password box if the user just used "ftp.whatever.com". Even if anonymous was turned off.

Thanks.
 
Old 04-06-2006, 03:54 PM   #8
livewire98801
Member
 
Registered: Jun 2004
Location: Seattle, WA
Distribution: Fedora 3/5, Mdk 10, FlavorOfTheWeek
Posts: 77

Rep: Reputation: 15
Hmm, sounds like thats your solution then. I honestly don't remember it doing that for me, but I do remember I liked ProFTPd a lot more. I had to quit using it because it quit authenticating, and I couln't figure out why.

I still like my webserver though I don't have password authentication set up, but that should be a simple matter of generating an .htaccess file, and it's a whole lot easier to manage. And it's easier to set it up so that you don't have to have a user account set up on the system to make it work, you don't have to worry about setting up chroot cells, etc.

If ProFTPd does what you want, lemme know. I'm all curious now. . .
 
Old 04-07-2006, 01:49 AM   #9
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
@hunterhunter, I doubt the ftp server has anything to do with it.
From my experience, it's indeed the browser that decides which username to use as default and they
often like to use "anonymous" for that.
 
Old 04-07-2006, 01:57 PM   #10
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
I actually like vsftpd better now... Much more simple.

As for browsers deciding which name to send yes it's true. However, vsftpd should atleast give the option to type in a user name and password.
 
Old 05-16-2006, 04:18 AM   #11
ythevenot
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Rep: Reputation: 0
hi,
does anybody has the answer for this?
I have the same problem, i just switched a windows FTP server to linux and now uses vsftpd. It was before working fine (with different browser internet explorer and firefox for example), ie asking for username and password. However since we installed vsftp it does not work (either from internet explorer or firefox), ie it does not ask for username and password but gives you an error message that anonymous connections are not allowed.
I have another box running with vsftpd and it is working fine. it seems the VSFTP configuration is the same however the new box is running the latest version of vsftpd. The pam.d vsftpd file is different however. could this be the problem?

Thanks for any help,
kind regards,
Yannick
 
Old 05-16-2006, 05:00 AM   #12
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
The PAM configuration can indeed play a role, as it is used by vsftpd to authenticate users, in conjunction
with the vsftpd config.

You could always try enabling the anonymous user in the vsftpd config. But please note that this has
quite a few security implications and you should provide a reliable configuration in vsftp wrt the anonymous user (ie don't allow him to change/update/delete anything).
 
Old 05-16-2006, 11:36 AM   #13
hunterhunter
Member
 
Registered: Nov 2005
Posts: 90

Original Poster
Rep: Reputation: 15
Solved

The guy who writes vsftpd took that feature out of this build for some reason. In previous builds it however, did throw a prompt onto the screen regardless of which browser was used.


Thanks for the help though!
 
Old 05-16-2006, 11:44 PM   #14
ythevenot
LQ Newbie
 
Registered: Oct 2003
Posts: 12

Rep: Reputation: 0
Hi all,

Thanks for your help,
we'll look at installing the previous build of vsftpd or another FTP server.

regards,
Yannick
 
Old 07-17-2006, 06:11 PM   #15
eviser
LQ Newbie
 
Registered: Mar 2006
Distribution: Red Hat 9
Posts: 7

Rep: Reputation: 0
I suffered the same issue as you, only I didn't make any changes to vsftpd before this started occuring (it worked fine for months). I narrowed it down to a bad GPO push which screwed up some of the settings in IE. I went to Tools-->Internet Options--Advanced (tab). Under the "Browsing" section, I enabled the "Enable folder view for FTP sites" checkbox and everything went right back to normal... Strange, but it worked.

Last edited by eviser; 07-17-2006 at 06:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dynamic SVG (php) on firefox: this XML blah blah eantoranz Programming 1 03-17-2006 11:58 AM
Bad Display Name balh.blah.blah.com in remove command 0.o *BSD 2 12-08-2004 01:37 PM
Expanding file names in a script? ../blah -> /home/blah Bebo Linux - General 24 03-29-2004 05:39 PM
ln -s smbspool /blah/blah/hugh? wlfdgcrkz Linux - Networking 0 06-24-2003 12:29 AM
newbie issues....kernel panic: blah blah blah Rio Nishida Slackware 16 11-29-2002 12:08 AM


All times are GMT -5. The time now is 01:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration